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À mon informaticiennne préférée et épouse LUZ,  
Merci pour sa patience 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Préface 
 
 
 
Ce petit document a pour but d'accompagner le lecteur dans une visite approfondie du logiciel BLENDER 
(Version 7.9). La méthode utilisée, sauf dans les tout premiers chapitres, réside dans des exercices qui 
conduisent à une "petite" réalisation d'un projet, aucours de laquelle, on apprend de nouvelles notions qui sont 
énoncées dans le sous titre du chapitre.  
Pour cela il a fallu mettre au point un "langage écrit" de description des actions de l'utilisateur sur l'interface du 
logiciel. Ce "language" pourra paraitre lourd au début, mais c'est le seul moyen trouvé pour que l'utilisateur ne se 
pose pas toujours la question "...mais où faut-il cliquer pour réaliser telle action ?" Il est entièrement décrit dans le 
chapitre 1, et une petite vidéo d'accompagnement montre son fonctionnement. Il est vivement conseillé de 
consulter ces deux aides pour une meilleure lecture des execices d'initiation.  
Bien sûr , si on le désire on peut rentrer directement dans le chapitre 2 et revenir plus tardivement au chapitre 1. 
 
Bonne lecture. 
 
 

Alain FOURNIER 
Septembre 2019 
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1. Descriptif de l’écran d’interface BLENDER 

Pour une analyse de la description en vue de l’utilisation de l’interface de Blender :  
Mise en place d’une syntaxe descriptive écrite en langage structuré par une grammaire des « actions  
utilisateur ».  
CONSEIL : Ce chapitre assez théorique est lourd et difficile, il faut prendre son temps , ne pas se décourager et 
avoir en permanence le logiciel actif sur un ordinateur pourvoir, tester… Il aidera le lecteur dans les explications 
des tutoriels qui sont décrits dans les chapitres suivants  
 
Remarque Préliminaire de Mécanique Classique: Ce que l’on appellera dans la suite l’univers visualisé dans 
Blender  en abrégé le « Monde de Blender » est un espace couramment appelé à Trois Dimensions. Ce qu’il 
faut comprendre c’est que chaque objet est repéré dans cet espace relativement à un repère (Trièdre) dit 
« global » XYZ (Couleurs de convention : X = Rouge ; Y = Vert ; Z = Bleu , ce qui correspond au trois couleurs 
fondamentales RVB ou en anglais RGB d’affichage codage des couleurs des points d’écran ou pixels - mot issu 
de PICture-image et ELement) 
Par rapport à ce repère lors d’un déplacement, un objet3D (représentation d’un solide) est défini par rapport au 
repère globale par ses degrés de liberté à savoir : 

- la position (X,Y,Z) les trois nombres coordonnées de son centre (géométrique) 
- les trois angles de rotation (dits angles d’Euler) par rapport à chaque axe X,Y,Z : (RotX,RotY,RotZ)  

Son propre repère positionné en son centre géométrique  est appelé repère « local », il est distinct du repère 
« global » (voir figure ci-dessous – il est obtenu en appliquant le déplacement des coordonnées (X,Y,Z) dit de 
translation par rapport à l’origine et les rotations . (RotX,RotY,RotZ) sur chaque axe)  
Dans le Monde de Blender une « grille » représente une partie du plan dit « horizontal » (définit par les axes X-
rouge et Y- vert), l’intersection de ces deux axes est nommé le « centre du Monde » coordonnées (0,0,0), un 
carré de grille est un carré  de coté par convention = 1 unité blender , on verra par la suite que l’on peut choisir 
les unités qui nous conviennent le mieux, mètre , pouce , ….) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Repère « global » 

Repère « local » du Cube « Centre du Monde » 

Carré « unité Blender » 
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1.1. DESCRIPTIF  DU DÉTAILS DES PARTIES PAR DÉFAUT DE L’ECRAN D’INTERFACE-BLENDER  APPELÉES : PANNEAUX 

Vue éclatée à partir de l’écran Interface Blender au centre de l’étoile – (Voir commentaires page suivante) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

PANNEAU « INFO » réduit à sa BARRE des menus = 

ECRAN D’INTERFACE-BLENDER 

PANNEAU « TIME LINE »  et sa BARRE des menus 

SOUS-PANNEAU de Visualisation du défilement 

PANNEAU 3DVIEW et sa BARRE des menus 

SOUS-PANNEAU « N » SOUS-PANNEAU « T» 

SOUS-PANNEAU  
de  

Visualisation 3D 

PANNEAU « PROPERTIES » 
et sa BARRE des menus 

PANNEAU  « OUTLINER » 
et sa BARRE des menus 

SOUS-PANNEAU 
De visualisation 

Paramètrage 

SOUS-PANNEAU 
De visualisation 
Arborescence 

des Objets 
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Remarque sur la fonction des panneaux présentés par defaut à l’écran par Blender  (éclaté de l’écran par précédente)  
PanneauInfo :  Il contient l’interface classique avec le système d’exploitation (Linux, Windows, MacOs …), mais aussi le choix d’espace de travail spécifique , les 
types de moteur de rendu, des informations de versions de blender, utilisation de la mémoire vive, et aussi des propriétés des objets dans le monde de Blender,  
Panneau3DView : Il sert à visualiser le mode de tous les objets créés, mais aussi il permet d’agir directement sur eux à la souris (voir chapitre suivant) 
Panneau TimeLine : symbolise la ligne du temps d’une suite d’enregistrements d’images pour une animation, mais aussi permet d’agir sur l’animation  
Panneau Outliner : donne sous forme de structure arborescente l’ensemble des objets situés dans le monde de Blender, visibles dans le Panneau 3D View, il 
permet de les sélectionner par leur nom. 
Panneau Properties : donne les propriétés de l’objet sélectionné soit dans Panneau3DView soit dans Outliner 

1.2. DESCRIPTON : RÈGLES GÉNÉRALES DE FONCTIONNEMENT DE L’ INTERFACE BLENDER / UTILISATEUR: 

La disposition de la fenêtre de base de Blender  est un ensemble de panneaux  autour d’un grand panneau central qui visualise le 
« monde des objets » de Blender (voir représentation schématique ci-dessous).  

• Chaque panneau est associé à un type de travail dans Blender 
• Chaque  panneau  à l’exception des panneaux « T » et « N » (voir page suivante) est toujours composé d’une ligne 

supérieure ou inférieure appelée « BarreMenus » ,qui contient les commandes des actions correspondant  au type 
de travail, symbolisées sous forme de petit  dessin  appelé «  icône », et/ ou de nom en clair appelé « menu » 

• Chaque panneau d’un type peut être basculé dans un autre type par un clic gauche toujours sur  le premier icône 
de la Barre - CONVENTION :  Le nom du panneau sera : Panneau<Nom de l’icôneType> 

 
 
 
 
 
 
 
 

Correspondance dans BLENDER entre Icône de bascule et le type de panneau avec sa barre 
(nom-icônes des divers types de Panneaux correspondant au type de travail) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Attention ! les Panneaux et leurs Barres peuvent changer en fonctions des actions demandées !!! 

 
 

Panneau  
de représentation 

des commandes de la Barre 

  BarreMenus placée Haute 
Icône 

de 
Bascule de Type 

 
Panneau  

de représentation 
des commandes de la Barre 

   BarreMenus placée Basse 

Panneau « Info » réduit à sa Barre 

Barre du Panneau « 3DView » 

Panneau « Timeline » et sa Barre (en position basse) 

Menu déployé du premier icône de 
Type de la Barre 

Sous-panneau de visualisation 
Panneau «3DView » 

Icône – bascule = Info 
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1.3. DESCRIPTON DES CONTENUS DES SOUS-PANNEAUX LATÉRAUX 

(Définitions des éléments activables par l’action de l’utilisateur sur l’interface Blender) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Exemple de sous-panneaux latéraux ici les Panneaux nommés « PanneauT » et « PanneauN » et de leur contenus 
Notion de PARAGRAPHE ouvert ou fermé dans chaque Panneau 
L’action sur une case ou un bouton  induit un changement de l’organisation du panneau : ouverture d’un panneau nommé fenêtre dans 

la partie basse du Panneau. Dans cette fenêtre figure des paragraphes précédés du symbole «  » appelé pointeau, qui 
commande l’ouverture d’un affichage sous-jacent, qui présente le contenu correspondant au titre . 

 Pour  « ouvrir » un paragraphe on clique (gauche) sur ce pointeau : il devient «  ». Par convention dans la suite : « Paragraphe 
[nom] » désigne le contenu du paragraphe ouvert 
Typologie des zones activables :type BOUTON et CASE  
- Un bouton-poussoir est un petit rectangle contenant un nom qui peut être précédé d’un icône (petit dessin). un clic provoque son 
changement en inverse vidéo et exécute l’action associée 
 
 
- Un bouton est un petit rectangle d’un bandeau surmonté d’un titre, et contenant un nom. Un clic active une action et  qui peut 
changer sa couleur 
 
 
-Un bouton-menu est un petit rectangle contenant un nom et l’icône        sur son coté droit, son activation produit le déroulement d’un 
menu contextuel pour la sélection d’une entrée 
 
 
 
- Une case à coche  est un petit carré accolé à un titre, un clic sur le rectangle marque une coche et éclairage du nom. 
 

 
- Une case à saisie est un petit rectangle contenant éventuellement un nom suivi de deux points dans laquelle on peut entrer une 
valeur alphanumérique. 
 
- Une case à menu contextuel est un petit rectangle muni d’un titre qui contient un icône sur sa gauche, son activation produit le 
déroulement d’un menu contextuel contenant un choix d’entrées ; celle choisie restera inscrite dans la case 
 
 
 
 
 
 

PANNEAU 3DView sa BARRE basse 

SOUS-PANNEAU « N » SOUS-PANNEAU « T» 

SOUS-PANNEAU  
de  

Visualisation  
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1.4. UNE REPRESENTATION DES ACTIONS UTILISATEURS –NOTION DE CHAINE OPÉRATOIRE 

 
 
 
On appelle Chaine Opératoire : la suite de choix logiques effectuée  
par un utilisateur pour pointer avec la souris une région de l’interface. Cela correspond  
au parcours de la hiérarchie du plus grand contenant vers le plus petit contenu activable  
associé à l’action « voulue » 
Les deux exemples  sont les chaines opératoires correspondant aux deux actions 
(flèches grises) décrites sur la figure ci-contre : 
 - Action : cliquer sur le menu « View » dans la barre des menus du panneau Outliner 

- Action : clique le nom d’objet « Cube » dans la Liste des objets de la Scène  
représentés dans le Panneau Outliner 

Nous choisirons dans la suite : 
La représentation d’une chaine opératoire dans la suite utilisera :  
les DESCRIPTIONS LINEAIRES précisées au extrémités des flèches grises 
dont la GRAMMAIRE  va être préciser dans les paragraphes suivants ; 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

PanneauOutliner  > BarreMenus > Menu = « View » < clic 
 

DESCRIPTION LINEAIRE 

CHAINES OPERATOIRES 

AVERTISSEMENT ! 
 

Ce qui est exposé dans la suite présuppose que le lecteur accepte : 
 

• De scruter attentivement l’écran en identifiant CHAQUE PANNEAU, et pour ce panneau : repérer SA 
BARRE DES MENUS et SURTOUT dans celle-ci son premier icône dit ICÔNE DE TYPE 

• De connaître le mieux possible les localisations des panneaux et leur nom dans l’écran de Blender ! 
(contenus de la page 3 fin du paragraphe 1.1-Remarque sur les fonctions des panneaux) 

DEPART 

BarreMenus  

Menu 

Liste 

PanneauOutliner  > Liste > Nom =« Cube » < clic 

DESCRIPTION LINEAIRE 

PanneauOutliner 
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BarreMenus (positionnée en Haut) 
Du PanneauInfo 
 

BarreMenus (positionnée en Bas) 
Du Panneau3DView 

BarreMenus(positionnée en Bas) 
Du  PanneauTimeLine 

1.5. ACTIONS SUR UNE BARRE D’UN PANNEAU ET LEURS DESCRIPTIONS SOUS FORMES DE PHRASES SYMBOLIQUES 

(GRAMMAIRE associée à l’ ACTION) 
 
Dans la suite il sera utilisé les notations suivantes pour désigner une action à partir de la barre des menus d’un panneau de l’interface 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• GRAMMAIRE DES ÉCRITURES D’ACTION SUR L’INTERFACE : BARRE DES MENUS 
CONVENTION : les caractères en gras sont les invariants, les caractères normaux les variables 
Action : utiliser une entrée ou sous entrée d’un menu d’une barre des menus haute ou basse d’un panneau  
 
GRAMMAIRE :  
Panneau[nom_IcôneType] > BarreMenus > Menu = [nom de Menu] > Entrée = [nom d’Entrée] > SousEntrée = [nom Sous_Entrée] 
 
Exemple et explications:  
Action : Cliquer sur l’entrée New du menu File du panneau Info 
S’écrit 
PanneauInfo > BarreMenus > Menu=File > Entrée=New < clic 
 
On peut décomposer le chronologie de la phrase de l’action par : 
D’abord on clique sur PanneauInfo > BarreMenus > Menu=File  
ce qui produit l’ouverture de la liste verticale des entrées de ce menu 
Puis Menu=File > Entrée=New < clic on déplace la souris dans la liste  
et on clique dans cette liste sur l’entrée New  
 
 
Autres Exemples : 
Action : Ouvrir le menu Add de la barre des menus du Panneau3DView 
S’écrit 
Panneau3DView > BarreMenus > Menu=Add < clic  
Correspond à agir ici 
 
 
Action : Cliquer la S-entrée Ball de l’entrée Metaball du menu Add   
S’écrit 
Panneau3DView > BarreMenus > Menu=Add> Entrée=Metaball > SousEntrée=Ball < clic ….  Correspond à agir ici 
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PANNEAU DROIT HAUT 

SOUS-PANNEAU VISUALISATION (Arborescence objets) 
 

1.6. EXEMPLES D’ACTIONS UTILISATEUR AVEC SOURIS  SUR LE PANNEAU DROITHAUT DE L’ECRAN D’INTERFACE-BLENDER 
ET LEURS DESCRIPTIONS SOUS FORME DE PHRASES SYMBOLIQUES 

Remarque : Dans la figure ci-dessous, chaque action sur l’interface est indiquée par une flêche, est décrite par la chaine opératoire correspondante.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

BARRE (menus,icônes) Action : Choisir l’entrée « Complete Matches Only » du menu 
« Search » 
 
 

Action : Sélectionner l’objet « Cube » dans la « Scene »  

Action : Afficher ou Cacher l’objet « Cube » dans la « Scene » 
 

Visualisation logique des 
contenus affichés par Blender 

Action : Déplier l’arborescence des « Objets » de la « Scène » 

Action : Interdire (fixer) ou liberer la manipulation de l’objet « Cube » dans la « Scene » 

PanneauOutliner > Liste = « Scene» > Icône  = « Objet-Cube » > Case= « Fixation » < clic 

 
Action : En mode RENDU UNIQUEMENTAfficher ou Cacher l’objet « Cube » dans la « Scene » 

PanneauOutliner > Liste = « Scene» > Icône  = « Objet-Cube » > Case= « Rendu» < clic 

PanneauOutliner> BarreMenus> Menu = [Search] > Entrée= [Complete Matches Only] 
 

PanneauOutliner > Liste = « Scene» > Icône  = «Objet- Cube » < clic 

 

PanneauOutliner> Liste= « Scene » > Icône= « + » < clic 
 

PanneauOutliner > Liste = « Scene» > Icône  = « Objet-Cube » > Case= « Affichage » < clic 

 
Vocabulaire Blender asocié aux 
propriétés de l’affichage d’un objet: 
Icône case d’affichage 
  
Icône case de fixation 
 
Icône case de rendu 
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1.7. EXEMPLES D’ACTIONS UTILISATEUR AVEC SOURIS SUR LE PANNEAU DROITBAS DE L’ECRAN D’INTERFACE-BLENDER 
ET LEURS DESCRIPTIONS SOUS FORME DE PHRASES SYMBOLIQUES (SELON LA GRAMMAIRE) 

 
 
 
 
 
 
Remarque : les actions suivantes présupposent que l’on a exécuté l’action précédente (choix du rendu !) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Action : Dans le Paragraphe « Anti-Aliasing » Cocher la case « Anti-Aliasing » 

PANNEAU DROIT 

SOUS-PANNEAU VISUALISATION (Paramétrage) 
 

BARRE (Icônes) 

Action : Dans le Paragraphe « Output » Aller Chercher un Dossier  

Action : Dans le Paragraphe « Performance » Entrer la valeur « 64 » dans la Case « Title Size X : » 

Action : Dans le Paragraphe « Anti-Aliasing » Cocher la case « 8 » 

Action : Cliquer sur  l’icône « RENDU » de la Barre Haute 
Résultat >OUVERTURE DU PANNEAU SOUS-JACENT BAS Répartition schématique  

des surfaces affichées 

PanneauProperties > Paragraphe = [Performance] > Case = [Title Size Y : ] < 64  
 

PanneauProperties > Paragraphe = [Output] > Icône = [Fichiers] > Entrée = [ Nom Dossier ] 
 

PanneauProperties > BarreIcones>Icône = [RENDU] < clic 
 

PanneauProperties> Paragraphe= [Anti-Aliasing] > Case = [Anti-Aliasing] < clic 
 

PanneauProperties> Paragraphe= [Anti-Aliasing] > Case = [8] < clic 
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1.8. ACTIONS UTILISATEUR AVEC SOURIS SUR LES PANNEAUX GAUCHE DIT « PANNEAUT »  DE L’ECRAN D’INTERFACE-BLENDER 
ET LEURS DESCRIPTIONS SOUS FORME DE PHRASES SYMBOLIQUES (SELON UNE  GRAMMAIRE) 

• AFFICHER OU CACHER LE PANNEAU GAUCHE T (POUR TRANSFORMATIONS) 
Il suffit de positionner le pointeur de la souris sur le Panneau de la Vue 3DView (en général au centre de l’écran ) et d’appuyer sur la touche « T »  d’où son nom : PanneauT 
• NOTION D’0NGLET DU  PANNEAUT. 

Sur le coté droit de la zone verticale du PanneauT sont disposés des petites excroissances rectangulaires contenant des noms verticaux : les onglets (comme pour des séparateurs de dossiers), 
chaque onglet correspond à un affichage spécifique dans le PanneauT qui contient les boutons, icônes, cases, listes …. associés au type de travail spécifié par le nom de l’onglet. 
Ainsi le début d’une action dans le PanneauT, correspond d’abord  à un choix d’Onglet :  qui provoque dans le PanneauT l’affichage spécifique des activables (boutons, cases …). Ainsi dans 
l’exemple suivant :  

PanneauT > Onglet = [nom onglet] > Bouton = [nom bouton]   est le début de PHRASE de la GRAMMAIRE de la description d’une action générale d’ un Bouton du PanneauT 
Cette action peut déclencher l’ouverture d’un panneau bas (affichage d’un sous panneau appelé souvent Panneau Éphémère )) dont le titre est le nom du bouton activé utilisé aussi pour un 
paragraphe. Cela permet alors de paramétrer l’action :  on écrira à la suite : 

> Paragraphe = [nom bouton] > Case = [nom case] < [valeur] ou coche ou clic 
D’où on obtient la phrase complète  (GRAMMAIRE) 
PanneauT > Onglet = [nom onglet] > Bouton=[nom bouton] > Paragraphe = [nom bouton] > Case = [nom case] < [valeur] ou coche ou clic 

 
Que l’on peut écrire  aussi en utilisant deux lignes mais  en respectant indentation : 

PanneauT > Onglet = [nom onglet] > Bouton=[nom bouton] 
 >Paragraphe = [nom bouton] > Case = [nom case] < [valeur] ou coche ou clic 

 
Exemple d’application d’une PHRASE DE GRAMMAIRE dans un cas particulier. 
L’action : PanneauT > Onglet = Tools > Bouton = Subdivide   fait apparaître dans un sous panneau coulissant contenant (voir manette latérale droite) le  « Paragraphe Ephemère » de titre 
Subdivide, qui donne les paramètres de l’opérateur Subdivide, dans lequel une case à contenu numérique indique le nombre de divisions voulues d’où l’action complète décrite par : 

PanneauT > Onglet = Tools > Bouton = Subdivide > ParagrapheEphemère = Subdivide > Case = NumbOfCuts<1 
…. Correspond à la figure ci-contre extraite du panneau gauche T 
 
 
 
 
 
 
GRAMMAIRE > Cas d’une Case ou Bouton à cocher ou cliquer  
 
PanneauT > Onglet = [nom onglet] > Bouton =[nom bouton] > Paragraphe = [nom bouton] > Case = [nom case] < coche ou clic 
PanneauT> Onglet = [nom onglet] > Bouton =[nom bouton] > Paragraphe = [nom bouton] > Bouton = [nom bouton] < clic 
 
GRAMMAIRE > Cas d’une Case ou Bouton à menu contextuel  
 
PanneauT > Onglet = [nom onglet] > Bouton =[nom bouton] > Paragraphe = [nom bouton] > Bouton = [nom bouton] > Entrée = [nom entrée] 
PanneauT > Onglet = [nom onglet] > Bouton =[nom bouton] > Paragraphe = [nom bouton] > Case = [nom case] > Entrée = [nom entrée] 

 

L’activation du bouton Subdivide  
produit l’ouverture  du sous panneau bas PanneauEphemere 
qui contient le Paragraphe ouvert Subdivide  
qui contient la case NumbOfCuts 

Manette de coulissage verticale du panneau 
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1.9. EXEMPLE D’APPLICATION DE LA PRÉCÉDENTE GRAMMAIRE DES PHRASES, DÉCRIVANT DES ACTIONS SUR DES CAS PARTICULIERS  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

PANNEAU GAUCHE « T » 

 
E

N
S

E
M

B
L
E

 D
E

S
 O

N
G

L
E

T
S

 

V

Action : Dans le paragraphe « Transform » de l’onglet « Tools » Cliquer sur le  bouton « Set Origin » 
Dans le menu contextuel choisir entrée «  Origin to Geometry »  

PanneauT > Onglet = « Tools » > Paragraphe = « Edit » > Bouton = « Set Origin »  
> Entrée « Origin to Geometrie » < clic 

 

Action : Dans le paragraphe « Rotate » de l’onglet « Tools » Cocher la case « Contraint Axis - X»  

PanneauT > Onglet = « Tools » > Paragraphe=  « Rotate » > Case  = « Containt Axis- X »  < clic ou coche 
 

Action : Dans le paragraphe « Transform » de l’onglet « Tools » Cliquer sur le  bouton « Rotate » 
pour faire une rotation de « paramètre »  angle = -36,4° 

PanneauT > Onglet = « Tools » > Paragraphe = « Transform » > Bouton = « Rotate » 
 > Paragraphe =«  Rotate » > Case Angle < “-36.4°” 
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2. Interface « Monde de Blender »/ « Monde de l’utilisateur » 

Pré requis :  On suppose ici que la description de l’écran et le vocabulaire écrit des actions a été étudié dans le 
Chapitre précédent : « Descriptif de l’écran d’interface deBLENDER » 
Remarque : il est important de choisir dans le PanneauInfo dans la case précisée sur la figure par un clic le nom 
« CyclesRender » !!!! (C’est le choix d’une fonction qui permet les affichages « réalistes » en temps réel à l’écran, 
on appelle cela un « moteur de rendu » !!) 
 
 
 
 

2.1. SE POSITIONNER PAR RAPPORT A UN OBJET DANS LA FENÊTRE SCENE DU PANNEAU 3DVIEW 

Remarque préliminaire : Dans ce paragraphe CE NE SONT PAS LES OBJETS QUI BOUGENT c’est NOUS 
QUI BOUGEONS PAR RAPPORT AUX OBJETS (principe de la caméra). 

• ACTION : DÉPLACER LA VUE EN ROTATION  
D’ABORD Pointer la souris sur la SCENE 
ENFIN Appuyer sur la molette centrale de la souris et maintenir en déplaçant celle-ci (ici autour du cube). 
 
 
 
 
 
 
 
 
 
 
 
 
 

• ACTION : DÉPLACER LA VUE EN TRANSLATION 
D’ABORD Pointer la souris sur la SCENE 
PUIS  Appuyer simultanément sur la touche [Maj] et sur la molette de la souris, et maintenir en se déplaçant  
 
 
 
 
 
 
 
 
 
 
 
 

• ACTION : ZOOMER, DEZOOMER SUR LA VUE  
D’ABORD Pointer la souris sur la SCENE 
PUIS  Faire rouler la molette de la souris dans un sens ou l’autre pour avancer ou reculer 

Mettre le Moteur de rendu sur  [Cycles Render] 

Pointeur 
écran  
de la 
souris 

« Monde de l’utilisateur » « Monde de BLENDER» 

ATTENTION ! 
Ces flèches indiquent un 

pivotement de la VUE  
pas du CUBE !!!! 

ATTENTION ! 
Ces flèches indiquent un 

glissement de la VUE  
pas du CUBE !!!! 

« Monde de l’utilisateur » « Monde de BLENDER» 

Touche majuscule 
du clavier 
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2.2. MANIPULER DES OBJETS 3D DANS LA FENÊTRE SCENE DU PANNEAU 3DVIEW 
• ACTION : SÉLECTIONNER UN OBJET 

D’ABORD Positionner la souris sur l’objet voulu  
PUIS  Cliquer le bouton gauche de la souris 
Résultat  : L’objet s’entoure d’un liseret jaune-orange  

• ACTION : DÉSÉLECTION D’UN OBJET 
Trois possibilités : soit Barre des menus basse > menu Select > Entrée = (de) select all ; 
soit la touche A ; soit cliquer sur un autre objet 

• REPÉRAGE DES OBJETS DANS L’ESPACE 3D DE BLENDER 
 Repère dit « global » de la SCENE : Référence en bas à gauche trièdre (x,y,z) (X=Rouge, Y= Vert, Z = 
Bleu) 
 Plan « horizontale XY» de référence est la Grille  
 Le « Centre du monde est intersection de l’axe rouge et axe vert  de la grille» 
Règle : Si l’objet est sélectionné : Repère « global »  est dupliqué sur le CG de l’objet  
 
Remarque : En cas de disparition repère: Menu Bas > Icône du repère désactivé > cliquer pour activer (cf figure) 
 
  

Sauvetage : Après des manipulations on perd le centre de rotation de la scène / objet   > Récupérer le 
centre de rotation de la scène au centre de l’objet : sélectionner l’objet et taper Touche « . » du clavier numérique 
 

• SUPPRIMER DES OBJETS 3D DANS LA FENÊTRE SCENE 
Remarque préliminaire : Par defaut blender présente à l’ouverture : une scène contenant : un cube, une lampe, 
une caméra 
D’ABORD Sélectionner l’objet  
PUIS  Panneau3DView > BarreMenusBasse > menu = Object > entrée = Delete  (touche [X] raccourci) 
Résultat : Menu contextuel de confirmation < clic 
 

• AJOUTER UN OBJET DIT « PRIMITIF » À LA SCÈNE 
Localiser le point d’insertion des objets : appelé  curseur (cf figure) 
 REGLE : le curseur est l’endroit où tout nouvel objet est implanté 
donc 
D’ABORD Positionner l’endroit de la scène où l’objet doit être ajouter 

- NON CONSEILLÉE : Sélection libre de la position du curseur = clique droit de la souris 
- CONSEILLÉE : Sélection référencée de la position du curseur au centre du monde :  

   Majuscule + « S » > Menu contextuel « Snap » (faire coincider, aligner)> Entrée :Cursor to center 
PUIS  Ajouter un objet à la position du curseur 
 Panneau3DView > BarreMenusBasse  Première barre des menus basse > menu=Add > entrée=Mesh 
(maillage)> sousEntrée (auchoix) 
 

• VISUALISATION ET UTILISATION DES « POIGNÉES » PAR BARRE DES MENUS BASSE 
Remarque préliminaire : Blender propose des « manettes à poignées » pour manipuler les objets (souvent 
appelées « widgets ») AVANT TOUTE ACTION : Sélectionner l’objet à manipuler et utiliser « les poignées » 
D’ABORD Panneau3DView > BarreMenus : on dispose de trois types de poignées, activables séparément ou en 
communs (voit figure) 
 
 
 
 
 
 
 
 
 
 
 

Bouton d’affichage du repère local de l’objet qui 
servira de « poignées » (widget) 

Poignées de « translation » 

Poignées de « rotation » 

Poignées de « mise à l’échelle » 

Représentation du widget 
sur l’objet selon le choix 
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PUIS  Pointer la souris sur une des extrémités du widget 
ENFIN  Appuyer sur le bouton gauche de la souris et maintenir en déplaçant celle-ci pour obtenir l’action 
voulue correspondante  sur l’objet comme nous allons le voir dans la suite. 
 
Remarque préliminaire : Dans la suite LES OBJETS NE GHANGENT PAS DE STRUCTURE GEOMETRIQUE 
(on ne modifie pas l’ossature (maillage, en anglais Mesh)  qui les composent restent invariants ). 
 

• TOURNER UN OBJET AUTOUR DES AXES DU REPÈRE-ROTATION : ACTION APPELÉE « R » 
Méthode 1- Souris 
D’ABORD Panneau3DView >BarreMenu > Icône = Arc de cercle (rotation) 
Résultat affichage de poignées circulaires qui permettent des rotations selon les axes de 
couleur (cercle rouge = Rot/X cercle vert = Rot/Y cercle bleu = Rot/Z) 
PUIS  Cliquer et déplacer en maintenant les cercles-poignées 
 
Méthode 2 – Clavier et souris 
D’ABORD Taper au clavier [ R ] ou [r]comme Rotation 
Résultat : position de la souris est reliée au centre de l’objet par un trait pointillé.  
PUIS  Déplacer la souris > Rotation de l’objet + Cliquer gauche quand la position convient 
Méthode 3 – Clavier 
Taper au clavier « R » + le nom de l’axe « X ou Y ou Z » +« La valeur en degré  de l’angle 
voulue "+ Enter 
Méthode 4 – Panneau « N » et Clavier 
PanneauN > Paragraphe = Transform > BarreCaseVertical = Rotation < ListeCase 
  Entrer les valeurs numériques voulues  selon les cases X, Y ou Z  
 

• DÉPLACER SELON LA DIRECTION DES AXES-TRANSLATION : ACTION APPELÉE « G » (ANGLAIS : GRABE) 
Méthode 1 – Souris 
D’ABORD Panneau3Dview > Barre menus Basse > Icône = Flèche (translation) 
PUIS  Cliquer et déplacer en maintenant les pointes des flèches-poignées du widget 
Résultat :  translation de l’objet selon les axes de couleur 
 
Méthode 2 – Clavier et souris 
D’ABORD Taper au la touche [G] ou [g] comme Grab (saisir en anglais) 
Résultat : la souris est liée d’une manière invisible à l’objet.  
PUIS  Déplacer la souris > l’objet suit la souris + Cliquer gauche quand la position convient 
Résultat : déplacement libre en translation de l’objet 
Méthode 3 – Clavier 
Taper au clavier « G » + le nom de l’axe « X ou Y ou Z » +« une valeur en carreaux de grille blender » + Enter 
Méthode 4 – Panneau « N » et Clavier 
Dans la Panneau « N » > Paragraphe = Transform > BarreCaseVertical = Location 
Entrer les valeurs numériques voulues selon les cases (coordonnées  du CG de l’objet)  X, Y ou Z  
 
Remarque préliminaire : Dans la suite ON VA MODIFIER LA GEOMETRIE DES OBJETS en déplaçcant les 
vertices,edges, faces qui les composent). 
 

• CHANGER LES DIMENSIONS D’UN OBJET (CHANGEMENT D’ÉCHELLE) : ACTION APPEL2E « S » 
 ATTENTION !!!: deux types de changment d’échelle : Scale directionnel ou scale global 
 
Méthode 1 – Souris- SCALE DIRECTIONNEL 
D’ABORD Panneau3DView >BarreMenus > Icône =  Bâton « casse tête » 
PUIS  Cliquer et déplacer en maintenant le Bâton « casse tête » choisi 
Résultat :  mise à l’échelle de l’objet (scale) selon les axes de couleur 

Méthode 2 – Clavier et souris SCALE GLOBAL 
D’ABORD Taper la touche  [S] ou [s] comme SCALE (mettre à échelle en anglais)  
Résultat : la souris est liée par un pointillé au centre de l’objet. (cf figure) 
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PUIS  Déplacer la souris > Changer échelle de l’objet + Cliquer gauche quand la position convient ou Taper 
une valeur au clavier (facteur d’échelle) + Enter 
Méthode 3 – Clavier- SCALE DIRECTIONNEL 
Taper au clavier « S» + le nom de l’axe « X ou Y ou Z » +« le facteur numérique de changement d’échelle » 
Méthode 4 – Panneau N et Clavier- SCALES DIRECTIONNELS 
Dans la Panneau « N » > Paragraphe = Transform > BarreCaseVertical = Scale 
Entrer les valeurs numériques voulues selon les cases (facteurs d’échelle selon les axes)  X, Y ou Z  
 

2.3. DÉFORMER DES OBJETS 3D DANS LA FENÊTRE SCENE DU PANNEAU 3DVIEW  

Description simplifiée d’un Objet 3D : Etre type géométrique défini par ses sommets ou nœuds (vertices en 
anglais), ses cotés ou arêtes (Edges)reliant deux sommets et ses faces (Faces)encadrées par des arêtes. Ils 
composent sa « structure interne », l’ensemble forme un Maillage (Mesh) > Modélisation d’un objet continu du 
réel.  
On peut donc avoir deux « conceptions – visions » d’un objet 3D comme le schématise la figure ci-dessous 
 
 
 
 
 
 
 

• MODES DE VISUALISATION ET DE TRAITEMENT DES OBJETS DE LA SCENE 
 
Mode Objet (Object Mode)  
C’est le mode de la « réalité » dans blender les objets sont vus comme des entités compactes sans montrer leur 
structure interne. Aucune modification n’est possible de celle-ci, mais on peut les déplacer et les changer 
d’échelle. 
Mode Edition (Edit Mode)  
C’est le mode de visualisation de la « structure » du dernier objet sélectionné, ce mode permet d’agir sur celle-ci 
 REGLE : Par défaut Blender se met en Object Mode 
Accès aux modes 
Panneau3DView > BarreMenuBasse > Case = Object Mode < clic  
Résultat : Dans le menu déroulé > Choisir entrée « Edit Mode » (Bascule pour retour) 
 
 
 
 
 
 ATTENTION !!!  en Mode Edition la première barre des menus basse change : ce sont les outils utilisés 
dans ce mode qui apparaissent (certains sont conservés : exemple poignées de translation, rotation, scale) 
 

• DEFORMATION DU MAILLAGE D’UN OBJET DE LA SCENE 
D’ABORD ModeObjet > Sélectionner un objet et se mettre en mode Edition  
Résultat : Contour de l’objet en surbrillance orange. 
PUIS  Panneau3DView > BarreMenuBasse > Case = Object Mode > Entrée = Edit mode  
Résultat : L’objet et ses éléments (vertice, edge, face) passent en orange  
Trois possibilités pour modifier le maillage en utilisant Panneau3DView > BarreMenus 
 
 
 

 Bouton  > Premier icône Travailler sur les sommets (vertices) appelé : Select Vertice 

 Bouton  > Deuxième icône Travailler sur les arêtes (Edges) appelé : Select Edge 

Objet 3D 
comme un bloc 
déplaçable et 

déformable mais 
conservant ses 

proportions 

comme une structure 
organisée d’éléments 
internes, sur les quels  

on peut agir 

Vision-conception 
d’un objet 3D 

OBSERVATEUR  OBSERVATEUR  



 

 16 

Bouton  > troisième icône Travailler sur les faces (Faces) appelé : Select Face 
Remarque : l’utilisation des actions G R S en Edit Mode vont être envisagés dans le paragraphe suivant. 
 

• AJOUTER DU MAILLAGE À UN OBJET DE LA SCÈNE : ACTION APPELÉE « E » - EXTRUSION 
Remarque préliminaire : Blender permet de dupliquer des éléments de la structure d’un objet en de nouveaux 
éléments qui demeurent connectés et s’ajoute à la géométrie mère. Ainsi : 
 Extruder un point donnera une arête nouvelle  
 Extruder une arête donnera une face nouvelle 
 Extruder une face donnera un volume nouveau. 
Comme le montre la figure ci-dessous 
 
 
 
 
 
 
 
 
 
 
 
 
 
D’ABORD Mode Object > Sélectionner l’objet (Exemple ci-dessous le CUBE vert ) 
PUIS  EditMode > Cocher Select Vertice 
PUIS  Taper la touche [E] 
PUIS  Déplacer la souris 
Résultat : Le déplacement de la souris est suivi par le nouveau vertice créé relié à l’ancien par une Edge mobile 
ENFIN Dans la scène,à la poisition souhaité > clic gauche  
Résultat : validation et fixation du vertice, et par conséquent de l’arête de liaison avec l’ancien. 
Remarque : On procède de même en choisissant , Select Edge ou Select Face 

Extrusion d’un Vertex 

Extrusion d’un Edge 

Extrusion d’une Face 
CUBE primitif 

Nouvelle Edge 

Nouvelle Face 

Nouveau Volume 
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Ensemble B 

Intersection de A,B Union de A,B Différence de A moinsB 

Ensemble A 

Ensemble B 

Ensemble A 

Ensemble B 

Ensemble A 

3. Modeling orienté impression 3D 
Exercice : Conception d’un petit robot, utilisation de fonctions booléennes 

 
Liste des points nouveaux abordés : symbole  
Ajout EdgeLoop : EditMode > selection Edge > Taper [Ctrl]+[R] 
Add On - Bool Tools > Utilisation des fonctions booléennes entre objets 
Fonctions Booléeans directes : ObjectMode > PanneauT > Onglet = Tools > Paragraphe = Bool Tools > Sousparagraphe = Auto Boolean > (Listes 
des opérations) 
Fonctions Booléeans en attente : ObjectMode > PanneauT > Onglet = Tools > Paragraphe = Bool Tools > Sousparagraphe = Brush Boolean > 
(Listes des opérations) 
Utilisation d'objets CURVES (Courbes de Bézier) : paramétrage, épaisseur (bevel) 
Transformation de CURVE en MESH 

 
Remarque préliminaire : Issues de la théorie des ensembles du mathématicien Bool, les fonctions booléens 
opèrent sur des ensembles d’éléments (voir figure pour les trois opérations fondamentales)) 
 
 
 
 
  
 

3.1. MISE EN PLACE DE MODULES SPÉCIFIQUES : LES ADD ONS 

D’ABORD PanneauInfo > BarreMenus > Menu = Fichier >Entrée = User Préferences 
  FenetreBlenderUserPreference > BarreMenus > Menu = AddOns 
PUIS   CaseRecherche < Taper : Bool (voir figure cidessous) 
 
 
 
 
 
Résultat : dans la partie large de la fenêtre apparition d’une ligne : « Object : Bool Tools » 
PUIS   Case devant phrase < coche 
PUIS  ListeIconesBas > Case = Save User Settings < Clic 
ENFIN Fermer la fenêtre 
Résultat : Dans le PanneauT > Onglet = Tools > Paragraphe = Bool Tools   apparaît ainsi que la liste des divers 
opérateurs booléans ! Ce sont certains de ces opérateurs que nous allons utiliser dans la suite. 
 

3.2. ASSEMBLAGE DES ÉLÉMENTS DU CORPS À PARTIR DE CYLINDRES 
• PREMIÈRE PHASE : DÉGROSSIR LE CORPS DU ROBOT À PARTIR DE PRIMITIVES : CYLINDER 
1- Le torse 

D’ABORD Ajouter un cylinder au centre du monde avec les dimensions : hauteur 2,5u, diamètre 1u 
PUIS  Sur le cylinder scale selon Y = 0.5 

2- Les bras 
PUIS  Placer le curseur en (3,0,0) 
PUIS  Ajouter un cylinder001 de dimension hauteur = 5 et rayon = 0.3 
 qui représentera les bras 
Remarque : le nom de l’objet est donné automatiquement par Blender. 
PUIS  Faire une rotation de 90° selon Y sur cylinder001 
PUIS  Placer cylinder001 par rapport à cylinder comme le montre la figure 

Case de recherche 

Fenêtre de la liste des 
résultats de la recherche 

Case d’activation à cocher 
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 3- « Souder » les bras et le torse  
Moyen :  Fonction Brush booléan : UNION en deux étapes : préparation et application 

Etape 1 - Préparation 
D’ABORD Sélectionner dans l’ordre cylinder001 et cylinder 
PUIS  PanneauT > Onglet= Tools > Paragraphe = Bool Tools  
   > Sparagraphe = Brush Boolean > Case = Union < Clic 
Résultat : Les deux objets sont en passe d’être réunis en un seul , MAIS ils ne le sont pas encore. On peut agir 
sur chaque constituant individuellement, Pour Cylinder, il suffit de le sélectionner, on peut alors le modifier.  
Pour Cylindre001 : un cage parallélépipédique l’entoure, c’est elle qu’il faut sélectionner pour sélectionner l’objet 
et lui appliquer des transformation 
Objectif : rajouter du maillage a Cylinder001 pour affiner plus tard  les bras.  
D’ABORD Sélectionner la « cage » de cylinder01pour sélectionner celui-ci 
PUIS  EditMode > Ajouter des edgeloops [Ctrl + R] comme le montre la figure. 
PUIS  Sélectionner Cylinder et cylinder001 

Etape 2  Application 
ENFIN  ObjectMode > PanneauT > Onglet= Tools > Paragraphe = Proporties 
   Bouton = Apply All < clic 
Résultat : les deux objets sont « soudés » en un seul : cylinder, cylinder001 a été intégré et à disparu de 
l’outliner. 
Remarque IMPORTANTE pour l’impression 3D : Observer en Wireframe que le maillage est « propre » ! (pas 
de surface intérieure à la différence d’une opération Joint entre objets) 

3- Les jambes  
PUIS  Placer le curseur en (3,0,0) 
PUIS  Ajouter un cylinder002 de dimension hauteur = 1.5 et rayon = 0.3 sera une jambe  
PUIS  Placer la jambe comme le montre la figure  
PUIS  Duppliquer celle- ci et la placer à coté comme le montre la figure 

4- Souder les jambes au torse 
Moyen : Fonction Auto booléan : éxécution directe de l’opération 

D’ABORD Sélectionner simultanément les deux jambes et le torse 
PUIS  PanneauT > Onglet= Tools > Paragraphe = Bool Tools  
   > Sparagraphe = AutoBoolean > Case = Union < Clic 
Remarque IMPORTANTE pour l’impression 3D : Observer en Wireframe que le maillage est « propre » ! (pas 
de surface intérieure à la différence d’une opération Joint entre objets) 

5- Le cou et la tête 
D’ABORD Positionner le curseur en (0,0,1) 
PUIS  Ajouter un cylinder rayon 0.4 (laisser la hauteur telle que, elle sera « absorbée » par opération union) 
PUIS  Positionner le curseur en (0,0,2) 
PUIS  Ajouter une sphère de rayon 0.7u 

6- Souder le torse, le coup et la tête 
D’ABORD Sélectionner simultanément : le torse, le cou et la tête (ordre peu important cette fois !) 
PUIS  PanneauT > Onglet= Tools > Paragraphe = Bool Tools  
   > Sparagraphe = AutoBoolean > Case = Union < Clic 
Remarque : Il est conseillé de renommer l’objet obtenu : “robot” 
 

• DEUXIÈME PHASE : AFFINAGE DE LA SILHOUETTE 
1- Affinage des bras et création des poignets 

D’ABORD Sélectionner l’objet « robot » 
PUIS  Passer en EditMode 
PUIS  Sélectionner chaque edge loop des bras et les déplacer au milieu du bras. 
PUIS  en Wireframe, mode vertice, sélectionner avec  boite les extrémités deux extrémités des bras 
PUIS  Déplacer légèrement vers le haut comme le montre la figure médiane 
 

 
PUIS  Scaler de 0.7 et déselectionner  
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PUIS  Pour chaque poignée faire une rotation de 30° environ voir figure de droite 
2- Création des pieds 

D’ABORD Passer en EditMode 
PUIS  Sélectionner les vertices de la face base des deux jambes 
PUIS  Extruder   
PUIS  Sélectionner en boite seulement les faces du pourtour de la partie basses des jambes (voir figure) 
PUIS  Extruder (sans déplacement), scaler global de 1.2 
PUIS  Scaler sur Z pour rattraper l’horizontale 
PUIS  Déplacer selon les Y  comme le montre la figure 

3- Création de l’œil de la tête 
D’ABORD EditMode > sur la sphère de la tête, sélectionner en vue de face une tranche de 8 par 
2 facettes 
PUIS  Extruder en Y vers l’arrière de 0.2 comme le montre la figure . 
 

4- Création des poignets 
D’ABORD Placer le curseur sur la face extrême du poignet du robot 
PUIS  Ajouter une UVsphere de rayon 0.3 
PUIS  Scaler selon Y de 0.7 
PUIS  Dupliquer et déplacer l’objet sur l’autre bras 
PUIS  Sélectionner simultanément les deux sphères poignets et le robot 
PUIS  PanneauT > Onglet= Tools > Paragraphe = Bool Tools  

 Sparagraphe = AutoBoolean > Case = Union < Clic 
 

5- Création de main-pinces 
Objectif : Utiliser un nouveau type d’objet pour réaliser à chaque extrémités des poignets une pince 
 Moyen : Objet Curve (courbes de Bézier) 

Etape 1 – Mise ne forme d’une courbe de Bézier 
D’ABORD ObjectMode se positionner dans un calque vide 
PUIS  Mettre le curseur au centre 
PUIS  Se mettre en vue top 
PUIS  Panneau3Dview > BarreMenus > Menu = Add > Entrée = Curve >sEntrée = Bézier < clic 
Résultat : Un petite courbe apparaît à coté du centre du monde. 
PUIS  Passer en EditMode  
Résultat : La  courbe affiche ses modificateurs sur ses constituants  (point, tangente au point) forme des 
« poignées » que l’on peut sélectionner et déplacer pour déformer la courbe 
 
 
 
 
 
PUIS  Utiliser les poignées des tangentes aux points A et B pour obtenir une forme en U  
PUIS  A partir des deux extrémités A et B  Extruder les doigts (voir figure 
ci-contre)  
 

 Etape 2-Donner de l’épaisseur à la courbe CURVE 
D’ABORD Passer en ObjectMode 
PUIS  Positionner le Curseur au centre 
PUIS  Panneau3DView > BarreMenus > Menu = Add >  
  Entrée = Curve >SousEntrée =Cercle 
PUIS  PanneauEphemère > Paragraphe > Radius = 0.2 
PUIS  ObjectMode > Modifier le cercle en ovale (petit axe X) 
PUIS  Sélectionner la Courbe en U 
PUIS  PanneauProporties > Barre Icones > Icones = CURVES > 
   Paragraphe = Géometry > Boite = Bevel Object <CircleObject 

Point de la courbe 

Poignée de la tagente à gauche du point 

Poignée de la tagente à droite du point 

Point A Point B 

Point A Point B 
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Résultat : la courbe est remplacée par un « tuyau » 
PUIS  Ajuster la forme du cercle pour avoir la forme de « tuyau » voulu  

 Etape 3-Transformer la Curve en Maillage (sinon pas d’application des booléans) 
D’ABORD Sélectionner l’objet « Tuyau » 
  Panneau3DView > BarreMenus > Menu = Object >  
   Entrée = Converte to > Sous entrée = Mesh from Curve .. 
Résultat : On peut vérifier en EditMode le nouveau maillage obtenu à la place de la courbe de bézier. 

 Etape 4 - Fermer les extrémités du Mesh 
D’ABORD EditMode > Panneau3DView > BarreMenus > Icône = Edge 
PUIS  Sélectionner le bord de l’ouverture > Alt + Clic Droit 
PUIS  Panneau3DView > BarreMenus >Menu = Add > Entrée = Faces > SEntrées = Make Edge/face 
Résultat : Fermeture par une Face  

Etape 5 - Ajouter la pince au bout des poignets  
D’ABORD Déplacer la pince dans le calque du robot 
PUIS  Ajuster la taille et la position comme le montre ja figure 
PUIS  Faire la même chose sur l’autre poignet 
PUIS  Sélectionner simultanément le robot et la pince 
PUIS  PanneauT > Onglet= Tools > Paragraphe = Bool Tools > Spar. = AutoBoolean > Case = Union < Clic 
 

3.3. AJOUTER DE L’APPARENCE AU ROBOT 

 (Voir chapitre 3 – Paragraphe 3.2 ) 
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4. Modeling méthode LowPoly (faible nombre de faces polygonales)  
Exercice : Conception d’un robot à partir de subdivision d’un cube 

Liste des points nouveaux abordés : symbole  
Ajout maillage : EditMode > PanneauT > Onglet = Tools > Paragraphe = Add > Case = Subdivde et Paramètres dans PanneauEphémère 
Utilisation de la technique des "lowpoly" (maillage polygonal à nombre assez faible de faces) par des opérations d'extrusions, rotations, 
déplacements enchainés sur un même objet de départ. 
Notions de material, texture : Utilsation du NodeEditor et notions de d’image-displacement créée dans le logiciel GIMP (Voir ANNEXE 1) 
Notions d'éclairage de la scène et de rendu. 
Utilisation des "modifiers" : ARRAY, SOLIDIFY, BEVEL, SUBSURF 
Utilsation des objets "particules" 

4.1. MODELAGE DU CORPS DU ROBOT PAR RAPPORT À UNE PRIMITIVE : UN CUBE  

 
 

• PREMIÈRE PHASE : MODELAGE DU CORPS À PARTIR DU CUBE DE RÉFÉRENCE  
 
 1- Le torse du robot 
D’ABORD EditMode > Sélectionner la face avant du cube (perpendiculaire à l’axe  rouge X) 
PUIS  PoignéeRouge > Déplacer la face pour que l’épaisseur du cube face une unité de 
grille 
PUIS  Extruder « un peu » (voir figure ) la face vers l’avant (sens de la flèche rouge)  
PUIS  Scaler sur la face avant de facteur 0.8 
Résultat : Un  bisot ou champ frein apparaît sur la face de l’objet 
ENFIN  Refaire la même opération sur la face opposé 
 
 2- Préparer le bas du robot pour la création des jambes : augmenter le maillage des cotés du robot pour 
pouvoir extruder les jambes 
D’ABORD EditMode > Mode = Edge > Pointer avec la souris,un edge de la face basse du robot 
PUIS  Appuyer simultanément sur les touches [Ctrl] + [R] 
Résultat : un edge « rose » de pourtour nommée « edgeloop » (edge en boucle)apparaît au 
milieu du corps, surtout ne pas bouger la souris ! 
PUIS  Faire rouler légèrement la roulette de la souris pour obtenir SEULEMENT 2 
edgeloops. (voir figure) 
PUIS  Cliquer Gauche  
Résultat : les deux edges loops changent de couleur (orange), et en plus ils suivent ensemble les mouvements 
de la souris 
PUIS  Déplacer au mieux la souris pour que les edges loops soient au centre de la face 
PUIS  Cliquer Gauche pour valider 
 
 3- Les jambes et pieds du robot 
D’ABORD Extruder une face basse (Z) d’une demi unité vers le bas, avec un scale pour 
légèrement amincir le bout (figure ci-contre) 
PUIS  Extruder vers le bas (Z) de 0.2 unité pour préparer le pied 
PUIS  Sélectionner la petite face du pied coté axe X (rouge)  
PUIS  Extruder de 0.2 unité 
PUIS  Faire une rotation par rapport à Y de -30°(voir figure) 
PUIS  Faire la même chose pour l’autre jambe 
 
 4-  Préparer les cotés du robot pour la création des bras (sans poignet ni main) 
Objectif : augmenter le maillage des cotés du robot pour pouvoir extruder les bras 
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D’ABORD EditMode > Sélectionner un coté latéral non bisoté du robot 
PUIS  Afficher le PanneauT (gauche) (appuyer sur la touche « T » s’il n’est pas affiché !) 
PUIS  PanneauT > Onglet = Tools > Paragraphe = Add > Bouton = Subdivide 
Résultat : Dans Panneau3DView, la face sélectionnée est subdivisée en quatre faces. Ce qui n’est pas suffisant 
Il faut augmenter le nombre de mailles; 
ATTENTION !!! En bas du PanneauT apparaît un sousPanneau appelé « Panneau 
Ephémère » dans lequel s’affiche les paramètres de l’opération en cours d’éxécution. Il a 
l’énorme incovénient d’être accessible JUSTE APRES seulement l’activation de l’action, il 
disparaît instantanément si on fait autrechose ! 
PUIS  PanneauEphemère > Case = Nomber of Cuts < Taper  2 
Résultat : On obtient une subdivision de la face comme le montre la figure ci contre.  
PUIS  Refaire sur le coté opposé  
 
 5- Les bras du robot(sans poignet ni main) 
D’ABORD Extruder un ARRIERE-BRAS perpendiculaire au corps longueur 1u 
PUIS  Basculer Face du bout de 45° vers le bas  
PUIS  Scale pour mincir  
PUIS  Extruder l'AVANT-BRAS perpendiculaire à la surface longueur 0.25 u 
PUIS  Scale pour mincir (voir figure) 
ENFIN Faire la même chose pour le deuxième bras  
 
 6- Le cou du robot 
D’ABORD  Sélectionner la petit face centrale du dessus 
PUIS  Déplacer celle-ci légèrement vers le haut pour incliner les épaules (figure)  
PUIS  Extruder de 0.1 u vers le haut 
 

• DEUXIÈME PHASE : ASSEMBLAGE D’OBJETS : AJOUT LA TÊTE SPÉRIQUE DU ROBOT 
 
 1- Première Méthode en Mode Objet 

Etape 1- Ajouter une tête sphérique 
D’ABORD ObjectMode > Positionner le Curseur pour Insertion  
PUIS  Eviter le positionnement avec clic gauche de la souris 
  Touche Maj+  « S » > menu contextuel > Entrée >Cursor To Center  
PUIS  Ajouter la sphère 
PUIS  Panneau3DView > BarreMenu > Menu = Add > Entrée = Mesh > Sous Entrée = UVSphere 
PUIS  Placer la Sphere sur le cou 
Remarque : PROBLEME > Les objets CORPS et TETE sont distincts 

Etape 2 - Rassembler TETE et Corps en un seul objet 
D’ABORD Selectionner les deux objets (Maj+Clic droit) 
  Panneau3DView > BarreMenu > Menu = Object > Entrée = Joint 
Remarque : Vérification en mode Edit ou déplacement ou Contour 
 
 2- Deuxième Méthode en Mode Edit 
D’ABORD EditMode >Positionner le Curseur pour Insertion 
PUIS  Selection directe de la face haute du cou + Maj S > Cursor to selected 
  Eviter le positionnement avec clic gauche de la souris 
PUIS  Ajouter le sphère 
  Panneau3DView > BarreMenu > Menu = Add > Entrée = Mesh > Sous Entrée = UVSphere 
PUIS  Placer la Sphere sur le cou 
Remarque : les deux objets sont directement solidaires > Vérifier en Mode Object 
 
 2- Ajouter la lettre R sur poitrine 
D’ABORD ObjectMode > Positionner le Curseur au centre de l’univers (peut-être dans un nouveau calque !) 
PUIS  Panneau3DView > BarreMenu > Menu = Add > Entrée = Text 
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 3- Paramétrage de l’objet Texte 
D’ABORD EditMode > Changer le Texte en « R »  
Remarque : dès le passage en EditMode le curseur est apparent à la fin du texte, l’utiliser comme dans un 
traitement de texte  ATTENTION ! L’objet Texte est un type d’objet différent des Meshs avec ses propres 
paramètres  
PUIS  ObjectMode > Panneau droite > barre des icones > Icones Texte (figure) 
PUIS  Paragraphe : Geometrie > Changer la valeur de « Extrude » selon les besoins 
PUIS  Paragraphe Font > Changer la valeur de « Size » selon les besoins 
 4- Transformer l’objet Texte en Mesh 
D’ABORD Panneau3DView > BarreMenu > Menu = Object > Entrée = Convert to > Sous Entrée = Mesh from 
Curve … 
PUIS  Joindre le nouveau Mesh-Lettre au corps (Peut-être pas toujours pertinent !!!) 
 

• TROISIÈME PHASE : MISE EN PLACE DE L’ŒIL ET DE SON IRIS SUR LE ROBOT  
 1- Placer la visière en creux de l’oeil 
D’ABORD EditMode > sur la sphère de la tête, sélectionner en vue de face une tranche de 8 par 2 facettes 
PUIS  Extruder en Y vers l’arrière de 0.2 comme le montre la figure . 
 
 
 
 
 
 
 
 

2- Placer un iris sphérique dans la Tête derrière le renfoncement de l’œil 
D’ABORD ObjectMode > Se mettre en vue Wireframe, puis insérer une sphère de rayon 1.5u comme le montre 
la figure ci-dessous. 
 
 
 
 
 
 

4.2. AJOUTER DE L’APPARENCE AU ROBOT- MATERIAL-NIVEAU 1 

 
Remarque : ce paragraphe est commun aux deux construction du robot 
VERIFIER > Moteur de Rendu = CYCLES 
 
 
Notion d’Attribut d’apparence de matière (Material) : 
Approche de définition de « MATERIAL » attribué à un objet :  c’est la manière dont est renvoyé la lumière par la 
surface externe de cet objet(mate, réfléchissant, translucide …) et aussi donc sa couleur. 
 

• PREMIÈRE PHASE : ATTRIBUER À L’ENSEMBLE DU ROBOT UNE APPARENCE DE MÉTAL 
 1-  Création d’un « material » 
D’ABORD Sélectionner l’objet 
PUIS  PanneauProporties > Barre icones> Icones MATERIAL 
 
 
Résultat : Apparition sous la barre d’icones du PanneauMaterial  
PUIS  PanneauMaterial > Bouton = New < clic 
Résultat : le Cadre (appelé pile des materials) affiche une ligne surlignée en bleu : « Material  » c’est le nom du 
material créé par défault par Blender , dont les paramètres sont présentés en dessous  
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PUIS  Dans la pile > Cliquer sur le nom et modifier le texte en tapant : « MetalRobot » pour se repérer entre 
les divers matérials 
 
 2- Paramétrage du Material 
D’ABORD PanneauMaterial > Paragraphe : Surface (pointeau ouverture bas = ouvert, sinon versla droite : fermé) 
PUIS  Cliquer sur le bouton « Use Nodes » 
Résultat :  le Paragraphe SURFACE se développe 
PUIS  Cliquer sur ponteau d’affichage de paragraphe =  SURFACE 
PUIS  ParagrapheSURFACE > CaseSurface < choisir GLOSSY BSDF 
( BSDF : fonction de distribution de diffusion bidirectionnelle.de la lumière) 
  Paramètre : Roughtness = 0.2 (rugosité) 
Remarque : Pour Voir l’effet MATERIAL > Développer Paragraphe PREVIEW (voir avec icône latéral / forme) 

3- Visualisation de l’objet avec son material > View Port Shading 
D’ABORD Panneau3DView > BarreMenus  > Icones = type d’affichage (Display) > Entrée : RENDER  
 ( hypothèse robot au centre du monde) 
Résultat : L’ensemble est dans l’ombre, il faut créer un espace scénique ! 
 

• DEUXIÈME PHASE : CRÉATION D’ UN ESPACE SCÉNIQUE : PLATEAU + ÉCLAIRAGE 
D’ABORD  le Plateau : Ajouter l’objet plan  avec déformation en Editmode(Dimension de la base a peu près 10u 
par 25u), sous les pieds du robot  
PUIS  L’éclairage : Sélectionner la lampe (soleil en pointillé  dans la 
scène du panneau 3DView voir ci-contre la sélection) 
PUIS  Positionner la lampe / Objet ( déplacement, rotation …) 
PUIS  PanneauProporties > Barre icones> Icones LAMPE 
  Cliquer sur le bouton « Use Nodes » 
Résultat le Paragraphe LAMPE se développe 
  Case = STRENGTH (Force) < Mettre la valeur = 1000 
 

• TROISIÈME PHASE : ATTRIBUER DE LA TRANSPARENCE AU FOND DE L’ŒIL DU ROBOT 
D’ABORD Sélectionner l’objet 

1- Attribuer à l’objet le nouveau matériel 
D’ABORD Sélectionner le Robot 
PUIS  Passer en EditMode 
PUIS  PanneauProporties > Barre icones> Icône = MATERIAL 
PUIS  PanneauMaterials > Premier Volet >Pile des Materiaux 
PUIS  Cliquer sur le bouton « + » 
PUIS  Cliquer sur le bouton « New » 
Résultat : Ajout d’un nom dans la Pile et changement de la partie 
  basse du panneau 
PUIS  Changer le nom pour : « Hublot » 
 2- Affecter au « Hublot » un material type verre 
D’ABORD Cliquer sur le Pointeau du Paragraphe = SURFACE 
 PargrapheSURFACE > CaseSurface < GLASS BSDF ou TRANSPARENT BSDF 
Remarque : Pour Voir MATERIAL > Développer Paragraphe PREVIEW (voir avec icône 
latéral / forme) 
PUIS  EditMode > Se positionner face au visage du robot 
PUIS  Sélectionner la suite de faces figure ci-contre 
PUIS  PanneauProporties > Pile des Materiaux > « Hublot » < clic 
PUIS  Appuyer sur le bouton « Assign » (figure ci-contre) 
Remarque : Vérification > en mode Render 
 3- Attribuer à l’IRIS du ROBOT une apparence d’éclairage rouge 
D’ABORD EditMode > Sélectionner la sphère interne « IRIS » derrière le hublot (mode wireframe recommandé !) 
Remarque : pour cela on sélectionne une petite face de l’iris et on appuie sur [Ctrl]+[L] pour obtenir l’iris entier ! 
PUIS  EditMode > Créer un nouveau material  > Nom = Iris , Surf = Emission, Color = Rouge, strenght = 10 
Résultat :  la sphère de l’iris « éclaire » l’interieur de la tête du robot ! 
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Panneau Rendus : PR 

Panneau Node Editor : PNE 

4.3. AJOUTER DU VIEILLISSEMENT AU METAL DU ROBOT : MATRERIAL ET TEXTURE – NIVEAU 2 
• PREMIÈRE PHASE : PRÉPARATION DE L’EPACE DE TRAVAIL 

Remarque préliminaire : cette phase consiste à subdiviser  l’écran en Quatre panneaux : un panneau où l’on 
visualise en direct les matérials appliqués sur le objet (Panneau des rendus : abréviation PR), un panneau où l’on 
créer les matériaux avec un éditeur (Panneau du Node Editeur : abréviation PNE) et enfin les deux panneaux 
droits classiques de l’Outliner et des Proporties. 
 
 1-  Subdivision du Panneau 3D view en deux panneaux identiques 
 D’ABORD Placer la souris sur la ligne de frontière entre le panneau de droite et la fenêtre de visualisation 
afin d’obtenir le changement de la forme du curseur               , 
 PUIS  Cliquer droit > menu contextuel (ci-contre) = entrée Split Area 
Résultat : une ligne de séparation horizontale mobile avec la souris apparaît, 
 PUIS  Choisir position de la ligne de séparation et cliquer gauche 
Résultat : le panneau 3DView ,et sa barre des menu basse est divisé en deux panneaux identiques verticales 
 PUIS  Caller les panneaux / besoins en jouant sur les lignes frontières (clic maintenu et deplacement). 
 
 2- Personnalisation Panneau haut en Panneau de visualisation partielle des rendus -Notée : PR dans la 
suite 

Etape 1- Création de la zone de vision du rendu 
 D’ABORD Placer la souris dans la fenetre PR 
  PUIS  Appuyer sur [Ctrl] + [B] 
 Résultat : Apparition d’une croix verticale en ligne pointillée, attachée à la mobilité de la souris 
 PUIS   Faire une sélection rectangulaire (bouton Gauche souris) de la zone voulue (autour du robot !) 
 Résultat : Apparition d’un rectangle en pointillés rouges autour de la zone 
Remarque en cas d’erreur :  [Ctrl] + [Alt] + [B] annule l’opération 

Etape 2 - Activation du rendu dans la zone précédemment créée 
 D’ABORD Placer la souris sur la zone encadrée en pointillé rouge ? 
 PUIS  Barre des menu basse de FR > Icône =Viewport Shading 
   Menu contextuel > Entrée = Rendered  
  Ou directement [Shift] + [Z] (Voir vue ECRAN) 
 
 3- Transformation Panneau bas en Panneau d’édition des matérial en boites (nodes) connectées 
 D’ABORD Panneau3DView> Premier Icône(en bas à gauche) > Entrée = Node Editor 
Résultat : ce nouveau panneau sera appelé PNE dans la suite (Voir vue ECRAN ci dessous) 
Remarque : Le PNE comporte une représentation 
nodale du material type métal appliquée au robot. 
 

 
 
 
 
 
 
 
 
 
 

• DEUXIÈME PHASE : APPLICATION D’UN EFFET DE ROUILLE AU MATERIAL MÉTALLIQUE DU ROBOT (NOTION DE 
TEXTURE) 

Remarque préliminaire : On appelle « Texture » une application sur le surface d’un objet d’une image 
(photographie, dessin …). Cela s’effectue d’abord en projetant sur un plan la surface de l’objet le plus fidèlement 
possible pour éviter les déformations du passage de la surface 3D à une surface 2D (en anglais : Unwrap), puis 
en appliquant à la projection l’image voulue. 
 

Node d’entrée (Input) 
Fonction de calcul pour le renvoi 
de la lumière 

Node de sortie (Output) 
Localisation de l’affichage sur 

l’objet sélectionné 

Lien de connexion (Socket) 
Lien simulant l’application de la fonction (ici 
aspect glossy : métal) sur l’objet sélectionné 

(ici la surface de l’objet) 
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 1-  Utiliser un node de projection « automatique » de la surface de l’objet « Robot » 
PNE > BarreMenus > Menu = Add > Entrée = Input > SousEntrée = Texture Coordinate 
Résultat : le nœud « texture coordinate » s’affiche, il possède une sortie « generated » qui renvoie les 
coordonnées sous forme de vecteur d’une projection de la surface de l’objet auquel il s’applique. (voir figure) 
 
 2-  Utiliser un node d’application d’une image sur la surface dépliée d’un objet 
 D’ABORD  PNE > BarreMenus > Menu = Add > Entrée = Texture > SousEntrée = Image Texture 
Résultat : le nœud « image texture »  s’affiche, il possède une entrée « vector » pour recevoir les coodonnées  
De l’endroit de l’objet où doit être envoyé les pixels de l’image de la case « open » où sera entré le nom du fichier 
image choisie., et une sortie « color » de renvoi de ceux-ci sur le material   
 PUIS  PNE > NodeImageTexture > Bouton = Open < clic 
   Choisir dans l’explorer le fichier image  voulu (ici : RustPaint.jpg) 
 PUIS  Disposer les nodes et les liens  comme le montre le trableau ci-dessous 
Remarque : Pour tirer un lien ou socket : cliquer sur un bouton de sortie de nœud, en maintenant le clic, 
déplacer le souris sur une entrée du nœud suivant et relaché ! 

Node Input 
(depliage automatique) 

 
socket 

Node fonctionnel 
(type texture : application 

image sur surface) 

 
socket 

Node fonctionnel 
(type material : renvoi 
métal de la lumière) 

 
socket 

Node Output 
(affichage du résultat sur 

le viewport) 

 
 
 
 
 
 
 
 
 
 
 

  
 
 
 
 

 

    

 
 
 
 
 
Remarque : l’effet obtenu est l’application des « taches de rouille » sur la surface métallique (figure ci-dessus), 
mais on peut accroitre l’éffet en « simulant » une granulosité produite par ces taches de rouille. 
 3- Utiliser le node de texture pour donner du relief aux attaques de la rouille. 
D’ABORD Sélectionner le Node Image texture précédent 
PUIS  PNE > Barremenus > Menu =Node > Entrée =Duplicate (ou directement appuyer sur [Shift]+[D]) 
PUIS  PanneauNE > Node ImageTexture > Bouton = color < Non Color Data 
PUIS  Connecter les nœuds comme le montre la figure ci-dessous. 
   
 
 
 
 
 
 
 
 
 
 
 
PUIS  Nommer le material : MaterialROUILLE 
Remarque : le deuxième image texture utilise une copie noir et blanc pour créer un « éffet de relief » sur la 
surface aux endroits des taches de rouille (en réalité ce n’est qu’une modification des rayons renvoyés par la 
lumière, pas une déformation du maillage !!!) 
 

Image de rouille type .JPG 
(anglais :  RustPaint.jpg) 

Résultat 
(extrait panneau3Dview) 

Premier Image Texture 
(forme repliée) 

Résultat 
(extrait panneau3Dview) 
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4.4. AJOUTER UN SURF AU ROBOT : NOTION DE  CURVE-NIVEAU 2 

 
 1- Créer la  forme en longueur du surf 
D’ABORD Changer de calque > Positionner le Curseur au centre 
PUIS  Passer en Object Mode 
PUIS  Panneau3DView > BarreMenus > Menu Add > Entrée = Curve >SousEntrée =Bézier 
PUIS  En utilisant les connaissances de la création des pinces (Page ????) >Obtenir en vue de dessus 
l’allure ci-dessous : 
 
  
 
 
PUIS  Nommer cette coube : SURF 

2- Créer une section profilée pour le surf 
PUIS  Panneau3DView > BarreMenus > Menu Add > Entrée = Curve > 

  >SousEntrée =Circle 
PUIS  Déformer le Circle comme le montre la vue de dessus l’allure ci-contre : 
 
 3- Appliquer la section au SURF 
PUIS  PanneauDroit > BarreIcones > Icône = CURVES 
  PanneauCurves > Paragraphe = Géometry 
   Case = Bevel Object < sélectionner «  CircleObject » 
Résultat : On obtient le « tuyau ci-dessous » 
 
 
 
 
 
 
Remarque : Pour l’ajustage du profil > toute modification du CircleObject entraine une modification de forme de 
l’ensemble du profil en EditMode (abréviation : EM) ou ObjectMode (abréviation : OM) 
 
 4- Préparer l’arrondi des bouts du Surf 
D’ABORD Panneau3DView > BarreMenus > Menu Add > Entrée = Curve >SousEntrée = 
Bezier  
PUIS   Obtenir en vue de dessus l’allure ci-contre : 
Principe : les points de cette curve permettent de définir par leur ecart par rapport à la curve à 
laquelle elle s’appplique, le « diamètre du tuyau », d’autre part l’orientation des tangentes en ces 
points , la propagation sur le tuyau de ce « diamètre »  (figures ci-dessous) 
 
 
 
 
 
 

6- Appliquer les arrondis au bout du SURF 
PUIS  PanneauDroit > BarreIcones > Icône = CURVES 
  Paragraphe = Géometry 
  Case = Taper Object= BesierCurve 
 
Résultat :On obtient la forme ci-contre 
 
Remarque : pour l’ajustage des bouts > Toute Modification du CircleObject entraine modification de forme de 
l’ensemble du profil en EM ou OM. 
Dans la suite nous allons construire séparément les éléments du reacteur : l’helice, le corps qui viendront s’ajouter au surf. 

Eloignement du 
vertice / « tuyau » 

sur Y vers le 
«tuyau »et  
rotation / Z 

 

Rapprochement du 
vertice / « tuyau » 

sur Y vers le 
«tuyau » 
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Afin d’alléger l’espace de travail, nous allons utiliser les « layers » que l’on peut assimiler à des calques. Chaque layer est 
un espace scènique propre. Ces layers sont « empilés » et accessibles soit séparément soit en superposition.Ils 
permettent un travail séparé sur chaque objet, mais aussi la possibilité de les rassembler ce que nous ferons à la fin. 

4.5. AJOUTER DES REACTEURS AU SURF : L’HELICE - MODIFIER NIVEAU 1 : MODIFICATEUR ARRAY 

 1- Création de l’Hélice du réacteur >Modificateur ARRAY 
Consigne : SUIVRE IMPERATIVEMENT l’ordre des étapes 

Etape 1 - Mise en forme d’une pale du réacteur 
D’ABORD  à partir du cube, en utilisant les modes EM et OM obtenir la forme  
ci contre avec les positions du repères et du curseur à l’origine 
PUIS  Nommer l’objet : PALE 

Etape 2 – Utilisation du MODIFIER – ARRAY pour cloner les pales  
D’ABORD Sélectionner la PALE 
PUIS  Appliquer toutes les modifications de transforme du CUBE en PALE :  
 Panneau3DView > BarreMeneus  > Menu = Object > Entrée = Apply > SousEntées= Loc,Rot,Scale 
PUIS  Ajouter le Modifier de démultiplisation : ARRAY 
 PanneauDroit > BarreIcones > Icône = Modifier <clic 
    Bouton=AddModifier < clic 
   Menu Contextuel > Rubrique verticale = Generate > Entrée = Array 
Résultat : dans le PanneauDroit , la partie basse affiche le Panneau de paramatrage de ARRAY  que nous 
appellerons : PanneauARRAY 
PUIS  PanneauDroit > PanneauArray 
   Case = Count > Valeur = 12 (exemple) 
   Case = Relative Offset < Décocher 
   Case = Object Offset < Cocher 
PUIS  Créer dans la SCENE un Objet EMPTY – entrée Plain Axes au centre de la scène 
Remarque : objet EMPTY n’est autre qu’un point sans autre géométrie représenté par 3 segments séquents en 
ce point, il servira de poignée pour « tirer les clones » 
PUIS  Panneau droit > PanneauArray > Case = Object Offset < Sélectionner « EMPTY » 
PUIS  Démultiplication des PALES 
  En vue de FACE : Fenêtre de vision > sélectionner EMPTY 
   Faire Translation sur X avec le Widget de EMPTY 
   Faire Rotation en tapant R et déplacement Souris (pour faire un tour) 
   Cliquer gauche pour Valider 
Remarque : pour des légères corrections possibles  d’angle et position à partir de l’empty suivre les 
transformations dans Panneau N >Paragraphe = Transform 

Etape 3-Obtention de l’objet HELICE et repérage par son centre 
D’ABORD Sélectionner les PALES 
PUIS  Panneau droit > PanneauArray > Bouton = Apply < Clic 
PUIS  Nommer le : HELICE 
Résultat : la fenêtre des paramètres se ferme : objet est créé 
Centrage de l’hélice 
PUIS  Sélectionner l’objet HELICE 
PUIS  PanneauT  > Paragraphe = Edit > Bouton = Set Orgine 
   Menu contextuel > Entrée = Origine to Geometry 

Etape 4- Mise en  réserve de l’hélice pour futur montage 
PUIS  Sélectionner l’objet Hélice 
PUIS  Mettre l’Hélice dans un autre calque  pour cela : 

Taper : Touche [m] > Menu contextuel = choisir case du layer voulu 
(2 sur la figure ci-contre par exemple) 
 



 

 29 

4.6. PARTIE 2- CORPS DU RÉACTEUR > MODIFICATEURS SOLIDIFY, BEVEL, SUBSURF 

 
 1-Création du corps du réacteur 
Consigne : SUIVRE IMPERATIVEMENT l’ordre des étapes 
 

Etape 1- Créer la forme générale cylindrique du réacteur 
D’ABORD Changer de calque > Positionner le Curseur au centre 
PUIS  Panneau3DView > BarreMenus > Menu = Add > Entrée =Cylinder 
PUIS  PanneauT > PanneauEphemère > Paragraphe = Add Cylinder 
   Bouton = Cap Fill Type < Sélectionner = Nothing (pas de face en bout) 
PUIS  Donner les dimensions de longueur 12 u, diamètre 2u 
PUIS  Aligner l’axe du cylindre sur l’axe X horizontal 
PUIS  Appliquer les transformations (Ctrl + A)  

Etape 2- Réglage épaisseur du corps du réacteur 
D’ABORD Sélectionner le cylindre 
PUIS  Se mettre en vue de droite 
PUIS  Ajouter le Modifier d’épaississement : SOLIDIFY 
  PanneauDroit > BarreIcones > Icône = Modifier <clic 
    Bouton=AddModifier < clic 
    Menu Contextuel > Rubrique verticale = Generate > Entrée = Solidify 
Résultat : dans le PanneauDroit , la partie basse affiche le Panneau de paramatrage de SOLIDIFY  que nous 
appellerons : PanneauSOLIDIFY 

Convention pour la suite : à chaque fois que nous choisirons (clic) un icone de nom :  
NOM_ACTION dans la barre des icônes, la partie basse du Panneau Droit sera appelé : 
PanneauNOM_ACTION  

PUIS  PanneauDroit > PanneauSolidify 
   Case = Thickness < 0.4 (Épaisseur) 
   Case = Offset < 1 (déplacement / surface origine = extérieur) 

Etape 3 - Obtention de l’objet corps du réacteur 
D’ABORD Sélectionner l’objet 
PUIS  PanneauDroit > PanneauSolidify > Bouton = Apply < Clic 
Résultat : la fenêtre des paramètres se ferme : objet est créé 

Etape 4 – Créer une tuyère à l’arrière  
En Mode Edit créer à l’arrière du cylindre la tuyère (figure ci-contre) 

Etape 5 – Travail sur l’aérodynamique du réacteur 
D’ABORD Ajouter le Modifier de biseau des bords : SOLIDIFY 
 PanneauDroit >BarreIcones > Icône = Modifier <clic 
    Bouton = AddModifier < clic 
   Menu Contextuel > Rubrique verticale = Generate > Entrée = Bevel 
Résultat : Dans PanneauDroit, la partie basse affiche le PanneauBevel de paramétrage. 
PUIS   Panneau droit > PanneauBevel 
   Case = Witdth < 0.3 (épaisseur du biseau exemple) 
   Case = Segments > Valeur = 3 (facettes du biseau exemple) 

Etape 6 - Ajouter le Modifier de lissage : SUBDIVISION SURFACE 
D’ABORD PanneauDroit > BarreIcones > Icône = Modifier < clic 
 PanneauDroit > Nouvelle partie basse > Bouton=AddModifier 
   Bouton = AddModifier < clic 
   Menu Contextuel > Rubrique verticale = Generate > Entrée = Subdivision Surface 
Résultat : Dans PanneauDroit, la partie basse affiche le PanneauSubSurf de paramétrage 
PUIS   Panneau droit > PanneauSubSurf 
   Case = View < Valeur = 3 (exemple) (lissage en vue direct- Panneau3Dview) 
   Case = Render < Valeur = 3 (exemple) (lissage  au rendu) 
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Etape 7 - Correction des défauts de l’ordre d’application des modifiers 
La partie basse du panneau de droite représente la pile des modifiers dans l’ordre de leur exécution, il est 
possible de changer cet ordre. En utilisant dans l’entête du titre du modifier les pointeaux pour les monter ou 
descendre (voir ci-joint) 
 
 
Choisir le meilleur ordre pour l’application des modifiers pour le réacteur 

Etape 8 - Correction de l’application du modifier SUB-SURF sur la tuyère 
D’ABORD en Mode Edition et vue de coté : créer un edge loop sur le cône de la tuyère (voir figure de droite) 
PUIS  Déplacer sens X , le edge loop jusqu’à amélioration du défaut (voir figures ci-dessous) 
 
 
 
 
 
 
 
Résultat : Reserrage de l’adoucissement du subsurf 

Etape 7 - Obtention de l’objet REACTEUR  
D’ABORD Sélectionner le réacteur 
PUIS PanneauDroit > PanneauSubSurf > Bouton = Apply < clic 
Résultat : la fenêtre des paramètres se ferme : objet est créé 
 

4.7. PARTIE 3 – ASSEMBLAGE DES DIVERS ÉLÉMENTS 

1- Assemblage du corps et de l’helice du Réacteur 
D’ABORD Utiliser les pièces hélice et corps ainsi qu’une UVsphere déformée pour obtenir l’assemblage ci-
dessous. Assembler l’ensemble en un seul objet 
 
 
 
 
 
 
 
 
 
PUIS  Nommer le nouvel objet : Réacteur 
 
 2- Assemblage du Robot , Surf et des réacteurs 
D’ABORD Duppliquer le réacteurs 
PUIS  Assembler l’ensemble des objets pour obtenir la structure ci contre 
PUIS  Ajouter le material et la texture du Robot 
PUIS  Ajouter à l’ensemble de material MaterialROUILLE du paragraphe 3-3 

4.8. AJOUTER DU REEL A LA SCENE- TEXTURE NIVEAU 1 

Remarque préliminaire : Pour mettre en valeur l’objet robot, il faut créer un 
espace scénique et ajouter un décor de fond on a choisi une photographie 
du Paysage de la planète Mars 
 
Attention !!! Vérifier que le moteur de rendu choisi est « Cycles -
Render » pour avoir la possibilité de voir les rendus en temps réel 
 1- Préparation de l’objet DECOR pour le reception de la texture de la photographie 
D’ABORD Créer à partir d’un plan la figure ci-contre  
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PUIS  Nommer le « DECOR » 
Remarque rappel : Pour pouvoir appliquer une image (texture) sur cette objet simple IL FAUT demander à 
blender de la DEPLIER à PLAT ( Unwrap : déballer) 
PUIS  Transformation de l’espace de travail : espace édition des formes dépliées (voir vue écran ci-dessous) 
  PanneauInfo >Case = Icône de [Default]  > Entrée = UVEditing 
Remarque : l’ensemble de l’écran est transformé en deux panneaux : le panneau gauche > PanneauU/V editing 
où seront représenté les dépliages et le panneau de droit où l’on reconnaît le panneau 3DView  
 
Objectif : Dépliage du fond de scène 
D’ABORD Panneau3DView > Sélectionner l’objet « DECOR » 
PUIS  Passer en Edit Mode  et Sélectionner tout ;  
PUIS  Panneau3DView > Barrelenus > Menu = Mesh > Entrée = UV/Unwrap >   
 sEntrée = Unwrap < clic  
Résultat : la forme dépliée apparaît dans le PanneauU/V editing :  (voir figure) 
PUIS  Remettre Affichage en mode ordinaire 
  PanneauInfo >Case = Icône de [UVEditing]  > Entrée = Default 
 
Objectif : Création d’une texture sur l’objet DECOR à partir 
d’un photographie  
Moyen : Utilisation du NodeEditor nœuds (voir paragraphe 3-3) 
D’ABORD Transformation PanneauAnimation (en bas) en 

PanneauNodeEditor (abréviation PanneauNE)  
 Mettre la souris à la jonction entre Panneau3DView et 

PanneauNE et en appuyant sur le bouton gauche tirer vers le 
haut  

 PanneauAnimation > BarreMenus > PremierIcone > Entrée = Node Editor 
Résultat : le panneau node editor vide apparait sera apelée (Voir vue ECRAN)  
 
 2- Utilisation de PanneauNE pour créer la texture sur le plan de décor de fond 
PRINCIPE : création d’un material opaque sur l’objet DECOR  pour « supporter » la projection de l’image 
D’ABORD  Créer un Noeud qui représente la sortie-affichage du matérial sur l’image de rendu :  

PanneauNE > BarreMenus > Case = New < clic 
 
Résultat : d’une part PanneauNE> BarreMenus > Case = New < « Material.001 » 
et d’autre part  dans l’espace de construction des nodes on a la structure nodale 
du material de base : Diffuse BSDF 
 
 3- Application d’une photographie (texture) sur le plan décor 
D’ABORD PanneauNE > BarreMenus > Menu = Add > Entrée = Texture > SousEntrée = Image texture 
PUIS   NodeImageTexture > Case = Open < ( utiliser Explorer > fichier = MARS.JPG) 
ENFIN NodeImageTexture > Sortie =Color -- à relier avec -- NodeDiffuseBSDF > Entrée =Color  
 
 
 
 
 
 
 
 
Remarque : Vérification de l’affichage en modeobjet : Panneau3DView > BarreMenus > Case = Display < rendu. 
Il se peut que le résultat soit en saturation (Blanc), dans ce cas aller dans le panneau Outliner, sélectionner le 
lampe, et dans le PanneauNE > NodeEmission > Case = Strength < diminuer la valeur !!! 
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 4- Donner une apparence de relief à l’image du DECOR 
Objectif : Ajouter une impression de relief au sol martien > Notion d’image displacement pour cela on utilise une 
image spéciale NOIR et BLANC (niveaux de gris) créée sous GIMP (utilitaire Unsane voir ANNEXE 1) 
D’ABORD PanneauNE > Menu=Add > Entrée=Texture > SousEntrée=Image texture 
PUIS  NodeImageTexture > Case =Open < ( utiliser Explorer > fichier = MARS_d.JPG) 
PUIS  NodeImageTexture > Sortie =Color -- à relier avec -- NodeDiffuseBSDF > Entrée =Displacement 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Remarque : en coupant le lien et en le reconnectant entre de deuxième Image texture et Output on peut voir la 
différence dans le rendu ! 
 

4.9. AJOUTER DISPARITION DU ROBOT– ADDONS ET PARTICULES 

 
• PREMIÈRE PHASE : ACTIVATION D’OUTILS SPÉCIALISÉS : ADD-ONS 

PanneauInfo > BarreMenus > Menu=Fichier > Entrée = User Préférences … 
D’ABORD Fenetre User Preferences > Bouton = Recherche < taper(« tools ») 
PUIS    Cocher les trois addons : Mesh LoopTools, Objects :Bool Tools ; Object : Fracture Tools 
PUIS  > Bouton Recherche < taper(« land) 
PUIS   Cocher addon : AddMesh: A.N.T. Landscape 
PUIS  Enregistrer les Add-ons : Bouton = Save User Settings < clic 
Remarque : Descriptif des Add ons 
 Mesh Loop Tools : Permet relier des edge loops qui se font face à face, regulariser une courbe, 
harmoniser répartition des longueur 
Localisation/interface :  Mode Edit > Menu Spécials = Taper « W  >MenuContextuel > Entrée= Loop Tools 
 
 Objects Bool Tools : permet d’utiliser un objet « outil » afin d’agir sur un autre objet « passif » par 
découpe, assemblage … selon des opérations booléeennes : union, intersection différence symétrique … 
Localisation/interface : Panneau3DVew > Panneau gauche « T » > Onglet=Tools > paragraphe= Bool Tools 
 
 Object Fracture Tools : permet de subdiviser un objets en morceaux 
Localisation/interface : Panneau3DView > BarreMenus > Menu=Add > Entrée =Fracture Helper Object 
 
 A.N.T. Landscape : permet d’ajouter un mesh de type « Paysage Montagneux » 
Localisation/interface : Pannneau3DView > BarreMenus > Menu=Add > Entrée =Mesh > SsEntrée=Lanscape 
 

• DEUXIÈMEPHASE :  DISPARITION DU ROBOT: ANIMATION – NIVEAU 1 
 
Objectif : FAIRE disparaître PROGRESSIVEMENT LE ROBOT avec EMISSION de « grains de sable » 
Consigne : SUIVRE IMPERATIVEMENT l’ordre des étapes 
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1 – Vérification de l’homogenéité du Maillage  
Remarque : un maillage travaillé peut posséder des « trous » ce qui induit des erreurs  
 Recherche  des trous : 
D’ABORD ModeEdit > BarreMenus > Icones=  « Vertices » 
PUIS  BarreMenus > Menu=Select > Entrée=Select All by trait > SEntrée=NonManifold 
Résultat : les zones « trouées » sont sélectionnées, s’il n’y en a pas sauter l’étape suivante ! 
 « Remplissage » des trous : 
Première méthode :  
D’ABORD BarreMenus > Menu=Mesh > Entrée=Clean Up > SEntrée=Fill Holes 
Deuxième méthode : 
D’ABORD Selectionner l’edge loop du bord du trou (Alt + Souris) 
BarreMenus > Menu=Mesh > Entrée=Faces > SEntrée=GridFill 
 
2 – Mise en place de la disparition progressive du robot  
D’ABORD  ObjectMode se mettre en vue de face 
PUIS  Créer un cube qui englobe le ROBOT, appliquer les modifs, le positionner au dessus du robot,  
le nommer : CACHE 
Utilisation des booléens 
PUIS  Sélectionner (multiple) dans l’ORDRE : d’abord le CACHE puis le ROBOT 
PUIS  Panneau T  > Onglet=Tools > Paragraphe = Bool Tools > Brush Booléan = Difference 
Résultat : Le CACHE est en filaire et le déplacement du CACHE vers le bas fait disparaître le ROBOT 
 
3 – Animation de la disparition progressive du robot  
Principe : Enregistrement des positions clé du CACHE, Blender calcul l’interpolation entre les deux positions 
D’ABORD ObjetMode > se mettre en vue de face 
PUIS  Mettre le CACHE au dessus du ROBOT 
PUIS  BarreMenusAnimation > Positionner le curseur en 1 (début de l’animation)  
PUIS  BarreMenusAnimation >Menu=Object> Entrée=Animation > SEntrée= InsertKeyFrame 
  Ou Touche « I » > Menu = Insert KeyFrame >Entrée = LocRot (location and Rotation) 
PUIS  BarreMenusAnimation> Positionner le curseur en 150 (fin de l’animation = 150 frame) 
PUIS  Deplacer le CACHE verticalement vers le bas pour faire disparaître le ROBOT totalement 
PUIS  Touche « I » > Menu = Insert KeyFrame >Entrée = LocRot (location and Rotation) 
Résultat : Pour voir l’animation : Utiliser BarreMenusAnimation>Icônes Magneto (voir figure) 
 
 
 
 
 
 
 
 
 
 
 
4 – Création d’une zone de découpe qui emettra les particules   
Principe : Il suffit de faire une copie du groupe Robot-Cache (dans un calque différent ) puis sur la copie, on 
créée un seconde cube légèrement décalé vers la bas sur l’axe Z, afin d’obtenir une 
disparition du robot en haut par le premier cache, et en bas par le deuxième cache , reste 
entre les deux une tranche ! (voir disposition sur la figure) 
D’ABORD  On duplique l’ensemble CACHE-ROBOT dans le second calque en gardant 
surtout le même position.   
PUIS  on renomme le duplicata du calque 2 : TRANCHE et ROBOT-PART 
PUIS   dans ce deuxième calque en ME on duplique la face base du cube TRANCHE, 
PUIS  on déplace la face base légèrement vers le bas,  
PUIS  on l’extrude verticalement vers bas sous les pieds du ROBOT 

ETAT des icones 
sans défilement 

ETAT des icones au 
cours du défilement 

Activation défilement dans les deux sens 

Arrêt défilement dans les deux sens 

Caler au début Caler à la fin 
 

Remonter à la dernière frame Aller à la prochaine frame 
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Résultat : en Mode objet  en visualisant de défilement on voit la sélection d’une tranche du ROBOTPART se 
déplacer vers le bas c’est elle qui va émettre des particules 
En sélectionnant dans le second calque le robot, puis en visualisant les deux calques simultanément on peut voir 
la tranche se déplacer vers le bas avec la disparition du ROBOT (voir figure ci-dessous en Wireframe) 
 
 
 
 
 
 
 
 
5 - Emission des particules à partir de la tranche : Notion de Particules 
D’ABORD  ModeObjet > Calque deux > Sélectionner la tranche du ROBOT (figure ci-dessus) 
PUIS  PanneauProperties > BarreIcones > Icones = Particles 
PUIS  PanneauProperties > Bouton = New 
Résultat : Dans PanneauProperties le PanneauParticles s’affiche avec la liste de tous ses paramètres 
PUIS  PanneauParticles > Case = Settings > Renommer = taper(SABLE) 
PUIS   Paragraphe = Emission > Case = Number = 5000 (si ordinateur le permet !!) 
Résultat: Apparition de petits points à la surface supérieure de la tranche. Pour visualiser l’animation utiliser le 
Magneto 
Remarque : Correction d’un défaut (apparition d’un filament) 
 Fenetre Particles > Paragraphe = Émission > Case = Use Modifier < à cocher  
 
6 – Visualiser les particules en Mode Rendu 
Principe : les particles sont des points visibles en mode solide (signalisation des meshs), mais invisibles en 
mode Rendu ( point pas de dimension !) ,il faut leur associer un objet de taille suffisante pour être vues 
D’ABORD  ModeObjet > créer un Icosphere (taille = 0.2) de nom = SABLE 
PUIS Selectionner  la tranche ROBOTPART 
PUIS Panneau droit > Barre des Icones > Icones = Particles 
 PanneauProperties > PanneauParticles  > Paragraphe= Render > BarreCases > Case=Object < clic 
       Case Dupli Object = Selectionner (SABLE) 
       Case Size = (à regler) 
Remarque : Visualiser en animation 
 
 7 – Réglage de la vitesse de descente des particules 
Principe et Réalisation du réglage:  Les particles sont soumises à une simulation de la gravité terrestre suivant 
l’axe Z, avec une accélération de 9.81 m/s², il suffit de modifier cette valeur pour changer la gravité. 
D’ABORD Sélectionner PanneauProperties > BarreIcones > Icone = Scène 
PUIS  PanneauScene > Paragraphe = Gravity 
  Modifier la case Z= (- 9.81) selon les besoins : -1 est conseillé (bon effet !) 
Résultat : Visualiser l’animation voir figure ci dessous 
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5. Travail sur le Rendu d’une scène : Notion de compositing 
Exercice : Mise en relief du filament éclairé d’une Ampoule (Cycles Render) 

Liste des points nouveaux abordés : symbole  
Modeling : Utilisation du Modifier SCREW 
Utilisation du Node Editor pour les matéral 
Description et utilisations des notions de RenderLayers (rendu par niveau) pour les parties d’un objet 
Utilisation du Node Editor pour le Compositing (composition) 
 

Objectif : Créer une Ampoule sur un fond et  traiter l’éclairage du filament  

5.1. MISE EN PLACE DES OBJETS ET DES MATERIALS D’AFFECTATION 
• PREMIÈRE PHASE : CONSTRUCTION DU FILAMENT : APPLICATION DU MODIFIER SCREW 

 1-  Obtenir l’hélice de la partie supérieur du filament  (voir note 1 – autre méthode) 
D’ABORD Se mettre en vue Top 
PUIS  Créer au centre de Univers un « cercle » 
PUIS  PanneauVew3D > BarreMenu > Menu = Mesh > Entrée = Circle 
PUIS  Panneau T > MenuEphemere > Case = Vertices < 20 
PUIS  EditMode > Déplacer le cercle sur X ou Y de telle sorte que le centre soit hors de la zone du cercle. 
PUIS  Sélectionner le « cercle » 
PUIS  PanneauProporties > BarreIcones > Icône = Modifier  > Bouton = AddModifier < clic 
   MenuContextuel > Liste = Generate > Entrée = Screw < Clic 
PUIS  Réglages : PanneauScrew > Case = Axis  < Choisir Y 
Résultat : On obtient pour le bon axe un anneau  
  Choisir Vissage d’enroulement : Case Screw (Filament < 3) 
  Choisir l’angle de rotation autour de l’axe : Case Angle (Filament < 360) 
  Choisir le nombre de segments par tour : Case Steps (Filament < 16) 
  Choisir le nombre de tour : Case Flip > Intérations : (Filament < 3) 
 2- Modelage du filament à partir de l’hélice 
 D’ABORD Edit Mode > Modifier le cercle de base sélectionné pour la section.  
Toute transformation de celui-ci agit sur l’ensemble de l’hélice (Loc, Rot, Scale) 
PUIS  Appliquer le Modifier 
  PanneauProperties > PanneauScrew > Bouton = Apply < clic 
PUIS   Modeler le filament  pour obtenir la figure ci contre : 
PUIS  Nommer l’objet : Filament 
 

• DEUXIÈME PHASE : MODELAGE DE L’ENSEMBLE VERRE ET CULOT 
D’ABORD Mettre la spire du filament au centre de l’univers. 
PUIS   Object Mode > Wireframe 
PUIS  Ajouter une UVsphere englobant les 2/3 de la partie haute du filament   
PUIS  Mettre le filament sur le calque 2 
PUIS  Effectuer le modelage de la lampe pour obtenir le résultat de la figure ci-dessous  
PUIS   Nommer l’objet : Ampoule 
 
 
 
 
 
 
 

• TROISIÈME PHASE : AFFECTER DES MATÉRIAUX SELON LES PARTIES DE L’AMPOULE 
 
D’ABORD En Edit Mode 
  Créer deux materials 
  Material : METAL (pour le culot 
  Material : VERRE (pour le haut) 

NODE : AnIsotropic BSDF NODE : Material OUTPUT 
< BSDF 

Surface > 

NODE : Glass BSDF NODE : Material OUTPUT 
< BSDF 

Surface > 

Partie culot (Métal) Partie éclairage (Verre) 
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PUIS  Assigner les matériaux aux parties correspondantes (voir figure ci-dessus) 
 

• QUATRIÈME : PHASE : FAIRE UN DÉCORS  
D’ABORD En Object Mode 
  Se mettre en vue de Front 
PUIS  Ajouter un plan derrière l’ampoule 
PUIS  Développer le plan en UVMapping Mode 
PUIS  Ajouter un material de base : Diffuse BSDF par défaut 
PUIS  En Edit Node :  
Créer l’arbre de nodes ci-dessous (fichier Destroy 01.jpg est l’image de fond) 
 
 
 

• CINQUIÈME PHASE : POSITIONNEMENT DE LA CAMERA POUR LE RENDU 
D’ABORD Vérifier que Les Objets Filament et Ampoule sont bien à l’origine du Monde de Blender 
PUIS  Sélectionner l’objet plan du Decors 
PUIS  PanneauN > Paragraphe = Transformation > Case = Location : 
Exemple > Mettre X :  0 ; Y : 28 ; Z : 0 
PUIS  Sélectionner l’objet Camera  
PUIS  PanneauN > Paragraphe Transformation > Case = Location : 
PUIS  Mettre X :  0 ; Y : -24 ; Z : 0 
PUIS  Case = Rotation  
PUIS  Mettre X :  90 ; Y : 0 ; Z : 0 
PUIS  Visualiser sur le panneau View3D la vision de la camera  
  PanneauView3D > BarreMenu > Menu = View > Entrée = Camera < clic 
  (action de type bascule entre vue normale et vue camera) 
 

• SIXIÈME PHASE : SÉPARATION DU FILAMENT PAR COUCHE (LAYER) 
Remarque préliminaire : Un « layer » est espace 3D comportant ses objets propres. Chaque layer est accesible 
séparément en activant la case correspondante dans Panneau3DView > BarreMenus (Exemple : voir 
manipulation figure ci-dessous).  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Objectif : Séparer les objets dans des Layers différents  
D’ABORD Sélectionner l’objet Filament,  
PUIS  Taper au clavier « M » 
  Menu Contextuel = Move to Layer > Case Voulue < clic (selon la répartition ci-dessous) 
 
 

NODE : Image texture 
Fichier : Destroy 01 NODE : Diffuse BSDF NODE : Material OUTPUT 

< Color > 
< BSDF 

Surface > 

 
Représentation contenu : 
Point couleur  = Occupation par objet 
(ici le cube) sélectionné 
Fond grisé = Affichage sur scène du 
Panneau 3DView 

 
Représentation contenu : 
Point grisé= Layer non vide 
Point grisé = Occupation par objet  
Fond clair = non affiché sur scène 
 

Layer 1 

Layer 2 
 

Panneau3DView : 
Sélection = Layer1 

Panneau3DView : 
Sélection = Layer2 

Panneau3DView : 
Sélection simultanée = Layer2 et Layer 2 

Utilisation de la souris : 
Cliquer sur une case = Activation du later (case = fond grisé) 
Cliquer et Touche [Maj] maintenue sur plusieurs cases = 
Superposition des layers  (cases = fond grisée) 
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5.2. PRÉPARATION DU COMPOSITING SUR LES ÉLÉMENTS SÉPARÉS : FILAMENT, DÉCORS …  
• PREMIÈRE PHASE: CRÉATION DE RENDUS SÉPARÉS ET RÉPARTITION DE ESPACE TRAVAIL 

Principe : « RenderLayer » signifie « Couche de rendu ». « Compositing » ou composition :  l’idée c’est d’abord 
de séparer les objets sur chaque RenderLayer, de traiter spécifiquement et enfin de les superposer. 
 
1  – Création des RenderLayers pour isoler le « Filament » 
D’ABORD PanneauProporties > BarreIcones > Icone = RenderLayer < Clic 
PUIS  PanneauRenderLayers  > Cadre = Pile RenderLayers ( figure ci contre) 
PUIS   Renommer le premier > DecorsLampe 
PUIS  Bouton = « + » >Ajouter un RenderLayer dans la pile dans l’ordre  
  et le nommer « Filament » suivant la figure ci-contre  
  (les cases cochées montrent les layers pris en compte pour le rendu final – la scène) 
Remarque : c’est cela qui permet la séparation du calcul des rendus : un par layer et/ou travail de material 
spécial pour certain objet > ici ce sera le Filament 
PUIS : PanneauRenderLayers >  Paragraphe = Layer : Établissement des liens entre les RenderLayers créés 
dans la pile et les objets de la scène (voir extrait de la fenêtre du PanneauDroit ) 

Etape 1-Premier Layer de la Pile : DecorsLampe  (Suivre la chronologie des commentaires) 
 
 
 
 
 
 
 
 
 
 
 
 
 

Etape 2-Deuxième Layer de la Pile : Filament (Suivre la chronologie des commentaires) 
 
 
 
 
 
 
 
 
Remarque : On veut ici un traitement spécifique de l’objet filament, c’est pourquoi il est isolé dans un renderlayer 
 
2 – Préparation de l’espace de travail de compositing 
D’ABORD Séparer le panneau central en deux panneaux horizontaux :  
PUIS  PanneauHaut  > IconeType = UV Image Editor qui sera appelé PanneauUVI 
PUIS  PanneauBas > IcôneType = Node Editor Editor qui sera appelé PanneauNE 
 

Ensemble : Décors, Ampoule, Filament 

Filament 

LAYER 1 

LAYER 2 

 DecorsLampe 
 Filament 

D’ABORD : 
Sélectionner le render Layer 

dans la pile 

Scène : (ensemble de TOUS les layers ) Layer : (pris en compte pour «DecorsLampe») 

PUIS : 
Cocher  la case qui correspond 
au DecorsAmpoule 

D’ABORD : 
Sélectionner le render Layer 

dans la pile 

Scène : (ensemble de TOUS les layers ) 
Layer : (pris en compte pour « Filament ») 

PUIS : 
Cocher  la case qui correspond 

UNIQUEMENT à Filament 

Reste : Décors, Ampoule 

LAYER 1 

Case choisie dans 
Grille du menu contextuel 

AVANT 
Grille layers BarreMenus 

APRES 
Grille layers BarreMenus 

 DecorsLampe 
 Filament 

 DecorsLampe 
 Filament 

Exclude : (pris en compte pour « DecorsLampe ») 

PUIS : 
Cocher  la case qui exclue le filament 
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3 – Création des premiers rendus associés à chaque layer 
Dans PanneauProporties > BarreIcones > Icône=Render < clic 
D’ABORD Paragraphe = Film > Case = Transparent < Coche (permet d’avoir un fond transparent) 
PUIS  Paragraphe = Render > Case= Render < Clic 
Résultat : Dans PanneauUI , affichage du premier rendu correspondant au layer « DecorsLampe » puis du 
deuxième rendu correspondant au Layer « Filament » 
Remarque : on peut visualiser les deux rendus séparément dans le PanneauUVI en utilisant : 
D’ABORD PanneauUI > BarreMenu > Menu = « Composite » < clic , le menu déroulant affiche les (render)layers 
qui peuvent être visualisés – Laisser sur « Composite » (dont on verra la nature dans la suite) 
 
4 - Configuration des nodes de renderlayers dans PanneauNE  
D’ABORD PanneauNE > BarreMenus >Case = compositing < clic et Case = Use Node < coche 
Remarque : Apparition de deux nodes connectés qui correspondent à l’affichage du Panneau UV 
 
 
 
 
 
 
 
 
PUIS  PanneauNE > BarreMenus > Case = Backdrop < coche (permet affichage en image de fond) 
ENFIN BarreMenus > BarreCaseCanaux > Case = Channels of image to draw < Clic 
Remarque : Un rectangle noir de fond s’affiche dans le PanneauNE : il permettra d’afficher les résultat du travail 
sur les divers RenderLayers 
Attention !!! : la dernière action est importante(sinon aucun effet spécial coloré sera visible !!!! 
0n a l’état de l’affichage ci –contre 
 
 
  
 
 
 

5.3. DEUXIÈME PHASE : COMPOSITING OU TRAVAIL DE MODIFICATION DE L’APPARENCE SUR LE FILAMENT 

 
1 - Création d’une branche de rendu pour le filament 
 D’ABORD  PanneauNE > BarreMenus > Menu = Add > Entree =Input > SousEntrée = RenderLayers 
Résultat : Appartition d’un nœud « RenderLayer » dans la fenêtre de 
visualisation du PanneauNE. Celui-ci est pour l’instant isolé (identique à 
celui connecté à Composite, mais non connecté au reste) 
PUIS  Node=RenderLayers > Case = « DecorsLampe » > Entrée = 
« Filament » < clic 
Résultat : l’ image interne du node change : le filament seul est affiché 
PUIS   Affichage du rendu du filament en arrière plan de la fenêtre des 
visualisation du PanneauNE 
PUIS  Mettre le souris sur le titre du Node appuyer sur :  
  [ctrl]+[Maj]+clic gauche 
Résultat : Comme le montre la figure ci-contre, le « Filament » apparaît en arrière plan, ceci est du à l’ajout du 
Node nouveau « Viewer » qui s’est connecté automatiquement au renderLayer du Filament 
2 - Création des effets sur le filament 

Etape 1 -  Ajout d’un effet de FLOU à lumière sur le filament 
   PanneauNE > BarreMenus > Menu = Add > Entree =Filter > SousEntrée = Blur (Flou) 

Node d’entrée (input) 
Type : Couche de rendu (renderlayer) 
Correspondant au layer de la pile : 
« DecorsLampe » (en bas) 
 

Node de sortie (output) 
Type : Composition (composite) 
Correspondant à la production du rendu 
définitif dans la fenêtre du Panneau *UVI 

Panneau du Node Editor 
 

Panneau du UV/ImageEditor 
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Résultat : Un nouveau node « Blur » est ajouté, en le 
connectant à la branche qui va du renderLayer «  Filament » 
au « Viewer » , et en règlant dans le node « Blur » 
 Case X : 14 (effet horizontal du flou) 
 Case Y : 20 (effet vertical du floiu), 
On peut voir en temps réel sur l’image de fond le résultat. 
 
 

Etape 2 - Ajout d’un effet d’EBLOUISSEMENT à lumière sur le filament 
  PanneauNE > BarreMenus > Menu = Add > Entree =Filter > SousEntrée =Glare (Eblouissement) 
Résultat : Un nouveau node « Glare » est ajouté,il faut connecter la sortie du renderLayer « Filament » sur 
l’entrée ( pont jaune image à gauche du node) du node « Glare ». 
PUIS  Connecter  « Glare » sur le « Viewer » 
Résultat : le lien « Blur » « Viewer » est automatiquement 
coupé, c’est normal une seul entrée est possible, la suite 
montrera comment combiner plusieurs entrées, par contre le 
nouvelle éffet est affiché en arrière plan  
PUIS   Node « glare » on règle comme suit : 
  Bouton « Streak » > entrée = « Ghosts  
  Case Itérations : 4 
  Case Color Modu : 1  (nombres de couleurs du spectre) 

Etape 3 - Regroupement  des nodes d’effet sur le filament 
D’ABORD  Déconnecter les nodes  
PUIS   Regrouper les nodes associés au filament  dans l’ordre suivant  en ménageant un espace assez 
grand devant le « Viewer » (place pour ajouter un node): 
 
 
 

Etape 4- Ajouter un node de « combinaison de node » et connecter les nodes 
D’ABORD PanneauNE > BarreMenus > Menu = Add > 
Entree =Color > SousEntrée =Mix 
Résultat : Un nouveau node « Mix » est ajouté. 
PUIS  Raccorder l’ensemble des nodes issus du render 
Layers « Filament » comme le montre la figure ci-contre. 
PUIS  Dans le node « Mix » on règle comme suit : 
  Bouton « Mix » > entrée = « Add » 
Résultat : En fond on voit l’addition des deux effets. 
 

Etape 5 - Regroupement du Filament et du DecorsLampe et correction des surexpositions 
D’ABORD Ajouter un node de « combinaison de node » 
  PanneauNE > BarreMenus > Menu = Add > Entree =Color > SousEntrée =Mix (mélange des layers) 
PUIS  Ajouter un node de correction BrightContrast 
  PanneauNE > BarreMenus > Menu = Add > Entree =Color > SousEntrée =BrightContrast (correction) 
Résultat : Un nouveau node « Mix » et le node 
 « BrightContrast »sont ajoués. Raccorder l’ensemble des nodes  comme le montre la figure ci-contre. 
PUIS  Dans le node « Mix » on règle comme suit : 
  Bouton « Mix » > entrée = « Add » 
PUIS  Dans le node « BrightContrast » régler selon les cas (ici Brigtht=60.2, Contract = 27) 
Résultat : En fond on voit l’addition des deux effets. 
 

Etape 5 - le fin du fin :  réglage de la profondeur de champ en fonction du focus de la 
camera sur le filament 

D’ABORD Réglage du focus de la camera sur le filament 

Render Layers 
Filament 

Blur 

Glare 

Viewer 
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Edit Mode > Mode solide : sélectionner la caméra 
PanneauDroit > BarreIcones > Icones = Camera >
  Paragraphe = Depth of Field > Case = Focus >  
  Sous Entrée = choisir (Filament) 
PanneauNE > BarreMenus > Menu = Add >  
  Entree =Filter > SousEntrée =Defocus 

PUIS  Intercaler le node « Defocus » entre le dernier 
node « Add » et le « Viewer » 
PUIS  Connecter l’entrée « Z » de « Defocus » à la 
sortie « depth » du node « DecorsLampe » (position profondeur dans le renderLayer «  DecorsLampe »)   
PUIS  Node = « Defocus » = Case= « Use Z-Buffer » < cocher (va renvoyer la mise au point de la camera sur 
le filament) 
PUIS   Brancher l’arbre des Nodes sur la sortie composite pour le rendu final 
Remarque : Il suffit de débrancher le node « viewer » et de le remplacer par le node « composite » et de lancer 
le rendu. 
PUIS  PanneauDroit > BarreIcones > Icône=Render < clic 
PUIS  Paragraphe = Render > Case= Render < Clic 
Résultat : Dans PanneauUI , affichage du premier rendu correspondant au layer « DecorsLampe » puis du 
deuxième rendu correspondant au Layer « Filament » enfin le rendu final est affiché. 
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6. Utilisation des textes et des particules (Cycles Render) 
Exercice : Créer une simulation dans laquelle un texte se dissout en  particules 

de plus en plus fines 

Liste des points nouveaux abordés : symbole  
Notion d’objet non maillé : les textes 
Notion de système de particules ponctuelles et animation  
Notion de Champ de force’ (Force Field)  
Notion de Corps physique (consistance simulant lde réel : les objets « se heurtent ») 

 

6.1. MISE EN PLACE DU TEXTE : CRÉATION, POSITION, MODELAGE ET CONVERSION DE TYPE MAILLAGE 

D’ABORD Panneau3Dview>Barremenu > Menu = Add > Entrée = Text < Clic 
PUIS  Mode Edit : Modifier le Texte 
Rappel : En mode edit le curseur (rectangle vertical blanc) apparaît comme dans un traitement de texte ordinaire. 
Utiliser les fonctionnalités connues pour changer le contenu du texte.  (ici on a choisit « Dolmen ») 
PUIS   Object Mode : Faire une rotation d’axe X de 90° 
PUIS  Se positionner face au texte sélectionné 
PUIS  PanneauProperties > BarreIcone > Icône = Texte > Paragraphe = Geometry 
   Bouton Extrude < 0.05  (réglage Epaisseur du texte) 
   Bouton Bevel < 0.02  (réglage Biseau de bord du texte) 
   Bouton Bevel : Resolution < 2 (réglage Arrondi du biseau) 
PUIS  Ajouter un Material > « Jaune »  
PUIS  Conversion du texte en Maillage :  
  Panneau3DView > BarreMenu > Menu = Object > Entrée = « Convert to … »  

 sEntrée = « Mesh from Curve/Meta/Surf/Text » 
PUIS  Nommer le “TEXTE” 
Remarque : On a souvent intérêt à retirer les points doublés lors de conversion pour éviter les défauts de rendu :  
 En mode Edit : PanneauT > Onglet = Tools > Paragraphe = Remove  > Bouton = Remove Doubles < clic 

6.2. MISE EN PLACE DE L’ANIMATION 

D’ABORD Dimension du film en nombre de  « Frames » (images) 
PanneauDroit > BarreIcone > Icône =  Render > Paragraphe = Dimensions > Bouton = End Frame < 135 
Remarque :  Pour l’instant on ne touche pas au reste (Vérifier : Frame Rate = 24 frame / seconde réglage 
standard). Regarder dans la barre d’animation la concordance des paramètres du film comme le montre la figure 
ci-dessous. 
 
 
 
 

6.3. MISE EN PLACE DES PARTICULES SUR LE TEXTE 
• PREMIÈRE PHASE : CRÉATION DU SYSTÈME DE PARTICULES  

D’ABORD Sélectionner le maillage TEXTE 
PUIS  PanneauProporties > BarreIcone > Icône = Particule > Panneau Particule > Bouton = new < clic 
PUIS  Nommer le système de particules : « SABLE » 
Résultat : le panneau particule se développe, dans le cadre-pile apparaît « ParticleSystem » le nom du nouveau 
système de particules ajouté à l’objet sélectionné. Nous l’appelrons Panneau Particles. On peut visualiser les 
particules en utilisant les boutons de lecture de la barre d’animation. 
Remarque et Conseil : la liste de paragraphes étant importante,  fermer tous les paragraphes pour mieux lire. 
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• DEUXIÈME PHASE :  RÉGLAGE DE RENDU DU SYSTÈME DE PARTICULES 
D’ABORD PanneauParticles > Paragraphe = Emission  
 D’ABORD   Nombre = 1000  (pour l’instant > éviter temps réponse lourd voir plantage machine !) 
 PUIS   BoutonStart = 20  (réglage du début de l’émission des particules en frame 20) 
   BoutonEnd = 30 (en frame 30 : toutes les particules auront été émises) 
   BoutonLifeTime = 100 (les particules auront une durée de vie de 100 frames) 
 PUIS  BarreCases  =  Verts / Faces / Volume > Case = Faces < clic 
 PUIS  Vérifier que les cases : « Random » et « Even Distribution » sont cochées 
Remarque : En mode « rendered » : rien n’apparaît ! Normal : les particules ne sont que des points sans 
dimension. Il FAUT affecter aux particules une forme de dimension visible au rendu comme suit. 
 PUIS  Créer un objet : ICOsphere, lui affecté à cette objet le material « Jaune » créé pour le texte et la 
nommer « GRAIN » 
 PUIS  sélectionner l’objet TEXTE   
 PUIS  Panneau Particles > Paragraphe = Render 
   BarreCase = None/Halo/Line/Path/Object/Billboard > Case = Object < clic 
   Case = Dupli Object < sélectionner “Particule” ( ICOsphere précédemment créée !) 
Résultat : Lancer l’animation et vérifier la présence des particules en rendu 
   Case = Size < 0.01  (réglage de la taille des particules) 
Remarque : Placer l’icosphere modèle dans le layer 2 pour éviter de la voir au rendu ! 
 

• TROISIÈME PHASE : RÉGLAGE DES DÉPLACEMENTS DU SYSTÈMES DE PARTICULES 
D’ABORD PanneauDroit > PanneauParticles > Paragraphe = Fileds Weights 
  Bouton Gravity < 0 (annulation de la gravité) 
Résultat : Lors de l’animation les particules restent au voisinage du texte, elles ne tombent plus ! 
ENFIN PanneauDroit > Panneau Particles > Paragraphe =Velocity 
  Bouton Normal < 0 (annulation de la vitesse initiale normal à la surface émettrice) 
Résultat : Lors de l’animation les particules restent « collées » au texte. 
 

6.4. MISE EN PLACE D’UNE TURBULENCE POUR « FAIRE VOLER ET DIMINUER » LES PARTICULES 
• PREMIERE PHASE : APPLICATION D’UNE TURBULENCE AUX PARTICULES 

D’ABORD Positionner le curseur au centre de l’univers ( début du texte) 
PUIS  Panneau3Dview > BarreMenus > Menu = Add > Entrée = ForceField > sEntrée = Turbulence 
Résultat : Présence d’un Empty qui matérialise l’origine de la turbulence 
PUIS  Positionner « Empty » au centre du texte  
ENFIN PanneauProporties > BarreIcone > Icône = Physics < clic 
   Paragraphe = Force Fiels > Case Strength < 2 
Résultat : Lors de l’animation les particules se dispersent en nuage !  
 

• DEUXIÈME PHASE  PHASE : RÉGLAGE DE LA DISPARATION DU TEXTE APRÈS L’ÉMISSION DES PARTICULES  
Principe : l’apparition ou la dispartition au rendu de l’objet qui émet les particules, est rélisé par la case 
« Emitter » du paragraphe Render : cocher ou pas. Il suffit de mémoriser gans l’animation état de cette clé pour 
simuler la dispartition de l’objet au moment voulu (lorsque les particules sont toutes émises !) 
D’ABORD Sélectionner le texte 
PUIS  PanneauAnimation > Placer le curseur = 1 
PUIS  Placer la souris sur  > Panneau Particles > Paragraphe =Render > Bouton = Emitter (état coché) 
PUIS  Cliquer Droit > Menu Contextuel= « Emitter » > Entrée = « Insert KeyFrame » < clic 
Résultat : le bouton prend une couleur jaune , et dans la barre d’animation sous le curseur apparaît un trait clair  
la coche du bouton « Emitter » est enregistrée à la frame 1 :  la source des particules : le texte sera affichée au 
début de l’animation) 
Remarque : dans la suite nous appellerons cette action : Mémorisation Emitter 
PUIS  PanneauAnimation > Placer le curseur = 40 > Décocher la case Emitter et Mémoriser Emitter 
Résultat : le texte sera donc apparent jusqu’à le frame 40 où il disparaitra ! 
 

• TROISIÈME PHASE : DIMINUTION DES PARTICULES APRÈS DISPARITION DU TEXTE 



 

 43 

Principe : Même principe que précédemment mais sur la Case = Taille des particules 
D’ABORD Sélectionner le texte 
PUIS  PanneauAnimation > Placer le curseur = 70 
PUIS  Placer la souris sur  > Panneau Particles > Paragraphe =Render > Bouton = Size 
PUIS  Cliquer Droit > Menu Contextuel= « Size » > Entrée = « Insert KeyFrame » < clic 
PUIS  PanneauAnimation > Placer le curseur =130 
PUIS  Cliquer Droit > Menu Contextuel= « Size » < 0.01 
ENFIN  Cliquer Droit > Menu Contextuel= « Size » > Entrée = « Insert KeyFrame » < clic 
Résultat : Les particules émises entre les frames 70 et 130 vont diminuer de la taille 0.05 à 0.01 pour rester à 
0.01 jusqu’à la fin  
 

6.5. MISE EN PLACE D’UN PLANCHER AVEC  REFLET POUR « RETENIR » LES PARTICULES 

D’ABORD  Ajouter un plan juste sous le texte (Taille 30) 
PUIS   Ajouter le matérial de la figure ci-dessous (type blanc avec aspect reflet) 
 
 
 
 
 
 
 
 
 
 
 
PUIS  Selectionner le plan 
PUIS  PanneauDroit > BarreIcone > Icône = Physics > Bouton = Collision < clic 
ENFIN  Légèrement surelever le texte / Plan (éviter le départ des particules au travers de l’intersection) 
Remarque : les particules qui tombent sur le plan rebondissent avant de disparaître  
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7. Animation Niveau 1 : Les clef-Images (KeyFrame) (Cycles Render) 
Exercice : Faire se déplacer en translation un cube, d’une position A à une 

position B en le faisant passer de la couleur bleu à la couleur rouge 

Liste des points nouveaux abordés (symbole) 
Animation avec Keyframes (clefs images) sur divers paramètres d’objet : directement sur l’objet ou sur ses propriétés 

 

7.1. ANIMATIONS DES COULEURS DU CUBE : KEYFRAME SUR CASE D’UN PANNEAU 

On suppose ici que le cube par defaut de blender à l’ouverture est en place, sinon ajouter un cube. 
 

• PREMIÈRE PHASE : MISE EN PLACE D’UNE CLEF IMAGE (KEYFRAME) SUR LA COULEUR DE L’ OBJET CUBE :  
Principe : les deux actions doivent être exécuter dans l’ordre chronologique qui suit : 
D’ABORD  Positionner le curseur d’animation sur la première image ( frame) 

PanneauAnimation > BarreMenu > Case = Position Curseur < 1 (figure ci-dessous) 
 
 
 
 
 
 
 
 
PUIS  Créer une première couleur pour le cube (bleu par exemple)  
  PanneauDroit > BarreIcones > Icône = Material < clic 
     Case = Diffuse Color < choisir dans le cercle de couleur < bleu 
PUIS  Mémoriser la couleur dans la première keyframe 
  Positionner le pointeur de la souris sur la case précédente : Diffuse Color et Clic droit 
     Dans le menu contextuel > Entrée = Insert Keyframe 
Résultat : L’entourage de la case change de couleur : passage en jaune. Et dans la PanneauAnimation sous le 
curseur (vert) apparaît un trait jaune : cela signifie que l’état de la couleur est mémorisé à la frame 1 
 

• DEUXIÈME PHASE : MÉMORISATION D’UNE AUTRE COULEUR DE L’OBJET « CUBE », EN FRAME 30  
D’ABORD  Positionner le curseur d’animation sur l’ image ( frame) 30 
   PanneauAnimation > BarreMenu > Case = Position Curseur < 30 
Résultat : Dans le PanneauAnimation le Curseur (vert) se positionne en framme 30 dans la ligne du temps. 
PUIS   Changer la couleur du Cube  (rouge par exemple) 
   Case = Diffuse Color < choisir dans le cercle de couleur < rouge 
PUIS   Mémoriser la couleur dans une deuxième keyframe 
   Positionner le pointeur de la souris sur la case précédente : Diffuse Color et Clic droit 
     Dans le menu contextuel > Entrée = Insert Keyframe 
 

• TROISIÈME PHASE : VISUALISATION DE L’ANIMATION DU CHANGEMENT DE COULEUR : 
 Dans le PanneauAnimation < BoutonLecture < clic (voir figure) ou appuyer les touches [Ctrl] + [A] 
 
   
 
 
 
Remarque : les boutons correspondent aux codes usuels de n’importe quel lecteur multimédia. 

Curseur indiquant la frame active 

Ligne du temps des frames de l’animation du début à la fin 

 

Frame de début de l’animation Frame de fin de l’animation Frame de la position du 
Curseur dans l’animation 

Bouton Lecture 
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7.2. ANIMATION DES COULEURS ET DES POSITIONS DU CUBE : KEYFRAME SUR POSITION DANS PANNEAU3DVIEW 

 Le Principe est le même que précédemment : on positionne le curseur d’animation sur une frame, on 
effectue une action dans le monde des objets et on mémorise dans une keyframe les paramètres correspondant 
à l’action. 
D’ABORD Positionner le curseur d’animation sur l’ image ( frame) = 1 
PUIS  Panneau3DView > Sélectionner le Cube 
PUIS  Appuyer la touche [I] > Menu Contextuel > Entrée = Location (mémorisation de la position du cube) 
PUIS  Positionner le curseur d’animation sur l’ image ( frame) = 130 
PUIS  Déplacer le cube dans la position voulue : exemple 3 unités sur l’axe des X 
PUIS  Appuyer la touche [I] > Menu Contextuel > Entrée = Location (mémorisation de la position du cube) 
Résultat : En remettant le curseur au début, on lance la lecture : le cube passe de la position 1 en bleu, à la 
position 2 en rouge 
 

7.3. FORMALISATION DES ACTIONS PERMETTANT DE CRÉER UNE ANIMATION 

Rappel du principe en trois temps et de sa répétition: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Positionner le curseur dans la ligne 
de temps de l’animation 

Positionner la souris au dessus de 
la case ou bouton à mémoriser 

Cliquer droit 
 Dans menu contextuel 
 Entrée = Insert Keyframe 

Appuyer la touche [I] 
 Dans menu contextuel 
 Entrée = Location (pour la position) 
 Entrée = Rotation (pour la rotation) 
 Entrée = Scale (pour le scale) 
 Entrée = LocRotScale (pour les trois) 

S’agit-il d’un déplacement ? 

OUI NON 

Exécuter l’action voulue sur l’objet 
dans le Monde de Blender  
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8. Animation Niveau 2 : Utilisation de l’espace de travail « Animation » de Blender  
Exercice : Simulation de choc de deux objets un cube et une sphère en 

translation  (Cycles Render) 

Liste des points nouveaux abordés symbole (symbole): 
Animation avec Keyframes (clefs images) , modification de l’interpolation automatique créée par Blender à l’aide des représentations en courbes 
et en points des espaces de travail :  GrapheEditor et DopeSheet 

 
On suppose que un cube (coté 2) en coordonnées (-5,0,0) et une UVsphere (5,0,0) (rayon 1) donc face à face 
sur l’axe des x . (La view front est conseillée !) 

8.1. PARTIE 1- ANIMATION DES OBJETS  

Le tableau suivant donne la chronologie des actions à éffectuer : 
Chronologie : Actions Objet Cube Objet Sphère 

Panneau Animation 
Mettre  
le curseur d'animation en position > 

Frame = 1 Frame = 1 

Panneau N > Paragraphe = Transform 
Positonner l'objet en > Coordonnées (-5,0,0) Coordonnées (5,0,0) 

Clavier > 
Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Vérification enregistrement keyframe 

PanneauN > Paragraphe=Transforme > 
Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

PanneauN > Paragraphe=Transforme 
> Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

Panneau Animation 
Mettre le curseur d'animation en position 
> 

Frame = 40 Frame = 40 

Panneau N > Paragraphe = Transform 
Positonner l'objet en > Coordonnées (-1,0,0) Coordonnées (1,0,0) 

Clavier :  
Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Vérification enregistrement keyframe 

PanneauN > Paragraphe=Transforme > 
Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

PanneauN > Paragraphe=Transforme 
> Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

Panneau Animation 
Mettre  
le curseur d'animation en position > 

Frame = 60 Frame = 60 

Panneau N 
Positonner l'objet en > Coordonnées (-4,0,0) Coordonnées (4,0,0) 

Clavier > 
Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Insérer un Keyframe :  
     Appuyer sur Touche "I" 
     Menu contextuel > Location 

Vérification enregistrement keyframe 

PanneauN > Paragraphe=Transforme > 
Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

PanneauN > Paragraphe=Transforme 
> Coordonnées en Jaune 
PanneauAnimation > sous Curseur < 
trait jaune 

 E
TA

T 
2 

 E
TA

T 
1 

 E
TA

T 
3 
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Remarque sur le fonctionnement de Blender : Entre les trois états mémorisés par les keyframes Blender 
« interpole » les états intermédiaires avec une méthode de calcul. Lors de l’exécution on peut remarquer au 
début, à la fin, avant  et après le choc des « ralentissements » pas très réalistes induits par le type de méthode. 

8.2. CORRECTION DES « RALENTISSEMENTS » : UTILISATION DE L’ESPACE DE TRAVAIL ANIMATION 
• PREMIÈRE PHASE : ACTIVER L’ESPACE DE TRAVAIL « ANIMATION » :  

  PanneauInfo > BarreMenuHaute > IconeCase = « Default » < clic 
  MenuContextuel > Entrée = Animation < clic 
Résultat : Mise en place dans l’écran Blender (encadré en rouge)de l’ensemble des panneaux ci-dessous 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• DEUXIÈME PHASE : CORRECTION DE LA CINÉMATIQUE DU CHOC ENTRE LES DEUX OBJETS 
1- Explications préliminaires sur le Cube dans le panneau Graph Editor :( le cube est suposé être sélectionné !) 
Le déplacement du Cube s’effectue sur l’axe des X représenté verticalement (unité blender), en fonction de la 
ligne du temps (unité frame) : la courbe rouge représente sa position sur l’axe des X à chaque instant : on 
l’appelle la « loi horaire », elle est en rouge parce que la trajectoire est l’axe des X de convention rouge. 
 
 
 
 
 
 
 
 
Remarque : pour obtenir cette courbe il FAUT que le cube soit sélectionné dans le Panneau3DView !!! 

Panneau Propriétés (objets) 
(BarreIcone Haute) 

Panneau OutLiner (objets) 
(Barremenu Haute) 

Panneau DopeSheet 
(Barremenu Basse) 

Panneau Graph Editor 
(Barremenu Basse) 

Panneau Animation 
(Barremenu Basse) 

Panneau 3D View 
(Barremenu Basse) 

Panneau View Camera 
Mode : Wireframe 

Temps (frame) 

Valeur X  (unité blender) 

Frame = 40 

X = 0 

Point correspondant au contact avec la sphère 
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2- Représentation cinématique de la vitesse pour un objet se déplaçant 
Si la loi horaire est représentée suivant la courbe noire (figure ci-dessous), pour les positions 1, 2, 3 du mobile 
l’angle que font les flèches tangentes à la courbe  représente la vitesse du mobile. En les reportant sur le cercle 
(sorte de compteur de vitesse), on interprète le mouvement de la manière suivante 
Passage de la position 1 > Position 3 : l’angle de la flèche/Axe zéro diminue dans compteur cela signifie que la 
vitesse diminue 
En position 3 > la vitesse s’annule (l’angle /axe zéro est nul !) 
Passage de la position 3 > position 4 : l’angle de la flèche /Axe zéro a changé de sens cela signifie que la vitesse 
à changer de sens et a augmenté : le mobile revient en arrière. Ce changement est d’autant plus lent que 
l’arrondi de la courbe de la loi horaire est « plat » (variation lente de l’inclinaison de la flèche !) 
 
 
 
 
 
 
 
 
 
 
 
 
Exemple de courbes : 
 
 
 
 
3- Correction de l’orientation de la vitesse du Cube au point de choc avec Graph Editor 
Objectif : Il suffit dans le PanneauGraphEditor de transformer comme le montre la figure ci-dessous : la courbe 
de loi horaire de gauche  en la courbe de loi horaire de droite . En effet dans cette seconde courbe la vitesse «  
se casse » brusquement en changeant de sens ce qui correspond plus à la réalité. 
 
 
 
 
 
 
 
 
 
Moyens : Pour obtenir ce résultat dans le PanneauGrapheEditor : 
D’ABORD Sélectionner le Cube : permet de s’assurer que la courbe est bien celle du Cube 
PUIS  Mettre la souris au dessus le la poignée de la demi tangente gauche (voir figure ci-dessus) : 
PUIS  Cliquer droit (la poignée devient orange) en déplacant vers le point origine, une fois la superposition 
obtenue : cliquergauche. Faire la même chose sur la demi-tangente de droite  
Résultat : vérifier avec l’animation les changements au moment du choc pour le cube 
 
4- Correction de l’orientation de la vitesse de retour de la Sphère au point de choc avec Graph Editor 
D’ABORD Sélectionner la Sphère dans le Panneau3DView 
PUIS  Retravailler dans PanneauGraphEditor la courbede sa lois horaire comme pour le Cube 
Remarque : A l’animation on peut remarquer un nouveau petit défaut : le Cube et la Sphère repartent avec la 
même vitesse, ce qui n’est pas encore très réaliste, puisque les surfaces de contact au sol sont très différentes : 
faible pour la sphère (quasiment un point) importante pour le cube (une face carré). Ainsi logiquement le recul de 
la sphère devrait être plus rapide que celui du carré. 
 

Position 1 

Position 2 

Position 3 

Position 4 

Loi horaire d’un objet 

Axe correspondant  
à une vitesse = 0 

Position 1 

Position 2 

Position 3 

Position 4 

SENS 
Positif 

« Compteur de vitesse » Temps 

Espace 

Poignée demi 
tangente 

Changement de sens  avec 
vitesse progressive assez lente 

Changement de sens  avec 
vitesse progressive très lente 

Changement de sens  avec 
vitesse progressive très rapide 
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5- Correction du rebondissement plus rapide de la Sphère / Cube avec Dope Sheet 
Objectif : Diminuer l’intervalle de  temps (en frame) séparant la keyframe=40 du point de choc et la keyframe=60 
mémorisée comme fin du retour. 
Remarque Préliminaire : Informations  dans le PanneauDopeSheet  
La partie gauche : « Dope Sheet Summury » est décrit par la figure ci dessous 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
On peut donc déduire de la représentation des keyframes en ligne de points verticales que la « distance » entre 
une keyframe K1 (Keyframe 40) et une keyframe K2 (Keyframe 60) représentent l’intervalle de temps (en frames) 
mit par le Cube pour aller d’une position A (mémorisée dans K1) à une position B (mémorisée dans K2). Si l’on 
diminue dans le Dope sheet la distance entre la colonne K1 et la colonne K2, le « temps » pour le parcours AB 
est diminué et donc la vitesse de l’objet est augmentée entre A et B. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Moyens :Pour obtenir ce résultat pour l’objet « Sphère » dans le PanneauDopeSheet  
D’ABORD  Dans la PanneauDopeSheet_Gauche > Cliquer sur « Sphere » 
Résultat : le nom « Sphere » passe en surbrillance, on peut déplier la liste des paramètres en cliquant sur le 
pointeau devant le nom (ce n’est pas nésessaire pour la suite !) 
PUIS  Positionner la souris sur la ligne de « Sphere », sur le premier point haut la dernière ligne verticale de 
points de la keyframe = 60 ( K2 sur la figure ci-dessus) 
Résultat : la colonne de points passe en jaune : elle est sélectionnée 
ENFIN  Maintenir le clicDroit et glisser déplacer vers la Keyframe = 40 ( K1 sur le figure ci- dessus) de manière 
à obtenir le configuration de droit des figures ci-dessus. 
Résultat : Exécuter l’animation et vérifier l’accroissement de la vitesse de la sphère après le choc. 
 
 
 
 
 
 
 
 

Keyframe 40 Keyframe 60 
0 

Objet sélectionné 

Ligne du temps en frames 

Liste des paramètres 
de l’objet  mémorisés 

La présence du point indique 
que le paramètre de la ligne 
horizontale correspondant est 
mémorisé dans la keyframe de 
la ligne verticale 
Exemple pointé : 
Coordonnée Z dans keyframe 60 

K1 K2 
0 

Intervalle de temps entre A et B 
0 

Intervalle de temps dimunué 
0 

K1 K2 
0 
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9. Utilisation du son pour animer des maillages dans Blender 2.79 
Exercice : Faire chanter et danser « Suzanne » la mascotte de Blender 

Listes des nouveaux points abordés : 
Groupe de vertices, Notion de Driver 
Clés de forme (Shape Key) et drivers d’animation,  
Audio et F-Curves (courbes de Béziers) utilisées pour animer à partir d’une bande audio 

 

9.1. MISE EN PLACE DE L’ANIMATION DES DÉFORMATIONS DE LA BOUCHE DE SUZANNE 
• PREMIÈRE PHASE : CRÉATION DE « SUZANNE » 

D’ABORD Créer un objet « Suzanne » au centre du Monde Blender 
Panneau3DView > BarreMenus  > Menu = Add > Entrée = Mesh > SEntrée = Monkey 

PUIS Nommer l’objet « Suzanne » 
PUIS Se mettre en vue Front 
PUIS Lisser le maillage  
  PanneauT > Onglet = Tools > Paragraphe = Edit  

> Bouton = Smooth < Clic 
 

• DEUXIÈME PHASE : MÉMORISATION DU MAILLAGE DE LA BOUCHE DE « SUZANNE » : NOTION DE VERTEXGROUP 
Objectif : Regrouper les vertices de la bouche dans un groupe, permet d’utiliser ce groupe sans avoir à le 
resélectionner à chaque fois à la main ! Ici cela permettra d’ajuster sur ce groupe les déformations pour simuler 
les movement de la bouche associés à la voix ! 
D’ABORD Mode Edit >Mode = Face  
PUIS Sélectionner la bouche de Suzanne, comme le montre la figure ci-contre 
PUIS Mémorisation des vertices dans un groupe 
 PanneauProperties > BarreIcônes > Icônes =Data Objects 
 Paragraphe = Vertex Groups > Bouton = « + » < Clic 
Résultat  : dans le cadre-pile apparaît un nouveau nom « Group » en blanc sur fond bleu 
PUIS DoubleCliquer sur le nom et remplacer par « Bouche » 
PUIS Paragraphe = Vertex Groups > Bouton = Assign < Clic 
Résultat : Le nom « Bouche » est ainsi associé à l’ensemble de la sélection. Cela permet en cas de besoin en 
Mode Edit en appuyant sur le Bouton = Select du Paragraphe = Vertex Groups de venir le sélectionner 
 

• TROISIÈME PHASE : PRÉPARATION DE L’ANIMATION D’UN MOUVEMENT DE LA BOUCHE DE « SUZANNE » : NOTION 
SHAPE KEY 

Principe : Il s’agit ici en ObjectMode de mémoriser (par exemple- voir schéma ci-dessous) deux états : Etat1 et 
Etat2, d’une partie du maillage, modifiés chacun en EditMode. Blender fait alors correspondre une variable = 
Case« Value » qui prend ses valeurs dans l’ ensemble des nombres compris entre 0 et 1 telles que d’une part  0 
= Etat1, 1 = Etat2 et d’autre part toute valeur intermédiaire correspond à une interpolation de la déformation 
continue qui fait passer de la forme du maillage de l’Etat1 à l’Etat2 (voir schéma ci-dessous). 
 
 
 
 
 
 
 
Pour cela : 
D’ABORD EditMode > Sélectionner la bouche de Suzanne 
 PanneauProperties > BarreIcônes > Icônes =Data Objects > Paragraphe = Vertex Groups  
  Sélectionner Nom = « Bouche » > Bouton = Assign < Clic 
PUIS Fermer la bouche de « Suzanne » = Scale sur Z pour obtenir la forme de la figure  
Remarque : Départ bouche fermée pour aller vers bouche ouverte (schéma ci-dessus) 
PUIS Se Mettre en ObjectMode 

0                                n                                1 Case = Value  >> 

Forme 
de la partie 

 de maillage 

ETAT 1 ETAT 2 
État intermédiaire interpolé 

par blender 
 

ShapeKeys 
enregistrées Basis Key1 

Déformation continue 



 

 51 

PUIS PanneauProperties > BarreIcônes > Icônes =Data Objects >  
 Paragraphe =Shape Keys > Bouton = « + » < Clic 
Résultat  : dans le cadre-pile apparaît un nouveau nom « Basis » en blanc sur 
fond bleu : nous venons de mémoriser le premier état de la forme de la 
« bouche fermée » sous le nom de « basis » (qui est l’état de référence nommé 
toujours Basis). Nous allons créer un second état de la « bouche ouverte » en 
créant une seconde clé, pour que blender puisse interpoler entre les deux. 
PUIS Paragraphe =Shape Keys > Bouton = « + » < Clic 
Résultat : dans le cadre-pile apparaît un nouveau nom « Key 1 » en blanc sur fond 
bleu.  
PUIS DoubleCliquer sur le nom et remplacer par « BoucheOuverte » 
 
PUIS Repasser en EditMode 
PUIS Sélectionner le bouche (si elle ne l’est pas !) 
PUIS Ouvrir la bouche de « Suranne » = Scale sur Z pour obtenir la forme de la 
figure ci-contre  
 

• QUATRIÈME PHASE : PRINCIPE  DE FONCTIONNEMENT D’UNE SHAPE KEY ET VÉRIFICATION SUR LA BOUCHE DE 
« SUZANNE » 

D’ABORD Se Mettre en ObjectMode 
PUIS PanneauProperties > BarreIcônes > Icônes =DataObjects > Paragraphe =Shape Keys > 
 CadrePile > Nom = BoucheOuverte < clic 
PUIS Scrapper  la Case = Value pour changer sa valeur  
Rappel : Scrapper une case consiste à cliquer gauche dedans et à maintenir en déplaçant vers la gauche (pour 
diminuer) vers la droite (pour augmenter) 
Remarque et vérification : vers la valeur zéro la bouche est fermée (état de la clé « Basis »), vers la valeur 1 la 
bouche est ouverte (état de la clé « BoucheOuverte ») les positions intermédiaires sont interpolées par Blender. 
 

9.2. ANIMATION DE LA CLÉ DE FORME  DE LA BOUCHE DE « SUZANNE » PAR UNE BANDE AUDIO. 

Principe : L’idée consiste d’abord  à faire coincider une animation avec le défilement d’une bande audio.La 
bande audio est considérée comme une courbe des amplitudes du son en fonction du temps, du son enregistré 
dans un fichier audio. Elle est utilisée pour faire varier en fonction du temps, les valeurs de la « Case Value » qui 
commande la Shape Key, c'est-à-dire animer les déformations du maillage voir schéma ci-dessous 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Pour cela, on suppose que l’on dispose d’un fichier audio sur lequel est enregistré une voix et de la musique 
(appelé « FichierAudio » dans la suite) 
 

• PREMIERE PHASE : PRÉPARATION DE L’ESPACE DE TRAVAIL 

Axe du temps 
 

0                                n                                1 Case = Value  >> 

Forme 
de la partie 

 de maillage 

ETAT 1 ETAT 2 FORME intermédiaire 

À chaque instant  de défilement 
de la 

bande audio 
 

Courbe d’amplitude du son 
enregistrée dans le fichier Audio 

Instant « t » 

Forme du maillage récupérée  
à l’instant t 

Curseur de lecture du son 
 

Valeur envoyée 
entre 0 et 1 

vers la ShapeKey 
Case = « Value  
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D’ABORD Séparer le Panneau3DView en deux panneaux 
Rappel : Mettre la souris à la séparation PanneauInfo-Panneau3Dview, maintenir pour positionner puis cliquer 
gauche 
PUIS Sur Panneau3Dview droit, choisir dans l’icône type > Menu = Graph Editor  
Remarque : On a la répartition de l’espace de Blender comme le montre la figure éclatée du dessous : 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
On a une coïncidence entre la représentation des successions des images (frames) du PanneauAnimation et du 
PanneauGrapheEditor : le curseur (ligne verte verticale) pointe l’image affichée dans le Viewport du 
Panneau2DView 

1- Vocabulaire associé au PanneauGraphEditor 
 
 
 
 
 
 
 
 
 
 

2- Fonctionnement de la région « Liste des Canaux » et notations pour la suite : 
Cette région sera appelée : RegionListeCanaux 
Dans l’exemple suivant on suppose que l’objet de nom Suzanne possède en frame 1, une Keyframe sur les trois 
valeurs X,Y,Z de sa position. Dans la RegionListeCanaux, on a l’affichage :                                           qui marque 
simplement l’enregistrement d’un bloc de données appelée « Action » associé à l’objet Suzanne à la frame 1.  
Si l’on clique sur le pointeau de début  on a l’affichage ci-contre :   
qui montre qu’une Action nommée « SuzanneAction » est ouverte  
 
Si l’on clique sur le pointeau de début on a l’affichage : 
Qui montre trois propriétés de position (X,Y,Z) appelées 
«Canaux »  Xlocation , Ylocation, Zlocation sont enregistrés dans  
l’actionSuzanne 
 

• DEUXIÈME PHASE : DÉBUT DE L’ANIMATION DE LA BOUCHE  
D’ABORD Panneau3DView > Sélectionner « Suzanne » 
PUIS Vérifier dans PanneauAnimation que le curseur d’animation (vert) est en position 1 
PUIS Positionner la souris sur : 
 PanneauProperties > BarreIcônes > Icônes =DataObjects > Paragraphe =Shape Keys >Case = value 
PUIS CliquerDroit > MenuContextuel > Entrée =Insert KeyFrame 

Panneau Info 

Panneau 3DView Panneau Graph Editor 

Panneau Properties 

Panneau Outliner 

Panneau TimeLine (aussi appelé Panneau Animation) 

 Liste dite des Canaux  :  
utilisée pour montrer les Objets 

animés et les paramètres de ces 
objets enregistrés dans des 

KeyFrames 

Représentation graphique : :  
Pour chaque Keyframe attachée 
à un paramètre d’objet animé, 
cette région affiche sous forme 
d’une courbe dite F-Curves les 
variations de valeur de ce 
paramètre en fonction du temps 
(axe bas du repère gradué en 
frame)  
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Résultat : Dans PanneauGraphEditor > RegionListeCanaux apparaît sous le nom « Suzanne » un « Key » qui si 
on l’ouvre avec le pointeau affiche « Value (boucheOuverte) » ce qui signifie qu’une clé d’image est associée à la 
valeur contenue dans la case value de la shapeKey de la bouche au temps correspondant à la frame = 1 
(première image de l’animation) 
 en langage blender  
« on dit qu’une ActionKey est créée, dans laquelle se trouve le Canal Value  (boucheOuverte) » 
 

• TROISIÈME PHASE : IMPLANTATION DE LA COURBE AUDIO POUR GUIDER LA PRISE DE VALEUR DE LA 
« CASEVALUE » 

D’ABORD Vérifier dans PanneauAnimation que le curseur d’animation (vert) est en position 1 
PUIS PanneauGraphEditor > Objet = « Suzanne » > Action = Key > Canal = Value(BoucheOuverte) < clic 
PUIS PanneauGraphEditor > BarreMenus > Menu = Key > Entrée = BakeSound to F-Curve 
Résultat : Affichage de l’explorer de fichier PanneauFileEditor de Blender et du  PanneauT correspondan 
Remarque préliminaire théorique : 
Un fichier audio par exemple de musique, enregistre la globalité des sons qui correspondent aux vibrations 
émises par tous les instruments et la voix. Pour simplifier un son audible est un mélange de plusieurs vibrations. 
Chaque vibration est caractérisée par son ampleur (amplitude : forte , faible mesurée en décibel) mais aussi par 
la propagation des oscillations par unité de temps (fréquence : aigue, grave …mesurée en hertz). Pour exemple 
d’une chanson sur de la musique, on peut distinguer approximativement les graves (guitare base, batterie, 
grosse caisse …) des aigues (guitare soliste, voix, cymbale ….) par leur zone de fréquences.   
 
 
 
 
 
 
 
 
 
PUIS  PanneauFileEditor >PanneauT > Paragraphe = BakeSound to F-Curve 
 Case = Lowest frequency < 500   (fréquence la plus basse 500 hz) 
 Case = Highest frequency < 20000  (fréquence la plus haute 20000Hz) 
Remarque : On sélectionne ainsi les fréquences comprises entre 500 et 20000 Hz qui est « en gros » la bande 
passante de la voix humaine 
PUIS PanneauFileEditor > choisir  « FichierAudio » < clic 
Résultat : Dans le PanneauEditor > ReprésentationGraphique  apparaît la courbe des variations du son qui va 
commander le Canal = Value(BoucheOuverte) 
Remarque : utiliser la roulette de la souris pour grossir la courbe, et le clic roulette maintenu pour déplacer le 
repère 
PUIS PanneauAnimation > Vérifier le fonctionnement en muet des variations de la bouche de « Suzanne » 
en lançant l’animation .  
Remarque : Il se peut que les oscillations du son soient un peu faibles et que par conséquent les mouvements 
de la bouche soient assez réduits. On peut corriger cela en utilisant une modification de la courbe 
 

• QUATRIÈME PHASE : AJOUT D’UN MODIFIER ENVELOPPE POUR AUGMENTER LES VARIATIONS D’AMPLITUDE DE 
LA F-CURVE  

D’ABORD  PanneauGraphEditor > ZoneReprésentationGraphique > 
  BarreMenus > Menu = View > Entree =Properties 

Remarque : un SousPanneau s’affiche sur le coté droit du PanneauGrapheEditor c’est PanneauN comme pour 
le panneau3DView mais celui-ci possède trois onglets verticaux. 
PUIS  PanneauGraphEditor > PanneauN > Onglet = Modifier < clic 
PUIS  PanneauGraphEditor > PanneauN > Paragraphe = Modifiers > Case = Ad Modifier < clic 
PUIS   MenuContextuel > Menu = Enveloppe 
Remarque : Par les paramètres du modifier « enveloppe »  nous allons  « influencer » la forme de la courbe  
Dans la suite TOUTES les manipulations se font dans le PanneauGraphEditor > PanneauN, il est important 
de bien suivre la chronologie des actions : 

Temps en seconde 

Amplitude en décibel 
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D’ABORD Positionner le curseur en frame = 0 
PUIS Paragraphe = Control Points : > Bouton = AddPoint < Clic 
Résultat : en déplaçant légèrement le curseur vert, on voit deux « points blancs » verticaux en -1 et 1 (voir figure 
ci-dessous).La droite verticale définie par ces deux points indiquent le début (dans la file du temps) des 
modifications qui vont être faites sur la courbe  
PUIS  Réglage des marqueurs de l’enveloppe dans le repère : 
Remarque : Les lignes pointillées horizontales vont servir  pour visualiser les bornes supérieure et inférieure de 
l’influence de  l’enveloppe sur la courbe : ici (figure ci-dessous) entre les valeurs -1 et 1, la valeur 0 étant la 
référence « centrale » de l’enveloppe. 
Il faut donc agir selon la chronologie du tableau suivant : 

Action sur les paramètres du Modifier = Envelope Effet sur la représentation graphique 
Paragraphe = Envelope > Case = Min < 0 La ligne base pointillée se cale sur l’axe des x 
Paragraphe = Control Points > Case = AddPoint < clic La courbe se déplace vers le bas (y < 0) 
Paragraphe = Control Points > Case = Min < 0 La courbe se cale sur l’axe des x 
Paragraphe = Control Points > Case = Max < à régler Selon la valeur l’amplitude augmente ou diminue 

 
 
 
 
 
 
 
 
 
 
 
 
 
Résultat : Revenir dans le Panneau Animation et lancer l’animation afin de vérifier que l’amplitude des 
mouvements de la bouche est plus importante 
 

9.3. ANIMATION DE L’OSCILLATION DE LA TÊTE PAR LA MÊME BANDE AUDIO 

Principe : il s’agit ici de faire agir les mouvements d’un objet nommé ici « Pilote » sur l’objet « Suzanne » de telle 
manière à ce qu’une oscillation verticale du « Pilote » induise une rotation de « Suzanne » par rapport à l’axe Y 
(supposé perpendiculaire à la face !). Les mouvements du « Pilote » étant liés comme précédemment à la bande 
sonore du FichierAudio. 
Pour cela, on suppose ici que l’espace de travail est toujours celui du paragraphe précédent. 
 

• PREMIÈRE PHASE : CRÉATION ET ANIMATION D’UN OBJET « PILOTE » SUR LA BANDE DE SON DE FICHIERAUDIO 
D’ABORD Ajouter une UV Sphere dans la scène près de « Suzanne » et nommer la « Pilote » 
PUIS Sélectionner « Pilote » 
PUIS Vérifier que le curseur du PanneauAnimation est en 1 
PUIS Positionner la souris sur : Panneau3DView > PanneauN > Paragraphe = location > Case = Z : 
PUIS CliquerDroit > Menu Contextuel > Menu = Insert Single KeyFrame 
Résultat : La case Z de location s’affiche sur fond jaune cela signifie que la key est enregistrée. On peut vérifier 
aussi que dans PanneauAnimation sous le curseur vert a pparait un demi-trait jaune. 
PUIS PanneauGraphEditor > BarreMenus > Menu = Key > Entrée = BakeSound to F-Curve 
Résultat : Le PanneauFileEditor s’ouvre ! 
PUIS  PanneauFileEditor >PanneauT > Paragraphe = BakeSound to F-Curve 
 Case = Lowest frequency < 10 
 Case = Highest frequency < 100 
Remarque : On sélectionne ainsi les fréquences comprises entre 10 et 100 Hz qui est gros la bande passante de 
des basses du rythme musical 
PUIS PanneauFileEditor > choisir  « FichierAudio » < clic 
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Résultat : Dans le PanneauEditor > ReprésentationGraphique  apparaît la courbe des variations du son qui va 
commander le Canal = Z Location que l’on peut voir dans la Liste des Canaux. D’autre part en lancant l’animation 
on peut voir la sphere « pilote » vibrer verticalement selon la bande audio ! 
 

• DEUXIÈME PHASE : CRÉATION D’UNE LIAISON ENTRE LES OSCILLATIONS VERTICALES DU PILOTE ET LES 
ROTATIONS/Y DE SUZANNE : 

Moyen : on utilise pour faire le lien entre Suzanne et le Pilote : un Driver 
D’ABORD Panneau3DView > Sélectionner « Suzanne » 
PUIS Positionner la souris sur : Panneau3DView > PanneauN > Paragraphe = Rotation > Case = Y  
PUIS CliquerDroit > Menu Contextuel > Entrée = Add Driver > SEntrée = Single From Target < clic 
Résultat : le pointeur de la souris se transforme en pipette,  
PUIS Placer la pipette > Paragraphe = Rotation > Case = Y< clic gauche 
résultat : la case rotation /Y se colore en violet. (le driver est lié à la Rotation/Y de Suzanne) 
 

• TROISIÈME PHASE : RÉGLAGE DE LA LIAISON POSITION Z DU PILOTE ET ROTATION Y DE SUZANNE 
D’ABORD PanneauGraphEditor > BarreMenus > Case = F-Curves  < Clic-Changer = Drivers  
PUIS RegionListeCanaux > Paragraphe = Suzanne < ouvrir  
Rappel : Pour ouvrir un paragraphe cliquer sur le pointeau devant le nom du paragraphe 
PUIS RegionListeCanaux > Paragraphe = Suzanne > Drivers < ouvrir 
Résultat : « Y Euler Rotation » apparaît : ceci confirme que nous avons enregistré un driver sur la rotation / Y de 
Suzanne 
PUIS Dans RegionRpGraphique > PanneauN > Onglet = Drivers, on a l’affichage ci-dessous : 
Commentaires : ce qu’il faut retenir , ce sont les indications ci-dessous : 
 
 
 
 
 
 
 
 
 
 
PUIS Dans le cadre correspondant au contenu de la variable « var », on indique que c’est le paramètre de 
position sur axe Z  de la sphere « Pilote ». Dans la case « Path : » comme le montre 
la figure, on entre au clavier : « location[2] » 
Remarque : en programmation de blender les déplacements sont rangés dans un 
tableau de dimension 3, de nom « location »,dont  l’indice varie de 0 à 2, d’où 
l’écriture : location [2] pour désigner Z. 
 

• QUATRIÈME PHASE : VÉRIFICATION DU FONCTIONNEMENT ET AFFINAGE DE L’ANIMATION 
PanneauAnimation > Lancer l’animation 
Remarque : L’objet « Suzanne » doit osciller en fonction de la bande Audio.Les mouvements trop rapides  
vont pouvoir être corrigés plus aisément grave au driver.En effet il suffit de multiplier la variable « var » de 
transmission par un coefficient d’affaiblissement exemple : 0.1. Ainsi : 
D’ABORD RegionRpGraphique > PanneauN > Onglet = Drivers  
 > Case = Expr : < Taper « var * 0.1 » (voir figure ci-contre) 
Remarque : ce coefficient est ajustable en cas de besoin ! 
 

9.4. ET LE SON RÉEL ? 

Remarque : On a utilisé le fichierAudio pour mouvoir des parties de Suzanne, mais ce fichier n’est pas encore 
audible, ce paragraphe permet d’implanter le son. 
D’ABORD GraphEditor > IconeType < Video Sequence Editor (noté PanneauVideoSE dans la suite) 
Remarque : Ce panneau est ce qui permet de mixer des videos, des sons … 

Objet piloté : 
Suzanne 
Paramètre piloté de cet objet : 
Rotation /Y 

Type de pilotage du driver : 
Une variable nommée « var » type 
« scripte» 
 (en langage de programmation) 
 
Affichage par défaut  du contenu de 
« var » :  ici 
Propriétaire « Suzanne » 
Chemin du paramètre propriétaire : 
Rotation/Y 
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PUIS PanneauVideoSE > Positionner le Curseur en 0 
PUIS PanneauVideoSE > BarreMenus > Menu = Add > Entrée = Sound 
Resultat : l’affichage bascule sur PanneauFileEditor 
PUIS PanneauFileEditor > Slectionner FichierAudio  (le même que pour l’animation) 
Résultat : En lançant l’animation , le son accompagne les mouvements de Suzanne ! 
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10. Animation Niveau 3 : Simulation de vol d’oiseaux (Cycles Render) 
Exercice  sur les Boids (particules aux comportements gérés par une 

intelligence artificiel) 

Liste des points nouveaux abordés (symbole ) 
Notion de particules simulants des comportement de groupe d’animaux (en anglais : boids) 
Notion d’armature (squelette) d’animation en liaison avec un maillage (corps), notion de parenté entre objets 
Notion d’accrochage de maillage et d’armature : déformation > correction :  outil weight paint 
Utilisation du DopeSheet et du Graph Editor pour simuler le battement des ailes d’un oiseau 
Utilisation du Modifier Mirror pour créer un maillage par symétrie 

10.1. CRÉATION ET ANIMATION DU VOL D’UN OISEAU 
• PREMIÈRE PHASE :  MODELAGE D’UN MAILLAGE POUR OBTENIR UNE FORME D’OISEAU : MODIFIER MIRROR 

D’ABORD Ajouter une primitive : Plan au centre de l’univers 
  Panneau Éphémère > Radius < 2 
PUIS  Passer en Edit Mode 
  Se mettre en vue de dessus 
  Créer un EdgeLoop Vertical selon une médiane (touches [ctrl]+ « R ») 
  Supprimer la face de droite 
Objectif : Travailler en miroir sur un seul coté du plan (le deuxième est obtenu par symétrie verticale) 
PUIS  Sélectionner le demi plan restant 
PUIS  PanneauProporties > BarreIcones > Icones = Modifier < Clic 
  PanneauProporties > Panneau Modifier > Bouton = Add Modifier < clic 
  MenuContextuel > Colonne = Generate > Entrée = Mirror < clic 
   Panneau Mirror > Case = (choisir axe de symétrie : ici « X ») 
   Panneau Mirror > Case = Clipping < cocher (permet de fermer les maillages sur axe de symétrie) 
Résultat : le demi plan d’origine est complété par son symétrique/médiane  
PUIS   Modeler la silhouette d’un oiseau schématique en vue de dessus (figure ci-dessous) en utilisant 
utilisant l’ajout d’Edge loops horizontaux. et verticaux 
  
 
 
 
 
 
 
 
 
PUIS  Donner de l’épaisseur : Extruder suivant Z de 0.09 unité blender 
PUIS  Completer le modelage de  l’épaisseur au corps en agissant sur les vertices, et edges médians pour 
obtenir la figure ci-dessous. 
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PUIS  Ajouter un material > blanc 
ENFIN  :Il est commode et important pour le suite de positionner l’origine géométrique du maillage avec le 
curseur au centre monde comme le montre la figure ci-dessous : 
 
 
 
 
 
 
 
 
 

• DEUXIÈME PHASE : STRUCTURE INTERNE DE L’OISEAU NÉCESSAIRE À L’ANIMATION : NOTION D’ARMATURE   
Explication préliminaire : Dans blender pour articuler un maillage, on doit le relier à un « squelette »(appelé 
armature) composé d’une suite d’  « os » (appelé bone) qui sont reliés les uns aux autres par des connexions de 
type rotation.  
Principe général d’une animation de maillage avec armature : D’abord on créée l’Armature voulu dans le 
maillage, puis on l’accroche au maillage, et enfin on anime les éléments de l’armature. 
 
D’ABORD  Ajout du premier os de l’armature : le corps 
  Pour mieux voir le travail > Affichage en WireFrame 
  On suppose ici que le maillage oiseau est bien positionnée (voir figure précédente) 
  Panneau3Dview > BarreMenus > Menu = Add > Entrée = Armature > SousEntrée = single bone 
   PanneauEphemere > CaseRotation X : < 90° 
PUIS   Visualisation des os à travers le maillage en mode Solid 
  PanneauProporties > BarreIcones > Icône =Données Objet Actif < clic 
   Panneau Objet actif > Paragraphe = Display > Case = X-Ray < Cocher 
 
Résultat : comme le montre la figure ci-dessous, l’os (forme volumique en pointe à 8 faces) apparaît « au 
travers » du corps solide. Noter bien le vocabulaire des parties de l’os 
 
 
 
 
 
  
 
 
PUIS  Ajout de la suite de l’armature : les ailes  
  Sélectionner l’os précédent 
 Passer en Edit Mode 
  Sélectionner la tête de l’os central 
  Extruder l’aile gauche (sans dépasser du mesh) 
  Resélectionner la tête de l’os central 
  Extruder l’aile droite (même longueur que l’autre aile !) 
 
Résultat :  On obtient la totalité de l’armature (squelette) désignée dans la figure ci-dessous : 
 
 
 
 
 
 
 
 

Origine commune : 
Univers – maillage - curseur 

« Tête » de l’os 

« Queue » de l’os 
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• TROISIÈME PHASE : AJOUT DU MÉCANISME DE PILOTAGE DES OS-AILES POUR UNE ANIMATION DE LEUR 
BATTEMENT EN SIMULTANÉ. 

Principe : Le procédé ressemble à celui des marionnettes. On va « attacher » deux « fils » aux extrémités des 
ailes du squelette. Puis relier ces « fils » a une « poignée » centrale (devant l’oiseau). Lorsque l’on tirera la 
« poignée » vers le haut : les deux ailes pivoteront / centre vers le haut et de même vers le bas.  
Moyen pour « accrochages des fils sur les ailes » : Ajouter deux objets type « Empty sphérique » au bout de 
chaque os des ailes (figure ci- dessous). Nommer les « CibleAileDroite » et « CibleAileGauche » 
 
 
 
 
 
 
 
Moyen pour « créer la poignée » : Ajouter devant la tête de l’oiseau à  deux unités blender une petit Cube de 
coté 0.5 
Moyen pour « accrocher des fils » entre la « poignée » (cube) et les « accrochages » (empty) 
Dans l’ordre : 
 D’ABORD  Sélectionner l’Empty et maintenir la sélection ( touche [Maj] enfoncée) 
 PUIS   Sélectionner le Cube 
 ENFIN   Taper [Ctrl] + « P »   
    MenuContextuel « Set Parent to »  > Entrée = Object (Keep Transform) < Clic 
Résultat : Un pointillé apparaît entre les deux objets. On peut vérifier que le déplacement vertical du cube induit 
le même déplacement de l’empty, mais pas l’invSerse : c’est la notion de parenté. 
Moyen pour relier l’armature : os au maillage de l’ail – « accrochage » du fil relié à la « poignée » 
Dans l’ordre 
 D’ABORD  Passer en Pose Mode (mode de pilotage des os d’armature) 
 PUIS   Panneau3Dview > BarreMenu > Case ObjectMode < Entreé = Pose Mode < Clic 
 PUIS   Sélectionner l’os de l’aile droite (passage en vert !) 
 PUIS   PanneauProporties > BarreIcone > Icône = Contrainte d’os <clic 
    Bouton AddBoneConstraint < Clic 
    MenuContextuel > Colonne = Tracking  > Entrée = Inverse Kinematics < clic 
    Panneau IK  
     Case ChainLength = 1 (longueur de la chaine d’os : ici os ail seul !) 
     Case Target = CibleAileD ( Empty doit tirer l’os) 
Résultat : le Bone sélectionné devient vert ! On peut vérifier qu’en déplaçant le cube verticalement l’os de l’aile 
suit ! MAIS il faut remettre le cube en Z=0 pour l’autre aile 
 ENFIN   Refaire le même travail pour l’empty CibleAileG . On obtient le résultat ci-dessous 
 
 
 
 
 
 
 
 
 
 
 

• QUATRIÈME PHASE : ACCROCHAGE DU MAILLAGE À L’ARMATURE DES OS. 
Dans l’ordre,  En Mode Object : 
D’ABORD  Sélectionner le maillage et maintenir la sélection (touche [Maj]) 
PUIS   Sélectionner l’armature 
ENFIN  Taper [Ctrl] + « P » > Menu Contextuel Set Parent to > Entrée = With Automatic Weight 

Empty sphérique 
(centré sur la queue de l’os) 

Empty 
« accrochage » 

Cube  
« poignée » 

Déplacement maitre 

Déplacement simultané esclave 
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Résultat : le choix de la parenté avec « poids automatique » permet de faire coller le maillage à l’armature en 
respectant au mieux les articulations. Pourtant on peut observer que les déplacements déforment au voisinage 
des articulations le maillage en particulier le tête de l’oiseau.  
 

• CINQIÈME PHASE : CORRECTION DES DÉFORMATIONS DU MAILLAGE 
Objectif : Il s’agit de localiser dans le maillage les ensembles de points qui se déforment mal lors du mouvement. 
Blender permet de visualiser ces zones dans un mode appelé « Weight Paint » 
D’ABORD  Passer en Weight Paint (mode de correction et visualisation des lieux de déformation ) 
  Panneau3Dview > BarreMenu > Case ObjectMode < Entreé = Weight Paint < Clic 
Résultat : le maillage se colore en zones qui vont du rouge-orange vers le jaune-vert-bleu. Le bleu correspond à 
aucune déformation, le rouge à une forte déformation. Il suffit de « peindre » en bleu les zones qui ne le sont pas  
en se limitant au corps assez loin des os ( risque de décochement maillage / os) 
PUIS  PanneauT > Onglet = Tools > Paragraphe=Brush > Icône = F-Substract  
ENFIN  Déplacer la souris BoutonGauche enfoncé sur zones rouges du corps pour les rendre bleues 
  Comme le monte la figure ci-contre (la queue de l’oiseau peut être laissée rouge !) 
 
 
 
 
 
 
 
 

• SIXIÈME PHASE :  MISE EN ANIMATION D’UN BATTEMENT D’AILE DU VOL DE L’OISEAU 
Principe : dans l’ordre il faut enregistrer un battement des ailes, puis itérer ce battement sur une durée 
d’animation, pour cela IL SUFFIT d’enregistrer les positions verticales du cube-poignée qui commande le 
déplacement des ailes. 

Chronologie : Actions Objet : Cube (poignée de déplacement ailes) 
Panneau Animation 
Mettre le curseur en > 

Frame = 1 
 

Panneau3DView déplacer verticalement le cube > Uniquement Z=-2 (position basse des ailes)  

                    
Clavier > Insérer une Keyframe 

Appuyer sur le touche « I » 
Menu Contextuel > Location 

Panneau Animation 
Mettre le curseur en > 

Frame = 20 
 

Panneau3DView déplacer verticalement le cube > Uniquement Z=0 (position horizontale des ailes) 

                    
Clavier > Insérer une Keyframe 

Appuyer sur le touche « I » 
Menu Contextuel > Location 

Panneau Animation 
Mettre le curseur en > 

Frame = 40 
 

Panneau3DView déplacer verticalement le cube > Uniquement Z=2 (position haute des ailes) 

                    
Clavier > Insérer une Keyframe 

Appuyer sur le touche « I » 
Menu Contextuel > Location 
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Panneau Animation 
Mettre le curseur en > 

Frame = 60 
 

Panneau3DView déplacer verticalement le cube > Uniquement Z=0 (position horizontale des ailes) 
Clavier > Insérer une Keyframe 

Appuyer sur le touche « I » 
Menu Contextuel > Location 

Panneau Animation 
Mettre le curseur en > 

Frame = 80 
 

Panneau3DView déplacer verticalement le cube > Uniquement Z=-2 (position basse des ailes) 
Clavier > Insérer une Keyframe 

Appuyer sur le touche « I » 
Menu Contextuel > Location 

 
Remarque : On peut vérifier le fonctionnement du battement d’aile en utilisant les 
commandes type lecteur vidéo, de la barre des menus basse, du panneau 
animation (figure ci-contre) 
 

• SEPTIÈME PHASE : MISE EN REPETITION DE L’ANIMATION D’UN BATTEMENT D’AILES DE L’OISEAU 
Objectif : Reproduire l’animation précédente périodiquement durant la durée globale de l’animation totale 
souhaité (ici 250 frames) 
Moyen : Changement d’espace de travail : Utilisation du DopeSheet 
 D’ABORD PanneauInfo > BarreMenus > Case = Default < Clic 
  MenuContextuel > Entrée = Animation < Clic 
Résultat : on obtient la répartition de l’écran de la figure ci-dessous : Espace de travail pour l’animation 
 
 
 
 
 
 
 
 
 
 
 
 
 
 PUIS PanneauTimeLine > Mettre le curseur au début de l’animation (trait vertical vert ) 
 ENFIN PanneauGraphEditor > BarreMenu > Menu  = Channel > Entrée = ExTrapolationMode 
   > SEntrée = Make Cyclic (F-Modifier) < Clic 
Résultat : Remplacement dans le PanneauGraphEditor  de la courbe bleu d’un cycle de vol par une courbe type 
sinusoïdale (voir figure ci-dessous). Vérifier l’animation avec le lecteur d’animation. 
 
 
 
 
 
 
 

10.2. CRÉATION D’UN GROUPE DE TROIS OISEAUX À VOLS DECALES 

Remarque préliminaire : ON NE PEUT DUPLLIQUER directement l’ensemble Armature-Oiseau-Cube parce 
que en particulier le cube  est enregistré en coordonnées absolues / armature et oiseau relative au cube. 
Pour éviter cela on crée un objet à part qui va servir de « repère » de l’ensemble . 

Courbe d’un seul battement Répétition du battement 

Extrapolation Mode 
Make Cyclic 

Panneau DopeSheet : 
Edition des Keyframes par objets 

Panneau GraphEditor : 
Edition des Keyframes par objets 
Edition des positions des objets en 
fonction du temps sous forme de 
courbe (interpolation entre les 
position mémorisées dans les 
keyframes) 

Panneau 3D View 

Panneau TimeLine 
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• PREMÈRE PHASE :  CRÉATION D’UN OBJET QUI PERMET DE DUPLIQUER L’ENSEMBLE OISEAU-ARMATURE-CUBE 
EN CONSERVANT L’ANIMATION 

D’ABORD Ajouter une ICOSPHERE sous l’oiseau comme le montre la figure ci-dessous. 
 
 
 
 
 
PUIS  Dans l’ordre  Sélectionner en maintenant la sélection ( touche [Maj]): Armature > Cube > Icosphere 
PUIS  Parenter l’ensemble en appuyant sur : [Ctrl] + « P »  
  Menu contextuel = Set Parent to > Entrée = Object (Keep Transform) 
Résultat : Deux lignes pointillées (liens de parenté) apparaissent en unissant d’une part IcoSpere au Cube et 
d’autre part l’Armature au Cube 
 

• DEUXIÈME PHASE : DUPLICATION DE TROIS OISEAUX 
D’ABORD Sélectionner l’ensemble en mode WireFrame : IcoSphere – Armature – Oiseau – Cube  
PUIS  Dupliquer et déplacer deux fois pour obtenir au total trois oiseaux 
Remarque : Vérifier en utilisant l’animation que les trois oiseaux battent des ailes ensemble. 
 

• TROISIÈME PHASE :  DÉCALAGE DU VOL DES OISEAUX LES UNS PAR RAPPORT AUX AUTRES 
Objectif : Décaler l’animation de chaque oiseau les uns par rapport aux autres pour avoir un effet de réel. 
Moyen : Utilisation du DopeSheet 
 PUIS Décaler les vols de chaque oiseau les uns / aux autres 
Principe : Dans le PanneauDopeSheet on a la description en tableau des enregistrements des Keyframes de 
chaque objet d’animation (Cube-poignée de chaque oiseau). Il s’agit ici de décaler dans le temps les lignes les 
une par rapport aux autres. Pour cela il suffit de procéder comme le montre la chronologie d’actions décrite ci-
dessous. 
 
 
 
C 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Résultat : lancer l’animation et constater que les trois oiseaux ont des battements d’ailes légèrement décalés. 

Nom du pilote d’animation des objets  
Oiseau 1  
Oiseau 2 
Oiseau 3 

Numéro de la frame dans la barre de temps 

POINT = Indication d’une keyframe enregistrée 

D’ABORD  Sélectionner les points-keyframes du 
Cube 001 (Oiseau 2) – Clic G + touche [maj] 
PUIS Scaler  avec la touche [S] pour rétrécir 
l’espace entre les points  

PUIS  Sélectionner les points-keyframes du Cube 
002 (Oiseau 3) – Clic G + touche [maj] 
ENFIN Scaler  avec la touche [S] pour élargir 
l’espace entre les points  
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• QUATRIÈME PHASE :  CRÉER UN GROUPE BLENDER DE L’ENSEMBLE DES TROIS OISEAUX 
Remarque préliminaire : afin de créer un vol de multiples oiseaux, nous allons regrouper les trois oiseaux dans 
un groupe qui servire de modèle pour copier les autres ! 
D’ABORD Sélectionner les trois objets oiseaux 
PUIS  Panneau3DView > BarreMenus > Menu = Group > Entrée = Create a new group 
  PanneauGaucheEphemère > Case = Name < « Oiseaux » 
 

• CINQUIÈME PHASE : CACHER LES OBJETS DE PILOTAGE ET DE LOCALISATION : CUBE ET ICOSPHERE 
Remarque : il suffit d’affecter  aux  objets icosphère un matérial : « Invisible » 
D’ABORD PanneauProporties > BarreIcones > Icône = material 
PUIS PanneauMaterial > Bouton=New < Clic 
PUIS  N ommer le material : « Invisible » 
PUIS  ParagrapheSurface > Case = Surface < Clic 
   Menucontextuel > Entrée = Transparent BSDF < Clic 
PUIS  ParagrapheSurface > Case = Color Clic  
  PanneauContextuel > RampeGaucheVerticale < Curseur-point au maxi haut blanc 
PUIS  Sélectionner tous les autres objets Cube et IcoSphere et leur affecter le material « Invisible » 
Résultat : Vérifier en mode object- Render sur tous les objets Cube et Icosphere sont invisibles 
 

10.3. CRÉER UN VOL D’UNE DIZAINE D’OISEAUX 
• PREMIÈRE PHASE : FAIRE VOLER UNE DIZAINE D’OISEAUX EN GROUPE …. 

Moyen : Utilisation d’un système de particules dit « Boids » c'est-à-dire dont chaque individu possède un 
comportement collectif / aux autres (via une intelligence artificiel) 
Note : Boids est le nom d'un programme informatique de type intelligence artificielle, développé par 
Reynolds en 1986, simulant le comportement d'une nuée d'oiseaux en vol. Le mot boid est par ailleurs 
une contraction de bird-oid (qui a la forme d'un oiseau). 
D’ABORD Créer un objet PLAN qui va servir d’émetteur du Système de particules  
  PanneauN > Paragraphe= Location > Cases X,Y,Z < (0,0,10) 
   Paragraphe = Dimension > Cases X,Y,Z < (8,8,8) 
PUIS  PanneauProporties > BarreIcone > Icône = « Particules » <Clic  
PUIS  PanneauProporties >PanneauParticules > Bouton = New < Clic 
  Paragraphe = Emisson 
    Case=Number < 20 (nombre de particules qui deviendront des oiseaux dans la suite) 
    Case=Start < 1 Case=End < 1 (création de toutes les particules en frame 1) 
    Case=LifeTime < 1000  (durée de vie pendant toute l’animation) 
Résultat :  des particules points apparaissent sur le plan, si l’on lance l’animation (Time Line) des particules sont 
émises par le paln (remettre le curseur à 0 après essai !!!) 
PUIS  PanneauParticules >Paragraphe = Physics 
  BarreCases > Case = Boids < clic (création de particules type boids) 
  ColonneCases > Case = Air Personnal Sp. < 0.35 (espace personnel) 
PUIS  PanneauParticules > Paragraphe = Render 
  BarreCases > Case = Group < clic  
  Case = Dupli-Group < Clic 
   Entrée < « Oiseaux » (groupe créé fin de phase précédente) 
Résultat : les particules prennent le forme de très petits oiseaux. 
   Case = Rotation < coche (permet de réorienter les « oiseaux ») 
   Case = Size < 0.15 ( à ajuster selon les cas !) 
Résultat : les particules-oiseaux prennent la taille voulue MAIS si l’on éxécute l’animation  
les déplacements des oiseaux ne se font pas vers l’avant de la représentation. REPERER la « bonne direction » 
sur un oiseau, procéder comme suit . 
PUIS  Panneau3Dview > en mode object sélectionner les Trois Icosphères des trois oiseaux et effectuer une 
rotation par rapport à l’axe Z jusqu’à coïncider avec « la bonne direction » 
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• DEUXIÈME PHASE :RÉGLER LES COMPORTEMENTS DES OISEAUX DU GROUPE LES UNS PAR RAPPORT AUX 
AUTRES 

Moyen :  Paramètrage des particules Boids 
PanneauProporties > PanneauParticules > Paragraphe = Boid Brain  (réglage des comportements de base ) 
L’encadré représente la pile des comportements pour chaque individu/groupe, l’ordre vertical est celui des 
priorités 
On peut agir avec la souris sur ceux-ci comme le montre la figure ci-dessous.  
 
 
 
 
 
 
 
 
 
 
En utilisant les boutons de la pile : mettre les deux comportements Separate (dispersion) et  
Follow leader (suivre leader) dans l’ordre précisé de la figure ci-dessus. 
 « Separate » : tendance à s’écarter les uns des autres 
 « Follow leader » : tendance à suivre un leader 
Case = Distance < 2.1 (ce qui règle la distance de poursuite du leader)  
Remarque : les valeurs choisies pour le compprtement sont à régler en observant l’animation du vol !!! 

Ajouter a la PILE  
un comportement de la 
liste 
>>>>>>>>>>>>>>>> 

Retirer de la PILE 
un comportement  

Mettre au dessus ou 
en dessous du 
précédent  un 
comportement de la 
PILE  
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11. Utilisation du Dynamic Painting 
Exercice Texte en Eau 

Liste des points nouveaux abordés  
Transformation Objet Texte en Objet maillage 
Notion de dynamic paint (peinture dynamique) d’un objet sur un autre (couleur gravure …) 
Notion de simulation des liquides 
 

Objectif : Création d’une animation d’une petite sphère qui traverse un texte en volume dont la matière simule 
l’eau. 

11.1. CRÉATION D’UN MAILLAGE  À PARTIR D’UN OBJET TEXTE MISE EN FORME, 

D’ABORD Panneau3DView > BarreMenus > Menu=Add > Entrée = Text 
PUIS  Redresser le texte > rotation de l’objet autour des X de 90° > Touches = [R]+[X]+[90] 
PUIS  Edit Mode  > Effacer le texte par défaut puis taper le texte par  = « Blender » 
PUIS  Object Mode > Donner du Volume au texte  
  PanneauProporties > BarreIcones > Icône = Texte (symbole F) < Clic 
   PanneauTexte > Paragraphe = Geometry > Case = Extrude < 0.1 (Épaisseur des lettres)  
   Paragraphe = Geometry > Case = Depth < 0.02 (Bisot bord de lettre) 
   Paragraphe = Geometry > Case = Resolution < 3 (Arrondi du bisot) 
   Paragraphe = Paragraph > Case = Spacing < 1.2 (espacement entre les lettres) 
PUIS  Transformation de l’objet Texte en Maillage 
  Panneau3DView > BarreMenus > Menu = Convert to > Entrée = Mesh from Curve/…/Text 
Remarque : En Edit Mode on peut remarquer que la géometrie du maillage n’est pas uniforme. 
PUIS  Edit Mode > Sélectionner Tout le maillage 
PUIS  Supprimer les doublons de la transformation Texte > Mesh 
  PanneauT > Onglet = Tools > Paragraphe = Remove > Case = Remove Doubles < Clic 
PUIS  Object Mode > Uniformisation du maillage 
  PanneauProporties > BarreIcones > Icones = Modifier < clic 
   PanneauModifier > Bouton = Add Modifier < clic 
   MenuContextuel > Colonne = Generate > Entrée = Remesh < clic 
Remarque : le maillage texte est complètement déconnecté, il faut le reconnecter 
   Case Remove Disconnected Pieces < Décocher !!!!! 
   Case Octree Depth < 6  
   PanneauModifier > Bouton = Apply < clic  (application définitive remaillage) 
PUIS  Lissage du maillage 
  PanneauT > Onglet = Tools > Paragraphe = Shading > Bouton = Smooth < clic 
Remarque : l’opération précédente est en générale insuffisante, les bords présentent un fort crénelage. 
PUIS  Edit Mode > Sélectionner le maillage 
ENFIN PanneauT > Onglet = Tools > Paragraphe = Defrorm > Case = Smooth Vertex < clic 
  PanneauEphemere > Bouton = Repeat < 10 

11.2. CRÉATION DE LA SPHÈRE-PROJECTILE ET DE SON ANIMATION ET D’UN PLANCHER DE RÉFÉRENCE 

D’ABORD Ajouter une UVSphere  (dimension 0.5) devant le texte à mi hauteur. Comme le montre la figure ci –
dessous. 
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PUIS  Animation de la sphère : 
Position curseur animation Position sphere/texte Mémorisation Keyframe 
PanneauAnimation > 
BoutonCurseur < 1 

Vue Face : Position texte – figure ci-dessus Insertion KeyFrame > 
Location 

PanneauAnimation > 
BoutonCurseur < 40 

Déplacer la sphère derrière le texte même 
hauteur 

Insertion KeyFrame > 
Location 

PanneauAnimation > Case = End < 60 ( limitation de la longueur de la séquence à 60 frames ) 
ENFIN   Ajouter un plan sous le texte et centré sur le milieu du texte (dimension 10) 

11.3. MISE EN PLACE DES DIFFÉRENTS MATERIAL DES OBJETS DE LA SCÈNE. 

D’ABORD Pour le plancher :  Diffuse BSDF > Gris clair (RGB > 0.4) 
PUIS  Pour le Monde :   Eclairage clair  (RGB > 0.6) 
PUIS  Pour le Texte :   GlassBSDF (R > 0.6 ; G > 0.7 ; B > 0.8) 
ENFIN  Pour la Sphere  DiffuseBSDF ( R > 0.3 ; G > 0.02 ; B > 0) 

11.4.  MISE EN PLACE D’UN ASPECT D’EAU SUR LE TEXTE SOUS L’ACTION DE LA SPHÈRE 

Principe : Pour dynamicPaint , il faut définir deux éléments : le support de la peinture (la toile = « Canvas ») et le 
pinceau ( la brosse = « Brush »). Ici la brush sera la sphere, le canvas le texte sumulant de l’eau. 
 

• PREMIÈRE PHASE :  LE TEXTE COMME « CANVAS » 
D’ABORD Sélectionner le texte 
PUIS  PanneauProporties > BarreIcones > Icône = Physics < Clic 
PUIS  PanneauPhysics > Case  Dynamic Paint < Clic 
PUIS   Paragraphe = Dynamic Paint > Case = Canvas < Clic 
PUIS      Bouton = Add Canvas < Clic 
Remarque : Vérifier dans Panneau > Paragraphe = Dynamic Paint Advanced que l’intervalle des Frames (ici 1 à 
40) correspond à celui de l’animation sinon corriger 
PUIS   Paragraphe = Dynamic Paint Advanced > Case = Surface Type < Clic 
     MenuContextuel > Entrée = Waves (simulation de vagues) 
     Case = Damping < 0.07 ( amortissement des vagues) 
Remarque : les facteurs  de la case d’amortissement : plus la valeur diminue plus l’amplitude des vagues est 
grand et inversement 
 

• DEUXIÈME PHASE : LA SPHÈRE COMME « BRUSH » 
D’ABORD Sélectionner la sphère 
PUIS  PanneauProporties > BarreIcones > Icône = Physics < Clic 
PUIS  PanneauPhysics > Case  Dynamic Paint < Clic 
PUIS   Paragraphe = Dynamic Paint > Case = Brush < Clic 
ENFIN      Bouton = Add Brush < Clic 
Résultat : En lançant l’animation la sphère traverse de gauche à droite le texte, celui-ci réagit comme s’il était 
constitué d’eau ! 
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12. Construire un material adaptatif qui en fonction d’une particule émise 
par un objet ,affiche à l’écran (viewport) une couleur différente. 

Liste des points nouveaux abordés ( symbole ) 
Notion de particules , Utilisation du NodeEditor pour définir les matériaux (couleurs, aspects …) d’un objet 
Notion de bibliothèque de materiaux complexes mis en groupe. 
Remarque : pour les nodes complexes un petit test permet de mieux comprendre son fonctionnement  >  signalé par symbole  

12.1. CRÉATION DES OBJETS DE BASE 

Remarque préliminaire : Blender peut attacher à un objet maillé  un système de points (dimension 0) appelé « système 
de particules » animées comme issues de cet objet. Mais pour les voir au rendu, il est nécessaire d’affecter à chaque point-
particule une copie (instance) d’un autre objet maillé choisi (ici une sphère).  

• PREMIÈRE PHASE : MISE EN PLACE DE L’OBJET SOURCE DU SYSTÈME DE PARTICULES 
D’ABORD Ajouter un plan (coté = 4 UB –Unités Blender) : l’émetteur (dimensions  indicatives) 
PUIS  Ajouter une UVsphere (diamètre = 2 UB) : le modèle des particules 
PUIS  Nommer le plan : EMETTEUR, la sphere : MODELE 
ENFIN Mettre la UVsphère dans le layer 2 pour ne pas gêner le travail 

• DEUXIÈME PHASE : MISE EN PLACE DU SYSTÈME DE PARTICULES SUR LE PLAN 
D’ABORD Sélectionner le plan 
PUIS PanneauProporties > BarreIcones > Icône=Particles < Clic 
PUIS Panneau Proporties >PanneauParticles > Bouton = New < Clic 
PUIS  PanneauParticles > Paragraphe = Emission >  
   Case = Number < 100 (nombre total des particules émises) 
   Case = Start < 1 (numero de frame de début démission des particules) 
   Case = End < 200 (numero de frame de fin de l’émission des particules) 
   Case = Lifetime < 200  (durée de vie en frames des particules) 
PUIS  Paragraphe = Velocity > Case = Normal < 10 (vitesse initiale normale des particules) 
PUIS  Paragraphe = Field Weights (Puissance des forces de champs actifs sur les particules) 
   Case = Gravity < 0 
Résultat : Dans le PanneauAnimation appuyer sur le bouton = lecture , les particules s’élèvent rapidement vers 
le haut. L’action suivante va permettre de « plafonner » leur progression verticale en les accumulant dans une 
sorte de nuage au dessus du plan (facteur Damp – friction, freinage …) 
PUIS  Paragraphe = Physics > SousParagraphe = Forces : > Case = Damp < 0.1 
PUIS  Paragraphe = Render > BarreCase > Case = Object < Clic 
PUIS   Case = Dupli Object < MODELE (Uvphere créée au depart) 
PUIS   Case = Size < 0.2 ( à régler selon les besoins) 
ENFIN  Paragraphe = Display > BarreCase > Case = Rendered < Clic 
Résultat : dans l’animation chaque particule est matérialisée par une instance (reproduction) de l’UVsphère.. 

12.2. CRÉATION DU MATÉRIEL (COULEUR) AVEC LE NODEEDITOR 
• PREMIÈRE PHASE : PRÉPARATION DE L’ESPACE DE TRAVAIL DE 

BLENDER 
D’ABORD Séparer horizontalement le Panneau3DView  en deux panneaux 
ENFIN  Choisir le type de chacun des panneaux par l’icône bas à droit  
 En haut : Panneau Node Editor  - Abréviation PanneauNE 
 En bas : Panneau 3DView  - Abréviation Panneau3D 

• DEUXIÈME PHASE : CONSTRUCTION DE L’ARBORESCENCE DES NODES  
Remarque préliminaire : UVsphere (nom : MODELE) sert de référence à chaque particule , c’est elle qui va 
recevoir le material. Mais ce material doit renvoyer au ViewPort une « couleur » différente selon la particule à 
laquelle  il s’applique. Hors Blender affecte à chaque particule un nombre unique (identifiant) en fonction de son 
ordre d’émission du plan. (voir figure ci-contre pour un exemple d’une émission de 10 particules) 

1 

0 

5 

3 4 

1 
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D’ABORD Sélectionner les deux layers 1 et 2 simultanément pour avoir le MODELE dans le même espace 
PUIS  Panneau 3D> Sélectionner = MODELE 
PUIS  Vérifier Moteur Rendu = Cycles (Barre menu Haut > Case = Cycles Render) 
PUIS  PanneauNE > BarreMenus > Case = New < Clic  
Résultat : Dans PanneauNE  : mise en place du material par default de blender Cycles : 
  Node = DiffuseBSDF > Node = Material OutPut 
 
 1-  Objectif :Ajouter un node qui récupère le numéro d’instance des particules : Particle info  
Moyen : PanneauNE > BarreMenus > Menu = Add > Entrée = Input > Sentrée = Particle Info 
Résultat : Affichaque dans l’espace des nodes du node : « Particle info » 
Liste et type des sorties du Node : ParticleInfo 
 
 
Valeur scalaire : numéro d’instance  > Caractèrise chaque particule 
Valeur scalaire : age en frame 
Valeur scalaire : durée de vie en frame 
Vecteur (3 coordonnées) : position 
Valeur scalaire : taille 
Vecteur (3 coordonnées) : vitesse 
Vecteur (3 coordonnées) : vitesse angulaire 
 
Remarque : La valeur récupérée est comprise entre 1  et 100 (nombre total de particules) 
 
 2-  Objectif : Ajouter un node qui à partir d’une valeur numérique renvoi un code de couleur  sur le 
Viewport : Hue Saturation value  
Moyen > PanneauNE > BarreMenus > Menu = Add > Entrée =Color > SEntrée = Hue Saturation Value 
 
Liste des Entrées du node : HSV 
    Vecteur (3 coord) : Couleur (de sortie) 
Valeur scalaire : Teinte 
Valeur scalaire : Intensité 
Valeur scalaire : Brillance 
Valeur scalaire : Puissance 
Vecteur (3 coord) : Couleur 
 
 Test : PanneauNE > Connecter en direct [Node HSV] > [Diffuse BSDF] comme le montre la figure ci 
dessous  et choisir une couleur dans le node HSV (case = Color et choisir dans le disque des couleurs)) 
 
 
 
 
 
 
 
 
Remarque de fonctionnement : la modification de la valeur de [Hue] déplace dans le disque des couleurs le 
pointeur de couleur sur une trajectoire circulaire pointillée (figure du dessous) et donc conduit à des couleurs 
affichées différentes – Voir Panneau3D en mode Rendered. 
 
 
 
 
 
 
 

Effet du Clic 
 sur la case Color 

Pointeur de la 
couleur choisie 

Pointeur de la 
couleur choisie 

Trajectoire correspondant à 
la variation de la valeur de 
Hue entre 0 et 1 
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 3 - Objectif : Relier la chaine de Nodes :  
Pour relier : Node [Particle Info] > Node [Hue Saturation Value] > Diffuse BSDF > Material Output 
Contrainte :  Node [Particle Info] > Sortie = Index  donne une valeur comprise entre 1 et 100  alorsque  
  Node [Hue Saturation Value] < Entrée = Hue reçoit une valeur comprise entre 0 et 1 
Methode  : Construction d’une « boite de nodes » telle que  
si  (la valeur d’entrée est comprise entre 0 et 100) alors (la valeur de sortie est comprise entre 0 et 1) 
On voit qu’il suffit de prendre (valeur sortie)= (valeur entrée) / 100 pour cela on dispose d’un node Math 
Moyen : PanneauNE > BarreMenus > Menu = Add > Entrée = Converter > SEntrée = Math 
  Sur le Node > Bouton = Type d’opération > MenuContextuel > Entrée = Divide < clic 
 
 
Liste des Entrées       Liste de la Sortie 
          Valeur scalaire : V1/V2 (ici 0,05) 
Bouton = Type d’opération choisie 
 
Valeur scalaire : V1 à choisir (ici 5)  
Valeur scalaire : V2 (ici 100) 
 
PanneauNE > Connexion de l’ensemble comme le montre la figure ci-dessous : 
 

Liens 
(Sockets) 

Transfert de l’index  
de chaque particule 

Transfert de 
l’index normalisée 

de chaque 
particule 

Transfert de la couleur 
correspondant à la valeur 

de l’index normalisé 

Transfert du calcul  
d’affichage 

 

 
 
 
 
 
 
 
 

    
 

Fonctions  
des Nodes 

 
 

Fonction qui 
transforme un 

nombre compris ente 
0 et 100 en un nombre 

compris entre 0 et 1 
 

Conversion des 
paramètres HSV en 

une couleur 
 

Shader« mat » 
recevant une couleur 
renvoyant le calcul 

d’affichage du 
material 

 

Sortie sur la surface 
de l’objet sélectionné 

du material sur le 
Viewport 

 

 
Résultat : On obtient le rendu de la figure ci-dessous. En agissant d=sur le paramètre « Value » du Node Math – 
Divide , on peut faire varier la multiplicité des couleurs. (Exemple ci-dessous) 
 
 
 
 
 

12.3. CRÉATION D’UN NODE DE REGROUPANT LES NODES PRÉCÉDENTS 

D’ABORD PanneauNE > Sélectionner tous les nodes sauf le node [Material Output]  
  PUIS PanneauNE > BarreMenus > Menu = Node > Entrée = Make Group 
Résultat : l’espace du PanneauNE devient celui de le figure ci-dessous : 
 
 
 
 
 
 

Value = 100 Value = 200 Value = 400 

Symbolisation des entrées 
en attente du Nouveau Node 
CECI N’EST PAS UN NODE ! 
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ENFIN PanneauNE  en appuyant sur la touche [Tab] : 
L’ensemble des nodes sélectionnés est « encapsulé » dans le 
nouveau node appelé « NodeGroup » -voir figure ci-contre. La 
touche [Tab] dite d  « ’édition » fonctionne en bascule, si l’on la 
réutilise en développe l’intérieur du Node. 
 

12.4. NOMMER ET PARAMÉTRER LE NODEGROUP. 
• PREMIÈRE PHASE : NOMMER LE NODEGROUP 

D’ABORD  PanneauNE dans le corps du NodeGroup > Case = NodeGroup < Clic 
Taper =  « Multicol-Particule » 
Résultat : Le nouveau nom « Multicol-Particule » apparaît dans l’entête du Node. 
PUIS  PanneauNE > Sélectionner le node Multicol-Particule  
PUIS  Editer le Node en Appuyant sur la touche [Tab] 
 

• DEUXIÈME PHASE : AFFECTER LE NOUVEAU NODE DE DEUX PARAMETRES : LA COULEUR QUI INITIALISE LE 
NODE HUE SATURATION VALUE, ET LE FACTEUR DE DIVISION DU NODE MATH-DIVIDE 

Moyen : Relier un lien entre GroupInput  et une entrée d’un node interne au NodeGroup 
D’ABORD Tirer un lien (socket) qui relie la sortie non affectée de GroupInput à l’entrée Color du Node Hue 
Saturation comme le montre la figure ci-dessous. 
 
 
 
  
 
 
 
 
 
 
Résultat : la première entrée Group Input est affectée du nom « Color » et une seconde entrée en attente est 
créée (petit cercle sous le point jaune connecté de Color - figure ci-dessus : Entrée en attente)  
ENFIN Tirer un second lien (socket) qui relie la sortie non affectée de GroupInput à l’entrée Value du Node 
Divide comme le montre la figure ci-dessous. 
 
 
 
 
 
 
 
 
 
 
Résultat : La deuxième entrée Group Input est affectée du nom « Value »  
 

• TROISIÈME PHASE :  NOMMER « EN CLAIR LES EFFETS » DES PARAMÈTRES DU NODE MULTICOL-PARTICULE  
Moyen : Paramétrage de l’interface du node par le Panneau N du NodeEditor 
D’ABORD  Dans le PanneauNE > Taper « N » 
Résultat : Apparition du PanneauN (à droite du PanneauNE) 
PUIS  PanneauN > Paragraphe = Interface > TableauNoms > Nom = Color < Clic 
    Case = Name < Taper > « CouleurInit » 
PUIS PanneauN > Paragraphe = Interface > TableauNoms > Nom = Value < Clic 
    Case = Name < Taper > « Dispersion » 
PUIS  Appuyer sur [Tab] 

Entrée en attente d’affectation 

Nouveau Lien 

Nouveau Lien 
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Résultat : On obtient le nouveau Node « Muticol-Part » avec ses deux paramètres intégrés modifiables comme 
le montre la figure ci-dessous 
 
 
 
 
 
 
  
 

12.5. AJOUT DU NOUVEAU NODE À LA PALETTE DE LA SESSION ACTIVE DE BLENDER.  

Objectif : Pouvoir utiliser le Node « Multicol-Particule » comme les autres nodes, dans : 
  PanneauNE > BarreMenus > Menu = Add > Entrée = Group > SEntrée = Multicol-Particule 
Moyen : PanneauNE > Node = Multicol-Particule > Case = « F » < Clic 
Résultat : le Node est enregistré même s’il n’est supporté par aucun objet , dans la liste des nodes utilisables 
dans cette session de blender. 
 

12.6. UTILISATION D’UN FICHIER BLENDER COMME « LIBRAIRIE » DE NODES CONSTRUITS  

Important : On enregistre ce fichier sous le nom « Librairie » (par exemple ), on pourra à partir d’une autre 
session de Blender, importer ce nouveau Node « Multicol-Particule ». 
Methode de réutilisation :  
D’ABORD Ouvrir une session Blender et créer un système de particules en affectant un objet-Modele aux 
particules 
PUIS  PanneauInfo > BarreMenus > Menu= Fichier >Entrée = Append 
Dans Explorer de fichier > Choisir le fichier « Librairie.blend » 
Dans la l’arborescence du fichier > Ouvrir « Node Tree » 
 Selectionner dans la liste « Multicol-Particule » 
Revenir dans le Panneau3DView, affecter par exemple à l’objet-Modele le material « Multicol-Particule » 
 
Remarque : Afin de compléter la « librairie » , il suffira à chaque nouveau création de la reproduire dans le fichier 
blender « librairie » comme l’a montré l’exercice précédent. 
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13. Application du système de Nodes :  
Construction d’un SHADER pour obtenir des dégradés sur un objet suivant les 

axes X ou Y ou Z (sous Cycles Render) 

Objectif : Construire un matérial qui lorsqu’il s’applique à un objet ,affiche sur le viewport une graduation 
de couleur suivant par exemple ici la coordonnée Z (comme les courbes de niveaux sur les cartes !) 
Remarque préliminaire 1: On suppose ici que l’espace de travail a été obtenu en séparant PanneauView3D en 
deux panneaux horizontaux:  
 un panneau haut > Node Editor  appelé PanneauNE dans la suite 
 un panneau bas > Resté en 3Dview appelé Panneau3D dans la suite 
Remarque préliminaire 2 : Les nodes proposés sont souvent complexes, aussi dans la progression de leur 
utilisation, des paragraphes de « Test » sont ajoutés avec l’icône   
 

13.1. RECHERCHE ET TESTS DE NODES CORRESPONDANTS 
• PREMIÈRE PHASE : MISE EN PLACE SUR UN OBJET D’UN NODE DE COLORIAGE VARIABLE 

Objectif : Afficher une couleur sur un objet (exemple : Cube), que l’on peut faire varier selon un paramètre 
numérique entré « à la main » 
D’ABORD Panneau3D  > Ajouter un cube à la scène et se mettre en MODE RENDERED (régler l’éclairage) 
PUIS  PanneauNE > BarreMenus > Bouton = New < Clic 
Résultat : Le material de base de Blender : Diffuse BSDF > Material Output est affecté au cube. 
Moyen : Ajout du node « ColorRamp » qui va fournir la palette des couleurs et d’un node « Value » qui va jouer 
le role de tester de valeur d’entrée 
PUIS  PanneauNE > BarreMenus > Menu = Add > Entrée = Converter > SEntrée = ColorRamp 
 
Liste des entrées du node     Liste des sorties du node 
         Vecteur couleur (3 coordonnées) 
         Valeur Scalaire de transparence 
 
 
 
 
Valeur scalaire : à interpreter 
 
  Test partie 1: pour comprendre le fonctionnement du node ColorRamp selon une valeur entrée 
 
D’ABORD  Node de saisie : PanneauNE > BarreMenus > Menu = Add > Entrée =Input > SEntrée = Value 
 
         Liste des sorties du node 
         Valeur scalaire transmise 
Case de saisie : valeur scalaire 
 
PUIS   PanneauNE > Connections des liens (sockets) comme le montre la figure ci-dessous 
 
 
 
 
 
 
 
 
Résultat : selon la valeur entrée (comprise entre 0 et 1 ) le cube passe du NOIR (valeur = 0) au BLANC (valeur = 
1) en passant par les nuances de gris 

Valeur à modifier 
en saisie clavier 
(pour test effet) 
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Test partie 2 : Paramétrage de couleurs dans le node colorRamp 

Comme le montre la figure le Node présente en partie centrale une case-ruban (appelée « Rampe ») de couleur 
dégradée du noir vers le blanc (de gauche à droite). A chaque extrémité sont disposés deux pointeaux qui ont 
pour rôle d’indiquer une couleur d’application (petite case interne au pointeau) . Chaque pointeau possède un 
numéro indiqué dans la case indiqué sur la figure, et aussi une position ( Pos : entre 0 et 1) sur la Rampe, cette 
valeur est accessible dans cette case [Pos :],  
Action sélectionner un pointeau : on clique dessus ou on tape son numéro dans la case numéro. 
Action déplacer un pointeau sur la Rampe : on clique et en maintient pendant de déplacement, ou on tape une 
valeur comprise entre 0 et 1 dans la case Pos :  
 
 
 
 
 
 
 
 
Action changer la couleur associée à un pointeau : on sélectionne le pointeau et on clique sur le case couleur 
sous le numéro et la position (figure ci-dessous) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Action ajouter plusieurs couleurs sur la rampe : on clique sur le bouton [+] pour ajouter des pointeaux, et 
après avoir sélectionné un pointeau on clique sur [-] pour l’effacer. On affecte ensuite à chaque pointeau la 
couleur voulue  (voir figure ci-dessous) 
 
Dans l’exemple ci-contre on a choisi : 
 Pointeau 0  > couleur = Vert  Pos : 0.5 
 Pointeau 1  > couleur = Bleu  Pos : 0.3 
 Pointeau 2  > couleur = Rouge Pos : 0.6 
 Pointeau 3  > couleur = Jaune Pos : 0.9 
 

Test Partie 3 – Vérification du changement des couleurs sur le cube en entrant une valeur dans value 
Il suffit de remplacer le node ColorRamp (noir et blanc) par le nouveau Node à 4 couleurs comme le montre la 
figure ci-dessous 
 
 
   
 
 
 
 
Résultat : selon les valeur dans node « Value » entre 0 et 1 , le cube affiche les couleurs du vert au jaune. 

 
Pointeau (sélectionné) 
Couleur = Noir 
Numéro =  0  
Position = 0.200 

 
Pointeau (non sélectionné) 
Couleur = Noir 
Numéro =  1  
Position = 0.800 
 

Clic sur la couleur 
choisie dans disque 

Affichage disque  
des couleurs 

ETAT INITIAL  
du NODE 

ETAT FINAL  
du NODE 

Pointeau 1 
sélectionné 

Clic sur case couleur 
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• DEUXIÈME PHASE : MISE AU POINT D’UNE FONCTION QUI FOURNIT LA VALEUR DE LA VALEUR DE LA 
COORDONNÉE Z D’UNE TEXTURE APPLIQUÉE À UN OBJET 

Remarque préliminaire : Afin de comprendre la localisation de diverses couleurs sur un objet , nous allons en 
employer une texture.Une texture est une image plane (motif, photographie ….) que l’on veut appliquer à le 
surface d’un objet 3D.  
Principe : Pour simplifier et de ne pas déformer trop l’image on utilise un Node qui permet de répartir au mieux  
(projeter !) la surface d’un objet 3D sur un plan qui recevra l’image : Texture Coordinate (voir figure ci-dessous). 
Moyen : PanneauNE > Barremenus > Menu = Input > Entrée = Texture Coordinate 
 
    Liste des sorties 
    Vecteurs (position) des éléments de texture générée automatiquement 
    Vecteurs normaux à la texture 
    Vecteurs de la texture de dépliage courant (si existant !) 
    Vecteur d’un objet servant de pilote au déplacement relatif de la texture 
    Vecteur de position dans l’espace vue de la camera 
    ? 
    ? 
    Objet pilote du déplacement relatif de la texture / objet 
    ? 
 
Objectif : Pouvoir déplacer , déformer la texture pour l’ajuster au mieux sur l’objet 
Moyen : On dispose d’un node qui permet d’agir sur la récupération des vecteurs de la texture de Texture 
Coordinate  sur la position, la rotation, et l’échelle de ceux-ci : node Mapping  
 
Vecteur transformé renvoyé 
 
 
 
 
 
 
Vecteur reçu 
 
 
 
  Test : Pour comprendre le fonctionnement du couple de nodes Texture Generated – Mapping, on 
ajoute une texture témoin présenté sous forme d’un quadrillage d’échiquier dans le node Checker Texture 
(échiquier : très utile pour tester les effets de déplacement !) 
D’ABORD  Panneau3D > sélectionner le cube 
PUIS  PanneauNE > Remplacer les nodes précédent sauf Diffuse BSDF et Material Output par ceux de la 
figure ci-dessous : 
  
 
 
 
 
 
 
 
Remarque : en changeant certains paramètres du node Mapping on obtient les exemples ci-dessous. 
 
 
 
 
 

Cases d’actions des transformations vectorielles 
Déplacement en translation  

Déplacement en rotation 
Déplacement en dilatation 

Rotation X = 60 Valeurs initiales Position Y = 0.1 Scale Z = 0.5 

X 

Z 

Y 

REPERE GLOBAL 
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• TROISIÈME PHASE : MISE EN PLACE DES COULEURS DE NIVEAUX SUR LE CUBE : TRANSMISSION DE LA 
COORDONNÉE Z DE TEXTURE AU NODE COLORRAMP : NODE SEPARATE XYZ 

 
On définit ainsi la fonction ci-dessous, qui lorsqu’elle s’applique à un objet, va définir sur celui-ci en fonction de la 
coordonnée Z les couleurs : noir, blen, jaune, vert et orange. 
 
 

Liens 
(Sockets) 

Transfert des vecteurs de la 
texture générée sur l’objet 

Transfert du vecteur 
transformé 

Transfert de la 
coordonnée Z 

 

 
 
 
 
 
 
 
 
 
 

   

Fonction de 
développement plan du 
maillage  (UVmapping) 

Fonction de transformation des 
vecteurs de la texture générée 

Séparation de la 
coordonnée Z du 

vecteur  

Selon la valeur de Z reçue sortie 
de la couleur correspondante 

 
Implantation de la fonction sur l’entrée du couple DiffuseBSDF-MaterialOutput qui définit la sortie sur le 
viewport (écran) 
 
 
 
 
 
 
 
 
 
Résultat : On obtient sur le viewport le rendu ci-dessous à gauche, à droite exemple sur objet Landscape 
 
 
 
 
 
 
 
Remarque : A l’aide de la méthode expliquée dans le chapitre précédent en peut sauver ce material dans le 
fichier « Librairie » sous le nom : Zniv6Couleurs 

FONCTION 

FONCTION VIEWPORT 
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14. Applications-Exercices à propos des materials et de l’utilisation du 
Node-Editor (sous Cycles Render !) 

14.1. EXERCICE 1 – ILLUSTRATION DU CODAGE DES COULEURS DANS BLENDER 

Objectif : Sur un objet cubique de coté 4 centré sur origine de l’univers et dont chaque sommet est 
pourvu d’une Uvsphère. Construire un SEUL material qui donne un rendu de couleur différent pour 
chaque sphère. 
 

• PREMIÈRE PHASE : CONSTRUCTION DE QUATRE SPHÈRES RÉPARTIES SUR LES SOMMENT D’UN CUBE 
D’ABORD  Créer un Cube de 4u de coté. 
PUIS   Ajouter une UV sphère de diamètre 2 
PUIS   Parenter la sphère au cube  
    Sélection maintenue ( touche [Maj]) d’abord la sphère puis le cube 
    Taper [Ctrl] + [P] > Menu Contextuel = Set Parent to > Menu = Object 
PUIS   Sélectionner le Cube 
PUIS    PanneauProporties > BarreIcones > Icône =Object > Paragraphe = Duplication 

   BarreCase > Case = Vertices < Cocher 
Résultat : la sphere est dupliquée en quatre sphères, réparties sur les quatre sommets du cube. 

• DEUXIÈME PHASE : CRÉATION D’UN MATERIAL QUI CHANGE DE COULEUR SUIVANT LA POSITION DE L’OBJET QUI 
LE SUPPORTE 

Principe : On utilise ici le codage « vectoriel » des couleurs dans Blender (table ci-dessous) et le node Object 
Info qui délivre en particulier les coordonnées de l’objet auquel on l’applique (voit figure cidessous) 
 
          Liste des sorties du node Object Info 
          Vecteur (3 coord .) = position de objet 
          Scalaire = index de l’objet 
          Scalaire = index du matérial 
          Scalaire = valeur unique affecté à 
 
D’ABORD Mettre l’espace de travail sous la forme du Chapitre 12 (Panneau 3DView, PanneauNodeEditor) 
PUIS  PanneauOutliner > Sélectionner la sphère qui a servi à la duplication 
PUIS  PanneauNE > BarreMenu > Case = New < Clic (création d’un nouveau material) 
Résultat : le material de base DiffuseBSDF relier à la sortie viewport  
PUIS  PanneauNE > BarreMenu > Menu =Add > Entrée = Input > SEntrée = Object Info 
PUIS  PanneauNE > Connecter les nodes comme le montre la figure ci-dessous 
 
 
 
 
 
 
 
 
 
PUIS  Panneau3Dview > BarreMenus > Bouton = Affichage des shaders dans 3D view < Rendered 
Résultat : On obtient une couleur par sphère comme le montre la figure du dessous du début de la Phase de 
travail : LE MËME material affiche une couleur DIFFERENTE selon la position de l’objet auquel il s’applique. 
Remarque : Ce codage « vectoriel » permet d’obtenir la combinaison des couleurs par des opérations sur les 
vecteurs  
 

Blanc  (1,1,1) 
Cyan  (0,1,1) 
Vert  (0,1,0) 
Jaune  (1,1,0) 
Rouge  (1,0,0) 
Magenta  (1,0,1) 
Bleu  (0,0,1) 
Noir  (0,0,0) 
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14.2. EXERCICE 2 – ILLUSTRATION DE GRADIENT DE COULEURS 

Objectif : Sur un objet circulaire, obtenir un changement dégradé de couleur radial 
 

• PREMIÈRE PHASE – UTILISATION D’UN GRADIENT DE TEINTE 
Principe : Un gradient de teinte peut être défini comme le passage plus ou moins progressif d’une couleur 
(exemple le noir) vers une autre couleur (blanc) dans une direction donnée (passage par les gris !).  
Moyen : Pour simuler ce phénomène on dispose d’un Node qui crée le gradient : Gradient Texture 
 

1- Création d’un gradient linéaire sur le plane : Node Gradient-Texture 
 Test : Pour comprendre simplement le fonctionnement de ce node sur un objet simple : plane. 
D’ABORD Panneau3DView > Créer un plane 
PUIS  Sélectionner le Plan  
PUIS  ModeEdit > BarreMenus > Menu = Mesh >Entrée = UnWrap … > SEntrée = Unwrap 
PUIS  PanneauNE > Créer l’arbre de Nodes ci-dessous  
 

Liens 
(Sockets) 

Transfert du facteur couleur 
selon les X de la texture créée 

sur l’objet 

Transfert e la couleur 
transformée selon la 

position sur la texture 

Transfert au 
VewPort 

 

 
 
 
 
 
 
 
 
 
 

   

Fonction de création du 
dégradé selon 

 la coordonnée  X 

Fonctions distibution des couleurs 
selon les vecteurs (positions) de la 

texture créée 

Shader par default 
de l’objet (Opaque) 

Calcul de l’affichage de la 
Surface de l’objet sur le VewPort 

 
Résultat : On obtient sur le disque le dégradé de la figure ci-contre. 
 
Remarque : Si l’on agit dans le Node ColorRamp > Case Pos : en changeant valeur ( potion du 
pointeur entre Noir/Blanc) on observe un déplacement (gauche-droite / figure) de la limite entre 
les deux teintes . Ainsi  peut interpréter une correspondance entre la rampe (intervalle compris 
entre 0 et 1) et la largeur du plan. 
 

2- Création d’un gradient radial :  
Objectif : le dégradé recherché doit partir d’une couleur (blanc ici) au centre et se propager radialement vers le 
bord en noir. 
Moyen : Pour cela nous disposons déjà dans le Node GradientTexture d’une case centrale qui par default 
contient « Linear » (voir paragraphe précédent) : cette case donne le type de répartition du dégradé . 
D’ABORD Node=GradientTexture > Case = Linear < Spherical 
PUIS  PanneauNE > NodeMapping > positionner le curseur de noir à l’extrème gauche  

( Pos: = 0) 
Résultat : Le dégradé observé (figure ci-contre) est cette fois radial a partir de l’origine de la 
texture projetée (en gros en bas à gauche).  
 
 3-  Centrage du dégradé radial sur l’objet : Nodes Coordinate Texture et Mapping  
Objectif : Déplacer le centre du dégradé au milieu du Plan 
Moyen : Il faut déplacer la texture  sur la diagonale du plan : coin bas gauche , coin haut droit. Le node texture 
coordinate appliqué au plan donne les coordonnées de la texture / plan.  (voir figure ci-contre). Le node 
Mapping récupère des coordonnées et permet de eur appliquer une transformation géométique ( Translation, 
Rotation, Changement d’ Echelle …) 



 

 78 

Remarque : Ce système de développement de l’objet sur un plan (UnWrappin) fait « coïncider » au mieux 
l’image de la texture avec la surface de l’objet (le système de coordonnées en 2D est noté U, V- Voir chapitre 
suivant pour plus de détails sur les UVMap)  
D’ABORD  Ajouter le Node Texture Coordinate : PanneauNE > BarreMenus > Menu = Add > Entrée = Input 
PUIS  Ajouter le Node Mapping : PanneauNE > BarreMenus > Menu = Add > Entrée =Vector 
 
 
 
 
 
 
 
 
 
PUIS  Paramétrer la tranformation des coordonnées texture dans le Node Mapping 
   BarreCase > Case = Texture < à cocher  
   Mise à l’échelle : BlocCases = Scale > Case X,Y,Z < 0.5 ( rayon du dégradé) 
   Déplacement du cetre de dégradé : BlocCases = Location > Case X,Y < 0.5 
PUIS  Dans l’arbre de Nodes précédent  ajouter devant le Node GradientTexture le couple Texture 
Coordinate, Mapping et connecter  selon la figure cidessous 
 

Liens 
(Sockets) 

Transfert des vecteurs de la 
texture développée sur l’objet 

Transfert du vecteur 
transformé 

Transfert de la 
coordonnée Z 

 

 
 
 
 
 
 
 
 
 
 

  
 
 
 

 

 

Fonction de 
récuparation des 
coordonnées du 
dévellopement UV de 
l’objet 

Fonctions de transformation 
géométrique des vecteurs de la texture 

générée 

Fonction de 
création du 

dégradé selon 
 la distance au 

centre 

Distibution des couleurs selon 
distance par rapport au centre 

du plan 

 
• DEUXIÈME PHASE – CRÉER UN OBJET CIRCULAIRE AVEC UN GRADIENT RADIAL A PARTIT DU CENTRE 

D’ABORD Panneau3DView > BarreMenus > Menu = Add > Entrée = Mesh >Entrée Circle (rayon = 2u) 
PUIS  ModeEdit > Menu = Mesh > Entrée = Face > SEntrée = MakeEdge/Face 
Résultat : On obtient un disque  
PUIS  PanneauNE > Créer l’arborescence de nodes ci- dessous 
  Node ColorRamp > Placer respectivement les pointeaux : 
 Cyan = 0.2 - Vert = 0 – Jaune = 0.6 – Rouge = 0.8 
   

 
 
 
 
 
 
 
 
 

   

Récupération des coordonnées UV 
sur le dépliage de l’obje 

Et 
Transmission à la transformation 

géométrique des coordonnées 
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Résultat : On obtient ainsi une répartition des couleurs en « cible » sur le disque. 
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15. Application-Exercide sur le système de Nodes : 
Animation d’un objet par une flamme et de sa fumée dans blender  

(Cycles Render) 

Liste des points nouveaux abordés : symbole 
Notion de simulation de feu et de fumée 
Application et description du node ColorRamp 

15.1. MISE EN PLACE DE L’OBJET ÉMETTEUR DE FUMÉE 

D’ABORD Créer un objet qui sera émetteur de flamme et de fumée : choix Suzanne (Mesh = Monkey) 
PUIS  Panneau3D > BarreMenus > Menu = Quick Effect > Entrée = Quick Smoke 
Résultat : Apparition d’un parallélépipède filaire contenant la sphère : c’est le domaine qui servira de container 
au phénomène (rien n’existe au dehors) 

15.2. AJOUTER LES FLAMMES À L’ÉMETTEUR DE FUMÉE 

D’ABORD Sélectionner Suzanne 
PUIS  PanneauProperties > BarreIcones > Icone= Physics < clic 
PUIS  Panneau Paragraphe = Smoke > Bouton = Flow Type < Entrée = « Fire + Smoke » 
Verification de fonctionnement : Lancer l’animation dans le PanneauAnimation avec les commandes type 
magneto > Apparition de la fumée et cette fois de flamme ! Mais si l’on se met en mode rendu : de la fumée mais 
toujours pas de flamme ! Il va falloir travailler les materials ! 

15.3. MISE EN PLACE DE L’ESPACE DE TRAVAIL : SÉPARATION  L’ESPACE DE TRAVAIL EN DEUX PANNEAUX 

HORIZONTAUX   

D’ABORD En Haut : Transformer en PanneauNode Editor (Choisir pour l’IcôneType < Node Editor !) 
PUIS  En Bas : Laisser Panneau 3D View  
PUIS  Panneau3DView > Sélectionner Domaine (rappel : parallèlipipède filaire entourant Suzanne) 
Résultat : Apparition dans PanneauNodeEditor du système de nodes attaché au domaine pour simuler le feu et 
la fumée, l’’état de ce matérial dynamique est celui décrit dans la figure ci-dessous. Ce qu’il faut en retenir y est 
spécifié : 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Permet  le réglage de l’intensité de fumée 
par  la rentrée d’un facteur de 
multiplication dans « value » (ici = 2) 

 

Attribue la densité des pixels de volume 
(voxel) de la fumée (nom= density ) par la 
valeur transmise par Fac 

 

Attribue la couleur des pixels de volume 
(voxel) de la fumée (nom = color ) par la 
valeur transmise par Color 

 

Permet à la lumière  
de se disperser en 
traversant le volume 

Permet l’absorption  
d’une partie de la lumière en 
traversant le volume 
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15.4. PREMIÈRE MODIFICATION DU SYSTÈME NODAL POUR OBTENIR LES FLAMMES AU RENDU 

Remarque préliminaire : Comme c’est visible sur cet assemblage, le dernier node 
fonctionnel  « AddShader » avant « Material Output » comporte une entrée « Shader  
laissée inoccupée ».Il suffit de complémenter cette entrée pour donner au rendu une couleur 
d’émission à la flamme comme le montre la figure ci-dessous : 
D’ABORD PanneauNE > BarreMenus > Menu = Add > Entrée = Shader > SEntrée = Emission  
( emet la luminosité d’un flamme de couleur choisie) 
PUIS  Node = Emission > Case = Color < choisir Orange (Rappel : après un clic sur la 
case permet affichage du disque de couleurs ci-contre !!) 
PUIS  PanneauNE > BarreMenus > Menu = Add > Entrée =Input > SEntrée = Attribute  
PUIS  Node = Attribute > Paramètre = Name < Taper « flame » (Attention ! c’est un mot-clé , cette entrée 
permet de renvoyer un facteur de densité de flamme dans « Fac » dans le Domaine de calcul) 
PUIS  Connecter les liens (sockets) comme le montre la figure ci-dessous 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Résultat : en Mode Rendu avec l’animation on obtient le résultat de la figure ci – jointe 
 
 
 
 
 
 
 
 
 
 

15.5. DEUXIÈME MODIFICATION DU SYSTÈME NODAL POUR UN RENDU PLUS RÉALISTE DES FLAMMES 

Remarque préliminaire : La flamme obtenue est d’un orange uniforme ce qui n’est pas le cas d’une flamme 
dans la réalité, on a plutot un cœur de flamme rouge sombre qui tend vers la surface vers yb jaune de plus en 
plus clair. Pour cela il nous faut une représentation de la couleur qui passe donc du rouge sombre au jaune très , 
c’est que que peut faire le Node = ColorRamp 
 

• PREMIÈRE PHASE : EXPLICATION SCHEMATISÉE DU FONCTIONNEMENT DU NODE COLORRAMP 
 Test :  Dans le Panneau3DView on dispose d’un Mesh = Plane, sur lequel on applique un material comme 
le montre l’arbre des nodes de la figure ci-dessous . 
Explication : le node « Texture Coordinate » créé un dépliage automatique du plan , et renvoie sur sa sortie 
Generated les coordonnées de ce dépliage. Le groupe « DiffuseBSDF ---Material Output » applique sur l’Objet 
sélectionné un diffusion de la lumière qui est reproduite sur le ViewPort. 
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Schématisation du processus : Le Node « ColorRamp » est une fonction qui renvoie selon la coordonnée 
reçue, une couleur paramétrée par la rampe de couleurs proprement dite : Noir-Rouge-Jaune, les « regions » de 
ces couleurs sont repérés ici par trois pointeurs numérotés : 0,1,2  de position réglable.Cette position de chacun 
(sélectionnable à la souris !) peut être modifiée en entrant une valeur dans la Case = « Pos : », comprise entre 0 
et 1 qui représentent respectivement les extrémités de la rampe. ( dans la figure ci-dessous :Pointeau Noir = 0 , 
Pos = 0.2 ; Pointeau Rouge = 1 ; Pos =0.45 ; Pointeau Jaune = 2 ; Pos =0.7). Ainsi pour tout point M (u,v) du 
déploiement du plan, le ColorRamp recalcule u,v entre 0 et 1 (repère imagé à droite  en blanc ci-dessous), et en 
fonction de ces valeurs  par rapport aux positions des pointeurs renvoie, la couleur correspondante comme le 
schématise la figure ci-dessous. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

15.6. DEUXIÈME PHASE : APPLICATION DE L’UTILISATION DU NODE COLOR RAMP POUR RENDRE PLUS RÉALISTE LA 

FLAMME 

D’ABORD PanneauNE > BarreMenus > Menu = Add > Entrée =Converter > SousEntrée = ColorRamp 
PUIS  Paramétrer le ColorRamp comme dans l’exemple du paragraphe précédent en utilisant les 
informations déjà données dans le chapitre 11 
PUIS  Connecter le ColorRamp à l’ensemble comme le montre la figure ci-dessous  
Résultat : On obtient l’image de dessous à droite sur le ViewPort en mode Rendu. Mais on peut régler le 
ColorRamp avec ses pointeaux pour faire varier l’affichage comme on le souhaite ! 
 
 
 
 
 
 
 
 
 
 
 

1 
 
 
0.7 
 
0.45 
 
 

0.2 
 
0 

0 

1 

M(u,v) 
 

max(u) 
 

max(v) 
 

0 
 

u 
 

v 
 

Dépliage du plan généré 
par TextureCoordinate 

 

Rendu sur le 
Viewport 

 

SCHEMATISATION du principe 
de calcul de COLORRAMP 

 

L 
 

Calcul  
Transformation 

Couleur affichée au 

Transmission des 
coordonnées du dépliage 
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16. Exercice-Application - Utilisation de texture procédural pour créer des 
effets de couleur : Fin de soleil bleu (Cycles Render) 

16.1. CRÉATION D’UNE SPHÈRE ET MISE EN PLACE DE L’ESPACE DE TRAVAIL  

D’ABORD Ajouter une UVsphère de diamètre 5 
PUIS Lisser le sphere :  
  PanneauT > Onglet=Tools > Paragraphe = Shading > Case = Smooth < Clic 
PUIS  Centrer la vision de la camera sur le sphère 
PUIS  Séparer horizontalement  le panneau3Dview en deux (Split sur le bord vertical droit) 
ENFIN PanneauHaut > Icône = identité (bas-gauche) < Node Editor 

16.2. TRAVAIL NODE EDITOR : AFFECTER À LA SPHERE TRANSPARENTE ET UN BORD BLEU D’ÉMISSION 

Remarque préliminaire : Dans la suite on utilise le mot « material » pour désigner l’effet produit par la lumière 
sur le corps sur lequel le material s’applique (réflexion, transparence, absorbsion …et aussi la couleur renvoyée.) 
Mais on utilise aussi le mot « shader » pour désigner le nœud du material voulu, ce qui un peu impropre parce 
que le shader est réalité un petit programme qui affiche le rendu du material 
 

• PREMIÈRE PHASE : METTRE UN FOND NOIR À L’ENSEMBLE DE LA SCÈNE POUR FAIRE RESSORTIR LE SOLEIL 
D’ABORD PanneauProporties > BarreIcone > Icône = World < Clic 
  PanneauWorld > Paragraphe = Surface > Bouton = Color < clic 
  MenuContextuel > RampeVerticaleNoretBlanc < Glisser Curseur vers bas 
Résultat : dans Panneau 3DView en mode render : Fond est NOIR. 
 

• DEUXIÈME PHASE : AJOUTER UN MATERIAL À LA SPHERE POUR COMMENCER LA CONSTRUCTION DE L’ARBRE 
DES NODES QUI DONNERA L’EFFET SOUHAITÉ. 

D’ABORD Panneau 3DView > Créer Une UVSphère et la gardée sélectionnée 
PUIS  Panneau NodeEditor > BarreMenu > Case = Material > Bouton = «  + » < clic 
Résultat : Apparition dans l’espace de travail du panneau Node Editor d’un arbre minimal correspondant au 
material par défaut affecté à l’objet Sphère : Diffuse BSDF < connexion > Material OutPut 
PUIS  Supprimer le Nœud [Diffuse BSDF]  (selection et taper « X ») 
Objectif : Il faut utiliser un nœud qui mélange deux material d’une manière radiale sur l’objet : c’est le rôle du 
node appelé « layerWeight ». En particuler ce node permet de simuler l’effet de passage de la réflexion à la 
réfraction d’une surface ( selon angle de vision par exemple par rapport à une surface d’eau, soit on voit au 
travers, soit c’est miroir de l’extérieur : Effet Fresnel) donc ici le pourtour de la sphère aura une qualité de renvoi 
de la lumière que sa partie de premier plan 
PUIS  PanneauNE > Contruire l’arbre ci-dessous à gauche,  
Résultat : Panneau3Dview > On obtient la figure ci-dessous à droite, l’effet voulu. 
Remarque : si l’on change la valeur du paramètre [Blend] (qui veut dire « mélange ») on fait varier l’épaisseur de 
la couronne « bleue » selon ce que l’on veut : ici le choix est 0.2 
 
 
 
 
 
 
 
 
 
 
 

Material de 
transparence du 

corps  de la sphère 

Material d’émission 
bleu du bord d de la 

sphère 

Mélangeur entre les deux material : 
transparence et emission selon la 
région de la sphère  

Localisation Bord/face du type de renvoi de la lumèrel par la sphère 
 

Envoi à l’affichage (ViewPort) 

Affichage du ViewPort 
( en mode rendu) Paramètre 

d’ajustement 
de la couronne 

bleue 

ARBRE DE NODES 

APPELÉ 

« COURONNE » 
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16.3. UTILISATION D’UNE TEXTURE PROCÉDURALE POUR DONNER UN EFFET SOLAIRE  

Remarque préliminaire : On peut simplifier l’idée d’une texture procédurale, comme le résultat d’un motif plus 
ou moins aléatoire créé par un algorithme sur des couleurs.Cette création d’un effet d’irrégularités est appelée 
aussi « bruit » 
Objectif : Utiliser un « bruit » déjà existant pour agir localement sur le mélange au bord de la sphère entre les 
couleurs bleu et noire : le Node « NoiseTexture » 
D’ABORD Ajouter un node « Noise Texture » 
Remarque préliminaire : Dans PanneauNodeEditor pour voir les effets d’un node « Shader » quelconque , il 
suffit d’ appuyer simultanément sur [Maj]+[Ctrl] et de cliquergauche sur le node du shader : cela produit 
deux effets.Un node « Viewer » se connecte automatiquement entre la sortie du shader et l’entrée du mode 
« Materiel Output », ce qui a pour conséquence d’afficher l’effet dans le Viewport du Panneau3DView. 
 
PUIS  Visualiser sur le Panneau3Dview les effets du bruit représentés ci-dessous : 
 
 
 
 
 
 
 
 
PUIS  Mise en Noir et Blanc des effets du Node NoiseTexture >  
  Déconnecter l’entrée du Viewer 

 Connecter l’entrée du Viewer sur la sortie Fac du Node Noise , on obtient lle même bruit qu’au dessus 
mais en noir et blanc 

PUIS  Création d’un arbre de nodes pour augmenter le contraste entre zone blanche et zone grise. 
Objectif : les nuances entre les parties blanches et grisées étant relativement faibles, on va augmenter les 
contrastes. Sachant que numériquement le noir est 0 et le blanc est 1, les niveaux de gris sont des valeurs 
comprises entre 0 et 1 , il faut rapprocher les « faibles » variations de gris de la figure gauche ci dessus vers le 
noir, par exemple en retirant à toutes les valeurs de gris, la valeur 0.5. On obtient alors le résultat de la figure 
droite ci-dessous.  
Moyen :Ceci est réalisé par l’arbre de nodes ci-dessous. 
 
 
 
 
 
 
 
 
 
ENFIN  Application de la branche précédente à l’arborescence appelée « Couronne », on a : 
 
 
 
 
 
 
 
 
 
 
Remarque : l’additif d’un node type Converter > Math =« Multiply » permet le réglage de l’épaisseur de la 
couronne, en changeant le fracteur de multiplication Value 
Résultat : On obtient une modification de la couronne comme le montre la représentation du viewport ci-contre. 

Arbre de nodes qui prend la couleur de chaque 
pixels du noise de droit et lui retire 0.5 

Nodes 
de 

bruit 

Node de 
réglage 
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16.4. CRÉATION D’UN NODEGROUP PARAMÉTRÉ À PARTIR DE L’ARBRE DE NODES PRÉCÉDENT POUR UN RÉEMPLOI 

 
Objectif : Création à partir de l’ensemble des nodes précédents (premiere phase) d’un « empaquetage » 
permettant de les garder dans une Librairie et de les réutiliser ultérieurement   
 

• PREMIÈRE PHASE - « EMPAQUETAGE » DES NODES : CRÉATION D’UN « NODEGROUP » 
D’ABORD Dans le PanneauNodeEditor > 
  Utiliser la sélection en boite pour sélectionner l’ensemble de l’arbre SAUF le Node OutPut 
PUIS  PanneauNodeEditor > BarreMenu > Menu = Node > Entrée = Make Group (raccourci [Ctrl] + G) 
Résultat : Le fond du PanneauNodeEditor change de couleur (gris-vert) un nouveau node apparaît à gauche : 
Group Input, c’est en quelque sorte la « parenthèse ouvrante » de l’ensemble du NodeGroup, le node de droite 
GroupOutput en tête jaune lui sera la « parenthèse fermante ». Ceci signifie que l’ensemble est considéré 
comme un node (figure ci-dessous) 
 
 
 
 
 
 
 
 
 
 
 
ENFIN  Affichage du nouveau Node Créer  > Appuyer sur la touche [Tab]  
Résultat : L’ensemble est regroupé sous la forme ci-dessous  
 
 
 
 
 
Remarque : la touche la touche [Tab] fonctionne comme une bascule. Si après avoir sélectionné le NodeGroup, 
on appuie de nouveau sur [Tab], le Node est « édité » avec son contenu.  
 

• DEUXIÈME PHASE – DONNER UN NOM ET AJOUTER DES RÉGLAGES SUR LE NOUVEAU NODEGROUP 
D’ABORD  Selectionner le NodeGroup 
   PanneauNode > Taper N pour afficher le PanneauN correspondant 
PUIS   PanneauN > Paragraphe = Proporties > Case = NodeGroup < Taper « BruitFresnel » 
 1-  Objectif : Ajouter des paramètres de réglagle des nodes internes sur l’interface du Node. Par exemple 

ici on veut pouvoir changer la couleur de la couronne et son épaisseur. 
Moyen : Liaison interne :  GroupInput-Sortie > Entrée-Emission 
PUIS  Editer le NodeGroup (Selection et [Tab]) (affichage de son contenu) 
PUIS  Avec la souris : tirer un lien depuis le point de sortie du Node Group Input (entête jaune), jusqu’au 
point d’entrée color (avec carrée bleu) du node Emission  comme le montre le schéma ci-dessous. 
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Résultat : Deux effets sont obtenus d’une part dans le NodeGroup  apparaître une sortie nommée « Color », 
d’autre part dans le PanneauN  > Paragraphe = Interface > Tableau Inputs / Outputs apparaît une ligne : Color – 
Shader – figure ci-dessous 
  
 
 
 
 
 
 
 
 2- Objectif : Nommer ce premier réglage de la couronne de Fresnel : CouleurPourtour 
Moyen :  Panneau N : Modification Tableau I/O 
PUIS  PanneauN > Paragraphe = Interface > Tableau Inputs/Outputs > Nom = Color < Clic 
   Case = Name < Taper « CouleurPourtour » 
Résultat : Dans le NodeGroup BruitFresnel la sortie Color est renommée : CouleurPortour 
 3- Objectif : Ajouter un réglage d’épaisseur de la couronne  
Moyen : Liaison interne :  GroupInput-deuxième Sortie > dexième Entrée Value-Multiply 
PUIS Editer le NodeGroup (Selection et [Tab]) (affichage de son contenu) 
PUIS  Avec la souris : tirer un lien depuis le deuxième point de sortie du Node Group Input (entête jaune), 
jusqu’au deuxième point d’entrée value (le plus en bas) du node Multiply  comme le montre le schéma ci-
dessous. 
 
 
 
 
 
 
 
 
 
 
 
 
Résultat : Trois effets sont obtenus, d’abord dans le NodeGroup apparaît une sortie supplémentaire  « Value », 
dans le Node Multiply l’ancienne valeur affichée disparaît (elle sera récupéré à partir du NodeGroup), enfin dans 
le PanneauN  > Paragraphe = Interface > Tableau Inputs / Outputs apparaît une ligne supplémentaire : Value 
 4- Objectif : Renommer le réglage de l’épaisseur de la couronne : Epaisseur 
Moyen :  Modification Tableau I/O 
ENFIN PanneauN > Paragraphe = Interface > Tableau Inputs/Outputs > Nom = Value < Clic 
   Case = Name < Epaisseur 
Résultat : Dans le NodeGroup BruitFresnel la sortie Value est renommée : Epaisseurr 
Remarque : On peut vérifier le bon fonctionnement de l’ensemble. D’abord appuyer sur [Tab] et modifier les 
réglages sue le Node Group comme ci-dessous . 
 
 
 
 
 
 
Remarque : d’une part ce node est réutilisable sur d’autres Objets que l’UV sphère (voir les dans le menu Add 
l(entrée group) à l’intérieur de l’exécution de en cours de Blender, mais il est sauver en même temps que cette 
occurrence de travail dans le fichier .blend, et par voie de conséquence utilisable à partir d’une autre éxécution 
de Blender. 

Donne le résultat 
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17. Création d’une animation d’objets articulés entre eux - Niveau 1  
Exercice : Utilisation d’une armature pour animer un ensemble d’objets 

composé de trois parties.  

Liste des points nouveaux abordés : symbole 
Notion d’os, d’armature liés à un groupe d’objets , en vue d’une animation de cet ensemble dit « articulé » 
Notion de contraintes entre os-objet  

 
Objectif : Il s’agit de construire un objet vertical composé de trois parties cône-cube-sphère appelées seigments  
et de les animer dans une « petite danse ondulatoire » (dandinement de gauche à droite) 
 

17.1. PREMIÈRE MÉTHODE : ANIMATION DES SEIGMENTS DE PROCHE EN PROCHE 
• PREMÈRE PHASE -CRÉATION D’UN OBJET LIÉ À SON SQUELETTE ARTICULÉ (ARMATURE) 

D’ABORD  Mise en place des objets > Créer trois primitives brutes : un cube, un cône, une 
sphère qui seront les seigments. 
PUIS   Régler leur position comme le montre la figure (important !) 
PUIS  Assembler l’ensemble en un seul objet  
  Panneau3Dview > BarreMenus > Menu = Object > Entrée = Joint 
 

• DEUXIÈME PHASE - MISE EN PLACE DU « SQUELETTE » D’ANIMATION LIÉ À L’OBJET  
D’ABORD Positionner le curseur comme le montre la figure ci contre (centre base du cône) 
PUIS  Panneau3DView > BarreMenus > Menus = Add > Entrée = Armature 
   SousEntrée = Single Bone (os du squelette « armature »)  
PUIS  Rendre visible le Bone 
  PanneauDroit > BarreIcones > Icône = Object (bone sélectionné) 
  Paragraphe = Display > Case = X-Ray < Cocher 
PUIS  Redimensionner l’objet “Os” comme le montre la figure ci-contre (utilisation de scale) 
Remarque : un « os » est un objet qui possède une tête et une queue comme le montre la figure 
 ci-contre : il a donc un sens. 
PUIS  Création d’une chaine d’os associée aux objets 
  Sélectionner l’os 
 PUIS EditMode > PanneauN > Onglet = Tools > Paragraphe = Armature Tools  

> Case=Subdivide < Clic 
  PanneauEphemère  > Case = Number of cuts < 2 
Résultat : On obtient une chaine de trois os comme le montre la figure ci-contre. 
 

• TROISIÈME PHASE - TEST DE L’ANIMATION DES OS DE PROCHE EN PROCHE  
• APPELÉE (FK- FORWARD KINEMATIC): 

Explications : Les trois os de l’ensemble sont chainés on dit « parentés » entre eux,dans l’exemple  
ci-contre on a « Bone003 » est le fils de « Bone002 » qui est lui-même le fils de « Bone001 ». Cela implique en 
animation dit Mode Pose , que « toute rotation d’un ancêtre agit sur ses descendants » ainsi une rotation sur 
Bone002 entrainera Bone003, mais n’agira pas sur Bone1 
 Test d’animation : Sélectionner l’armature, passer en Pose Mode : 
  Panneau3DView > BarreMenus > Case = EditMode < PoseMode, 

Exécuter des rotations sur chaque os en annulant à chaque fois. On vérifie que les os pivotent bien en 
entraînant leurs enfants. 

Remarque : Ainsi la méthode d’animation du squelette va consiter à agir à animer chaque os les uns par rapport 
aux autres. En assimilant ces os à un bras : bone001(haut du bras), bone002(avant bras) et bone003 (la main), . 
l’animation est une cinématique qui part de haut du bras vers la main (on dit « vers l’avant » : Forward ) 
 

Queue 

Tête 

Bone 

Bone002 

Bone003 

Curseur 
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• QUATRIÈME PHASE – ACCROCHAGE DU MAILLAGE DES OBJETS AUX OS 
 1-  Réglage de la coincidence des jonctions de la liaison entre objets / aux connexions entre os  
 Suivre précisément les localisations des jonctions des os par rapport aux contacts géométrique des 
objets : Cône, Cube, Sphère.- comme le montre la figure ci-dessous !!!! 
 
 
 
 
 
 
 
 
 2- Liaison entre le maillage de l’objet et l’armature 
D’ABORD Mode Object > Sélectionner dans l’ordre : L’objet puis l’armature 
PUIS  Panneau3Dview > Barremenus > Menu = Object > Entrée = Parent < Clic 
  SousEntrée = WithAutomatic Weigths < Clic 
 Test de la liaison os-Maillage 
Sélectionner l’armature, passer en Pose Mode et éxécuter des rotations sur chaque os en annulant à chaque 
fois. On vérifie que les os pivotent le maillage supérieur se déplace ave les os de l’armature voir exemple ci-
dessous 
 
 
 
 
 
 
 

• CINQUIÈME PHASE :  CRÉATION D’UNE ANIMATION TYPE FK 
 D’ABORD Sélectionner l’armature 
 PUIS  Passer en PoseMode 
PUIS  Animation de l’armature os par os  en suivant l’ordre de gauche à droite du tableau suivant 
D’ABORD 
Position curseur animation 

PUIS 
Position des os de l’armature 
Mode Pose 

ENFIN 
Mémorisation Keyframe 

 
 
 
PanneauAnimation > 
BoutonCurseur < 1 

 
 
 
Selection de tous les os 
 

 

 
 
 
Insertion KeyFrame > Location-
Rotation 

 
 
 
PanneauAnimation > 
BoutonCurseur < 40 

 
 
Tournerer les os un à 
un  
Sélection de tous les 

os 
 

 
 
 
Insertion KeyFrame > Location-
Rotation 

 
 
 
PanneauAnimation > 
BoutonCurseur < 80 
 

 
 
Tourner les os un à 
un 
Selection de tous les 

os 

 
 
 
Insertion KeyFrame > Location-
Rotation 
 

 
 

 
 

 
 

CUBE 

CONE 

Jonction des deux os  

CUBE 

SPHERE 

Jonction des deux os  

Première rotation sur l’os « bone 001 » 

Deuxième rotation sur l’os « bone 002 » 
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PanneauAnimation > 
BoutonCurseur < 120 
 
 

Tourner les os un à un 
Selection de tous les os 

Insertion KeyFrame > Location-
Rotation 
 
 

 
 
PanneauAnimation > 
BoutonCurseur < 160 
 

 
 
 
Tourner les os un à un 
Selection de tous les os 

 

 
Insertion KeyFrame > Location-
Rotation 
 
 

 ENFIN  PanneauAnimation > BarreMenuIcone > Icône = Lecture < Clic 
 

17.2. DEUXIÈME MÉTHODE : ANIMATION DE L’ENSEMBLE DE L’ARMATURE PAR UN CONTRÔLEUR  

Principe                    : En reprenant l’image du bras pour la chaine d’os. Cette fois la méthode consiste à imposer 
à la main ((bone001) une position (role du « controleur ») , le reste du bras « se debrouille «  pour suivre. C’est 
la notion de « cinématique inverse » (IK Inverse Kinematic) 
Objectif : Astreindre la chaine d’os à suivre un objet : le « controleur » d’IK 
D’ABORD Créer un objet Torus au dessus de la chaine 
PUIS  Mode Pose > sélectionner l’os de pointage (Bone003) 
PUIS  PanneauProporties > BarreIcones > Icones = Contrainte d’Os > Bouton = AddBoneConstraint < clic 
PUIS    MenuContextuel > Colonne = Tracking > Entrée = Inverse Kinematics 
PUIS  Panneau IK > Case = Target < Choisir « Torus » 
Résultat : L’os se colore en jaune entouré de bleu, et s’aligne sur le Torus. 
ENFIN   Revenir en Mode objet > Déplacer le Torus 
Résultat : la chaine suit les déplacements du Torus. On peut ainsi refaire l’animation du type précédent en 
mémorisant à chaque position seulement la localisation du Torus, comme le montre le tableau ci-dessous. 
 
D’ABORD 
Position curseur animation 

PUIS 
Position du Torus 
 

ENFIN 
Mémorisation Keyframe 

 
 
PanneauAnimation > 
BoutonCurseur < 1 
 
 
 
 

 
 
Sélectionner le Torus 
 
 

 
 

 
 
Insertion KeyFrame > Location 
 

 
 
PanneauAnimation > 
BoutonCurseur < 40 
 
 
 

 
Déplacer le Torus 
vers le bas 
légèrement à droite 
Sélectionner le Torus 

 
 
 

 
 
Insertion KeyFrame > Location 
 
 
 
 

 
 
PanneauAnimation > 
BoutonCurseur < 80 
 
 
 

 
Déplacer le Torus  
vers le haut et recentrer 
Sélectionner le Torus 
 

 
 

 
 
Insertion KeyFrame > Location 
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PanneauAnimation > 
BoutonCurseur < 120 
 
 
 

 
 

Déplacer le Torus 
légèrement à 
gauche 
Sélectionner le 
Torus 

 
 
 

 
 
Insertion KeyFrame > Location 
 
 
 
 

Résultat : lancer l’animation pour voir le résultat. 
Remarque : Au cas où les Keyframes enregistrées ne conviennent pas (erreurs …. !), il suffit de procéder 
comme suit : 
D’ABORD Panneau3DView > PanneauN > Paragraphe = Transforme > Positionner la souris sur l’ensemble de 
cases > Locati : ( en vert) 
PUIS  CliquerDroit > MenuContexel > Entrée = ClearKeyFrames (éfface TOUTES les Keyframes) 
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18. Création d’une animation d’UN objet articulé Niveau 2  
Exercice : Utilisation de contrôleurs IK pour animer  

une armature de « chenille » 

Objectif : Imiter la manière de ramper d’une chenille en utilisant un système de « poignées » permettant de 
piloter les différentes parties du corps cylindrique d’une chenille schématisée. 
Remarque préliminaire : Dans blender tout Os (bone) créé même seul, est élément d’une Armature. Il est donc 
important de nommer clairement les armatures et leurs os d’appartenance pour se repérer. 
 

18.1. CRÉATION DE LA STRUCTURE CORPS (MESH)-SQUELETTE(ARMATURE) QUI SUPPORTERA L’ANIMATION 
• PREMIÈRE PHASE : LE MAILLAGE DU CORPS 

D’ABORD Positionner la vue en « Top » (permet de voir l’échelle de la grille) et « orthographique » 
PUIS  Créer un cylindre de diamètre  2UB et de longueur 16UB 
ENFIN Positionner le centre géométrique du cylindre à l’origine de l’univers 

• DEUXIÈME PHASE : CRÉATION DU SQUELETTE D’ARTICULATION : ARMATURE 
D’ABORD Créer un os simple :  
 Panneau3DView > BarreMenus > Menu = Add > Entrée = Armature > SEntrée = Single Bone 
Pour le « voir » en Mode Object 
 PanneauProporties > BarreIcones > Icône = Armature > Paragraphe = Display > Case = X-Ray < coche 
PUIS  Aligner l’os sur l’axe Y  et le changer d’échelle pour obtenir la position ci-dessous /cylindre 
 
 
 
 
 
PUIS  Mode Edit > sélectionner l’os 
PUIS  Création d’une chaine d’os à partir du précédent 
  PanneauT > Onglet = Tools > Paragraphe = Modeling > Case = Subdivide < Clic 
  PanneauEphémère > Case = Number of Cuts < 4 
Résultat : On obtient alors la “chaine” d’os appelée Armature comme le montre la figure ci-dessous  
 
 
 
 
 
Remarque : L’armature doit nous permettre de déplacer le cylindre-« chenille » lorsque l’on agit sur ses os en 
rotation. On peut vérifier ici que ce n’est pas encore le cas ! 
PUIS  ModeObject > Sélectionner l’Armature 
ENFIN PanneauN > Paragraphe = Item > Case < Taper : « Squelette » 

• TROISIÈME PHASE :  LIAISON ENTRE LE MAILLAGE ET L’ARMATURE « SQUELETTE » 
Remarque préliminaire : Pour déformer le maillage selon la position de l’armature, il faut nécessairement affiner 
au mieux la résolution (nombre de mailles) du cylindre, sinon le pliage de celui-ci se fera mal ! 
D’ABORD Sélectionner le cylindre 
PUIS  Passer en Edit Mode et ajouter a peu près 18 Edge loops ( avec [Ctrl] + R ) comme le montre la figure 
ci-dessous 
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ENFIN Objet Mode > Sélectionner dans l’ordre : le cylinder (maillage) puis l’amature  
 Panneau3DView > BarreMenu > Menu = Object > Entrée = Parent > SEntrée =With Automatic Weigth 
 
 
Résultat :  On sélectionne l’armature, on passe en Pose Mode, 
on sélectionne un os (changement couleur bleu) et si l’on fait une 
rotation sur un os non seulement l’os et ses enfants tournent, et le 
maillage suit comme le montre la figure ci-contre sur une rotation 
de l’os « Bon003 ». 
 

18.2. CRÉATION DE « POIGNÉES » D’ANIMATION D’AVANCE VERS L’AVANT 

Objectif : Il s’agit ici de créer des objets (Mesh) qui par des déplacements simples (translation…) vont permettre 
de déformer le corps de la chenille pour simuler son ondulation lors de son déplacement.(voir suite des états de 
la chenille dans ses déplacements ci-dessous) 
 
 
 
 
 
 
Moyens : Nous utiliserons des anneaux (taurus) comme poignées et  des « contraintes » comme des « ficelles 
invisibles attachées » aux os de l’armature pour obtenir les déplacements du maillage. 
Vocabulaire des contraintes : Une contrainte qui s’applique à un objet O1 est exercée par un objet O2. L’objet 
O1 est appelé « propriétaire » de la contrainte et l’objet O2 est souvent appelé « target »  ce qui est mal dit 
puisque souvent c’est lui qui agit sur le « propriétaire ». 
 

• PREMIÈRE PHASE : CONTRAINDRE LE CORPS ENTIER À S’ARQUER VERS LE HAUT  
Remarque préliminaire : Nous allons utiliser une contrainte de type IK produite par un os nouveau indépendant 
de l’armature déjà créée c’est lui qui servira  pour astreindre la déformation au corps. Les noms choisis pour les 
os de l’armature « squelette » sont ceux de la figure ci-dessous : 
 
 
 
 
 
 
 
D’ABORD Création d’un nouvel os nommé « TARGET » > au point (9,0,0) 
  Positionner le curseur en (9,0,0), ajouter un os simple et positionner le sur l’axe X 
  PanneauN > Item > Case < Taper « PILOTAGE » (nom de l’armature) 
  PanneauProporties > BarreIcones > Icône = Os > PremiereCase < « TARGET » 
Remarque sur la structure des objets de la scène : on dispose maintenant d’une Armature PILOTAGE qui 
contient l’os TARGET 
PUIS  PoseMode > Sélectionner « Bone2 » (couleur devient « bleue ») 
PUIS  PanneauProporties > BarreIcones > Icones = Bone Constraints < clic 
  Bouton = Add Bone Constraints > Colonne = Tracking > Entrée = Inverse Kinematics < clic 
PUIS  PanneauIK > Case = Target < Choisir Liste < PILOTE  (armature) 
ENFIN  PanneauIK > Case = Os  < Choisir Liste < TARGET (os) 
 
Remarque IMPORTANTE : si l’os « TARGET » est positionner TRES PRECISEMENT sur le même axe X que 
l’armature « SQUELETTE » le déplacement sur X de TARGET ne provoquera aucun déplacement de l’ensemble. 
 IL FAUT en Mode Object légèrement déplacer TARGET sur Y (Exemple au point (0,0.3,0)) puis revenir en Mode 
Pose et déplacer TARGET (de la droite vers la gauche) pour obtenir la figure page suivante. 
 

Changement  de partie 
mobile 

Avancée  
de la partie ARRIERE 

Avancée  
de la partie AVANT 
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On pourra s’étonner d’avoir choisi Bone02 et pas Bone01 pour la contrainte d’arc du corps. On réserve l’os 
Bone01 pour articuler la « tête » de la chenille et la maintenir horizontale ce qui n’est pas encore le cas. 
 

• DEUXIÈME PHASE : MAINTENIR LA TÊTE HORIZONTALE MALGRÉ LA COURBURE DU CORPS. (VOIR DESSIN CI-
DESSOUS) 

 
 
Remarque préliminaire : Nous allons créer un objet-point  (Empty), qui servira de « visée » pour l’os 
« Bone001 » de la « tête » de la chenille, par l’intermédiaire d’une nouvelle contrainte « Damped Track »  
D’ABORD  Mettre le curseur en (12,0,0)  
PUIS  Panneau3DView > Barrelenus > Menu = Add > Entrée = Empry > SEntrée = Plain Axe 
PUIS  PanneauN > Paragraphe = Item > Case < Taper « Empty-TETE » 
PUIS  En PoseMode > Sélectionner Bone001 
PUIS  Affichage du repère propre à Bone001 afin de viser correctement !!! 
Remarque : les repères propres des os ont toujours l’axe sur Y et tête-queue dans le sens positif des Y. 
  PanneauDroit > BarreIcones >Icône = Armature > Paragraphe = Display  > Case = Axes < Coche  
PUIS  PanneauProporties > BarreIcones > Icone = Bone Constraints < clic 
  Bouton = Add Bone Constraints > Colonne = Tracking > Entrée =  Damped Track  < clic 
PUIS  PanneauDamped Track > Case=Target < Choisir « Empty-TETE » 
Remarque : la contrainte Damped Track appliquée à Bone001 oblige Bone001 à s’orienter de telle manière à ce 
que son repère propre pointe l’axe spécifié par la case cochée de la rubrique « To : » Dans le cas particulier ci-
dessous on a fait correspondre l’axe Y du repère propre de Bone001 en cochant la case « To : » [Y] . Il faut que 
ces deux informations coïncident pour que lors du déplacement du squelette, Bone001 pointe toujours sur 
« Empty-TETE » (voir figure ci-dessous) 
 
 
 
 
 
 
 
 
 
 
 
Résultat : le déplacement de l’os « target » sur l’axe X dans la direction de la chenille, courbe toujours celle-ci 
mais la « tête » demeure sur l’axe X comme le montre la figure cidessous où l’on a « grossi » l’os « TARGET » 
pour visualiser sa position. On remarquera que Bone001et le maillage pointent bien sur Empty-TETE 
 
 
 
 
 
 
 
 
 

PanneauDroit > SPanneau = Damped Track Panneau3DView > Visualisation constrainte 

Repère propre de 
Bone001 

correspondance 

Case [Y] coché ! 

Axe Y du repère propre à Bone001 
pointe sur Empty-TETE ! 

Maintient de la tête horizontale 
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• TROISIÈME PHASE : CRÉATION D’UNE « POIGNÉE » D’ANIMATION POUR LE DÉPLACEMENT DE L’« AVANT » DE LA 
CHENILLE 

Objectif : Ajouter un objet O au dessus de la chenille, qui par son déplacement sur X devra provoquer le 
déplacement de TARGET et donc de la chenille 
D’ABORD Ajouter un « Torus » et le positionner au dessus de « TARGET » à 5 ub sur Y, Le nommer 
« ManetteAvant » 
PUIS  PoseMode > Sélectionner TARGET 
PUIS  PanneauProporties > BarreIcones > Icone = Bone Constraints < clic 
  Bouton = Add Bone Constraints > Colonne = Transform > Entrée = 
 Copy Location  < clic 
PUIS  PanneauCopy Location > Case=Target < Choisir « Torus» 
PUIS  PanneauCopy Location  > Garder SEULE le case X cochée puisque 
le déplacement se fait selon X comme le montre la figure ci-contre.  
Résultat : En Mode Object , Déplacer le « torus » sur l’axe des X et constater 
que la chenille suit le mouvement .  
 

• QUATRIÈME PHASE : RÉALISATION D’UNE ANIMATION DE LA PREMIÈRE ÉTAPE L’AVANCE DE LA CHENILLE 
Remarque préliminaire : pour une animation il suffit simplement mémoriser dans une keyframe la position du 
Torus pour déplacer la chenille en avant. Mais ceci se limite simplement pour l’instant à une partie du 
mouvement. On peut simuler comme le montre le tableau ci-dessous, l’avance de la partie AVANT (flèche) qui 
bouge vers l’avant pendant que la partie ARRIERE (point rond) demeure fixe.  
Schéma de la mobilité Avant /Fixité Arrière 
ETAT 1 ETAT 2 ETAT 3 ETAT 4 
 
 
  
 
 
 
 
 

 
 
 

 
 
 

 
 
 

 Avancer Torus 
« ManetteAvant » 

Avancer Torus 
« ManetteAvant » 

Avancer Torus 
« ManetteAvant » 

 

Mais il manque la suite du déplacement :  à savoir une inversion de mobilité de la partie avant/ partie arrière le 
maintient fixe de la partie avant pendant que l’arrière tente de la rejoindre en avançant comme le montre le 
tableau ci-dessous 
 
Fixité Avant / Mobilité Arrière 
ETAT 5 ETAT 6 ETAT 7 ETAT 8 
 
 
 
 
 
 
 
 

 
 
 
 

 
 

 
 
 

 

18.3. LE DÉPLACEMENT DE L’« ARRIÈRE » DE LA CHENILLE 

Objectif : Ajouter un objet O, poignée pour déplacer la partie arrière  
D’ABORD Ajouter un « Torus », le positionner au dessus de « bone» à 5 ub sur Y et le nommer  « Manette 
Arrière» 
PUIS  En PoseMode > Sélectionner le Torus 
PUIS  PanneauDroit > BarreIcones > Icone = Bone Constraints < clic 

Avant  fixe Arrière mobile 

Arrière fixe Avant mobile 
Sens de l’avancée de l’avant 

Sens de l’avancée de l’arrière 

Torus 
« ManetteAvant » 

Sens déplacement 
Torus 
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  Bouton = Add Bone Constraints > Colonne = Transform > Entrée =  Copy Location  < clic 
PUIS  PanneauCopy Location > Case=Target < Choisir « Manette Arrière» 
PUIS  PanneauCopy Location  > Garder SEULE le case X cochée 
Remarque : vérifier que le déplacement de ce torus sur X déplace l’arrière de la chenille. 
 

18.4. CORRECTION SUR LES LIENS ENTRE LES POIGNÉES ET LA CIBLE DE LA TÊTE : EMPTY-TETE 

Remarque : Le montage précédent conduit à une déformation inverse de la tête si « ManetteAvant »dépasse la 
cible « Empty-TETE » (voir figure ci-dessous) 
 
 
 
 
 
 
 
 
 
 
 
 
 
Moyen : Pour éviter cela, il suffit de lier le déplacement de l’  « Empty-TETE » au torus « ManetteAvant » par une 
contrainte type « Copy Location » mais cette fois entre deux maillages. 
D’ABORD En Mode Object > Sélectionner : Empty-TETE  
PUIS  PanneauProporties > BarreIcones > Icones = Containte Objet > Bouton = AddObjectContrainte <clic 
  Colonne = Transform > Entrée =  Copy Location  < clic 
PUIS  PanneauCopy Location > Case=Target < Choisir « ManetteAvant» 
ENFIN PanneauCopy Location  > Garder SEULE la case X cochée puisque le déplacement se fait selon X 
comme le montre la figure ci-dessus et cocher la case Offset (Déplacement relatif de Empty/torus ) 
Résultat : En Mode Object , Déplacer le « ManetteAvant » sur l’axe des X et constater que la chenille suit le 
mouvement ,ainsi que la cible « Empty-TETE ». 
 

18.5. ANIMATION DU TRAJET DE LA CHENILLE 

Remarque : le texte « CHEMIN DE LA CHENILLE » sert de « repère » pour visualiser le déplacement de la 
chenille / sol dans le Tableau d’animation ci-dessous 
D’ABORD 
Position curseur animation 

PUIS 
Position des Torus 
 

ENFIN 
Mémorisation Keyframe 

 
 
PanneauAnimation > 
BoutonCurseur < 1 
 
 
 

Sélectionner les Torus 
 
 
 
 
 

 
 
Insertion KeyFrame > Location 
 

 
 
PanneauAnimation > 
BoutonCurseur < 40 
 
 
 

Déplacer le ManetteArriere vers 
l’avant 
Sélectionner les Torus 
 
 
 

 
 
Insertion KeyFrame > Location 
 
 
 
 

Empty-TETE 

Torus : ManetteAvant Torus : ManetteArrière 

INVERSION de la 
position de la tête 

Dépassement ManetteArrrière/ Empty-TETE 
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PanneauAnimation > 
BoutonCurseur < 80 
 
 
 
 

Déplacer le ManetteAvant vers 
l’avant 
Sélectionner les Torus 
 
 
 
 
 

 
 
Insertion KeyFrame > Location 
 
 
 
 
 

 
 
PanneauAnimation > 
BoutonCurseur < 120 
 
 
 

Déplacer le ManetteArriere vers 
l’avant 
Sélectionner les Torus 
 
 
 
 
 

 
 
Insertion KeyFrame > Location 
 
 
 
 

 
 
PanneauAnimation > 
BoutonCurseur < 160 
 
 
 

Déplacer le ManetteAvant vers 
l’avant 
Sélectionner les Torus 
 
 
 
 
 

 
 
Insertion KeyFrame > Location 
 
 

 
Résultat : Lancer l’animation à partir de PanneauAnimation > Bouton = Lecture < Clic 
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19. Utilisation d’un système métrique dans Blender 

19.1.  LECTURE DES MESURES DU CUBE PAR DÉFAUT DE BLENDER. 

Remarque : L’unité de base est celle de la grille du plan XY , on la nomme: Unité Blender (UB) 
D’ABORD Sélectionner le Cube par défaut de blender ou en créer un. 
PUIS  Panneau3DView > Barremenus > Menu =View > Entrée = Properties (ou touche « N ») 
Résultat : à droite, dans la scène du Panneau3DView s’affiche le PanneauN 
PUIS Vérifier dans PanneauN > Paragraphe = Transform 
  Case Location > ( X=0 , Y=0 , Z=0 ) (position du centre géométrique à l’origine de l’univers) 
  Case Rotation > ( X=0° , Y=0° , Z=0° )  (aucune rotation par rapport aux axes X Y Z) 
  Case Scale > ( X=1 , Y= 1 , Z=1)  (échelle 1 sur les trois dimensions) 
  Case Dimensions ( X=2 , Y=2 , Z=2 )  (Dimension du Cube coté = 2 UB ) 

19.2. CHOISIR LA MÉTRIQUE « MÈTRE » 

D’ABORD PanneauProporties > BarreIcones > Icones = Scène < Clic  
PUIS  Paragraphe = Units > Bouton = Unit Presets < clic 
   MenuContextuel > Menu = Meters (par exemple !) 
Résultat : Plusieurs effets.  
 Panneau3DView >  Scène en haut et à gauche sous « User Persp » s’affiche « Meters ». La Grille de plan 
XY est à l’échelle 1m.  
 PanneauN >Paragraphe = Transform, les unités de longueur sont exprimées en m (mètre) et les angles en 
° (degré). 
ENFIN  Paragraphe = Units > Case = Scale est à 1.000000 par défaut on peut l’ajuster pour obtenir des 
sous divisions du mètre : 0.01 pour cm … 

19.3. AFFICHAGE DES MESURES ET APPLICATION DES MODIFICATIONS SUR LES OBJETS 

D’ABORD  Dupliquer  le cube de référence deux fois, de chaque coté sur l’axe OX 
PUIS   En vue de face de gauche à droite, nommer les cubes :  C1, C0 (cube original) , C2 
PUIS   Sur C1 : faire un scale de 0.5, sur C2 un scale de 2 
PUIS  Pour CHAQUE CUBE  
   Sélectionner le Cube 
   Passer en EDIT MODE 
   PanneauN > Paragraphe = Mesh Dsiplay > SParagr. = Edge > Case = length < coche 
Résultat : Les mesures de longueur s’affichent sur l’objet dans l’unité choisie.  
Défaut : les trois cubes affichent les mêmes dimensions !!!! En regardant dans le PanneauN on s’aperçoit que : 
 Pour C0 > Scale est à (X=1 , Y=1 , Z=1) donc échelle normale 1, mais 
 Pour C1 > Scale est à (X=0.5 , Y=0.5 , Z=0.5) donc échelle de 0.5  (Mesure réelle = affichage x 0.5) 
 Pour C2 > Scale est à (X=2 , Y=2 , Z=2) donc échelle de 2 (Mesure réelle = affichage x 2) 
Correction : Pour que l’affichage en Mode Edit corresponde à la mesure réelle, il faut « appliquer » les 
transformations effectuées sur C1 et C2. 
ENFIN  Pour CHAQUE CUBE 
   Sélectionner le Cube 
   Panneau3DView > Barremenus > Menu = Object > Entrée = Apply > Entrée = Scale 
Résultat : Tous les cubes sont maintenant à la même échelle 1. On peut vérifier leur dimension en Edit Mode  
Comme le montre la figure ci-dessous. 
Conseil : 
Pour éviter cette difficulté lors de la 
transformation d’objets en ModeObject, 
donc d’être obliger d’appliquer les 
transformations. Il est conseillé de 
travailler directement en Edit Mode, les 
transformations se font alors 
directement de manière éffective. 
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Panneau Graphe Editor Panneau Video Squence Editor 
Mode = Image Preview 

 

Panneau Video Squence Editor 
Mode = Sequencer 

 

Panneau TimeLine 
 

Panneau Info 
 

20. Montage Vidéo dans Blender 2.79 

 
 

20.1. MISE EN PLACE DE L’ESPACE DE TRAVAIL 

Remarque préliminaire : Éléments nécessaires - Deux fichiers Vidéos avec des défauts (oscillation de caméra 
…)(ici deux mp.4 : ERDEVEN-Dunes.mp4 et ERDEVEN-Vagues.mp4) 
 
Panneau3DView > BarreMenus > Icones Types < Video Editing 
Résultat : Disposition de espace de travail (work space)- (voir figure ci-dessous) 
Panneau Graphe Editor   
notation PanneauGE 
Panneau VideoSquence Editor 
notation PanneauVSE 
Remarque 1 : Dans PanneauVSE > 
BarreMenus > Cases = Mode 
 Permet d’avoir : 

 Mode = Sequencer 

 Mode =ImagePreview 

 Mode = Mixte 
On notera dans la suite :  
PanneauVSE-Sequencer  ou PanneauVSE-ImagePreview 
Remarque 2 : Les effets de déplacements (translation, roatation,  zoom) sont obtenus dans tous les panneaux 
par les mêmes manipulations de la souris décrites dans le paragraphe 1-1 de cette documentation. 
 

20.2. RECHERCHE DES INFORMATIONS SUR LES VIDÉOS DES FICHIERS UTILISÉS 

Remarque préliminaire : Il est utile pour la production finale de connaître les paramètres d’enregistrement de la 
vidéo en registrée en fichier mp4. Pour cela on peut utiliser le programme VLC (gratuit) 
D’ABORD Ouvrir le fichier (ici ERDEVEN-Dunes) à partir de VLC 
PUIS  Arrêter l’animation 
PUIS  Taper [Ctrl] + [I]  
Résultat : une fenêtre apparaît : Fenêtre Information Media En Cours (noté ici FenetreInf) 
PUIS   FenetreInf > Onglet = Codec < Clic 
Résultat : le contenu de FenetreInf affiche en particulier les informations suivantse sur le vidéo : : 

Pour la Vidéo : 
Type de Codec (COdeur DECodeur) : MPEG 4 
 
Résolution de images : Type 1080p (* voir les divers types à la fin) 
Débit d’images : 28 images/seconde 
 
Pour l’Audio 
Type de Codec : MP4 
 
 
 
(*) type de standard utilisé 

Normes - débit d’image par seconde des Film généralement : 24 F/S (frame/second – français : image/seconde) 
Résolution d’images en pixels les plus courantes : (noté : Nombre de pixels par ligne x Nombre de lignes) 
 720p  désigne  1280 x 720 pixels  appelé HD (Haute Definition) 
 1080p désigne  1920 x 1080 pixels appelé Full HD 

1440 désigne 2560 x 1440 pixels 
2160 désigne 3840 x 2160 pixels  appelé 4K ou Très Haute Définition 
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20.3. INSERTION DES VIDÉOS « BRUTES » DANS L’ESPACE DE TRAVAIL 
• PREMIÈRE MÉTHODE À PARTIR DE BLENDER POUR LE PREMIER FICHIER : ERDEVEN-DUNES.MP4 

D’ABORD PanneauVSE-S > Barremenus > Menu = Add > Entrée = Movie < clic 
Résultat : Nouveau PanneauFileBrowser s’affiche 
PUIS PanneauFileBrowse > Sélectionner à l’endroit le fichier : Erdeven-Dunes.mp4 < clic 
Résultat : Dans PanneauVSE-IP > affichage de la première image du tournage, dans PanneauVSE-S apparaît 
deux bandes (strip) avec nom de fichier : Bande (bleu claire) – audio et en dessous Bande (bleu foncé) – vidéo. 

• DEUXIÈME MÉTHODE : UTILISATION DE L’EXPLORER DU SYSTÈME 
D’ABORD Ouvrir l’explorer du système d’exploitation (windows, linus ou mac0s)  
PUIS  Répartir les deux fenêtres Explorer/Blender l’une à coté de l’autre. 
PUIS  FenetreExplorer > Sélectionner le fichier .mp4 voulu : ici Erdeven-Vagues 
PUIS  Souris Glisser-Déplacer l’icône de Explorer dans Blender > PanneauVSE-Sequenser 
Résultat : même affichage qu’avec l’autre méthode, les deux bandes avec le nom de fichiers se positionnent au 
dessus  (voir figure) 
  
 
 
 
 
 
 

20.4. VISUALISATION DES CONTENUS  

Remarque préliminaire : par défaut, Blender lit la plus « haute » des bandes dans la PanneauVSE-Sequenser 
(ici ERDEVEN-Vagues) 
D’ABORD PanneauTimeLine > BarreMenus > Case = Start < 1 
Résultat : la ligne verticale orange se cale à 1 dans les trois panneaux : c’est le « curseur » de visualisation des 
images (frames) 
PUIS PanneauTimeLine > BarreMenus >Utiliser les boutons le lecture type « magneto » 
 

20.5. VISUALISER LA BANDE SITUÉE EN DESSOUS : ICI ERDEVEN-DUNES 

D’ABORD PanneauVSE-Sequencer > Bandes  = « ERDEVEN-Vagues » (audio et vidéo) <clic 
PUIS PanneauVSE-Sequencer > BarreMenus > Menu = strip > Entrée =Mute Srip ou Taper [H] 
Résultat : les deux bandes sont entourées d’un cadre blanc pointillé ( pour revenir à la normal : [Alt]+[H] ), et 
surtout dans PanneauVSE > ImagePreview c’est le contenu de la deuxième bande (ici ERDEVEN-Dunes) qui 
s’affiche ! 
 

20.6. CONSIDÉRATION SUR LES BANDES AUDIOS : 

Remarque : Blender n’est pas un banc de mixage audio, on peut simplement découper les parties interessantes 
exactement comme on va le faire pour les bandes vidéos. Cela peut être utiles pour supprimer des parties 
génantes ou de silence. Pour mieux voir le contenu des bandes audio (affichage des amplitudes de son) 
D’ABORD PanneauVSE-Sequencer > Bande audio < clic 
PUIS PanneauVSE-Sequencer > PanneauN > Onglet = Strip > Paragraphe = Sound  

> Case = DrawWaveform < clic 
Résultat : dans la bande « audio » le titre est remplacé par la courbes de variations des intensités de son. 
 

20.7. SUPPRIMER DES BANDES  

D’ABORD PanneauVSE-Sequencer > Bande < clic 
PUIS  PanneauVSE-Sequencer > BarreMenus > Menu = Strip > Entrée = Erase Strip  ou taper [X]  
Remarque : On pourra ici supprimer les bandes sons des deux fichiers 
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Résultat : on obtient ainsi le nouvel affichage ci-dessous dans PanneauVSE-Sequencer : 
 
 
 
 
 
 
 
 
 

20.8. LE MONTAGE PROPREMENT DIT (ORGANISATION DES SÉQUENCES) 
• PREMIÈRE PHASE : PLANIFICATION DU TRAVAIL – PHASE ESSENTIELLE DU TRAVAIL 

Objectif : on désire que le film commence par un affichage des dunes (BANDE 1) puis qu’apparaissent les 
vagues de BANDE2, mais dans BANDE 1 et BANDE 2, il existe des « défauts » (oscillation de caméras ….) que 
nous devons faire disparaître. Nous allons procéder comme suit ( ceci n’est que le début du plan qui consiste au 
« découpage brut » des films, la version complète sera donnée à la fin !) 
D’ABORD Pour la BANDE1 : Repérer les défauts : frame de début, frame de fin dans BANDE1 
PUIS  Retirer la séquence où se situe le défaut de la BANDE1 (dunes) 
PUIS  Faire la même chose pour la BANDE2 (vagues) 
PUIS   Placer BANDE1 au dessus de BANDE2 
PUIS  Ajuster pour avoir la cohérence voulue 
Remarque : Toutefois il y a un réglage à faire pour visionner la totalité de chaque bande, comme le montre la 
figure ci-dessous la longueur en frames de la partie visionnée (déplacement du curseur) va de 1 à 250 (Voir 
PanneauTimeLine > BarreMenus > Case = Start  et Case = End, alors que les bandes des fichiers dépassent 
cette zone 
  
 
 
 
 
 
 
 
 
 
 

• DEUXIÈME PHASE : TRAVAIL SUR LA BANDE1- COUPURE EN FIN DE BANDE 
•  

 1- Réglage de la zone visualisable 
D’ABORD PanneauVSE-Sequencer > Positionner le curseur « à la main » (clic maintenu + déplacement) à la fin 

de la BANDE2 (la plus longue !) 
PUIS  PanneauTimeLine > Copier le numéro de la frame en cours dans la Case = End 
Résultat : la Zone visualisable se calle sur la BANDE2 
 2- Repérage du défaut sur la BANDE1 (dunes) 
D’ABORD  PanneauVSE-Sequencer > Masquer BANDE2 (Rappel : Sélection et taper 
PUIS   PanneauTimeLine > Mettre le curseur au début et Lancer la lecture (Boutons magnétoscope) 
PUIS  Noter la frame où commence le défaut (ici oscillation de la caméra) frame = 355, et le défaut continue 
jusqu’à la fin de la BANDE1 
Remarque : on peut ajuster avec précision le déplacement du curseur frame par frame en utilisant les pointeaux 
latéraux de  la Case = Position du curseur. 
 3- Suppression de la partie correspondante au défaut 
Remarque : Le cas qui est traité ici correspond à une partie à retirer en fin de bande. La technique consiste 
simplement à « avancer  la fin de bande », il n’est pas nécessaire de couper. 
D’ABORD PanneauTimeLine > BarreMenus > Case = PositionCurseur < 355 ( pour se repérer) 

Appelée BANDE 1 dans la suite 

Appelée BANDE 2 dans la suite 

Zone visualisable 

Position du curseur = numéro de frame en cours de lecture 
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BANDE 1 BANDE 2-1 BANDE 2-2 

Zone visualisable 

PUIS  PanneauVSE-Sequencer > BANDE 1 >Sélectionner le pointeau de fin de la BANDE1. 
 
 
 
 
 
 
 
Résultat : l’entourage et le pointeau passe en couleur blanche, un numéro blanc, s’affiche au dessous du 
pointeau c’est le numéro de la frame de fin (ici 398) 
PUIS  Taper [G] (grab = déplacer) au clavier 
PUIS PanneauVSE-Sequencer > Déplacer lentement la souris vers la gauche jusqu’à ce que le numéro = 355 
Résultat : On a avancé la fin de la BANDE 1 de la frame 398 à la frame 355, ce qui pour effet de supprimer 
l’oscillation finale de la caméra. 
Remarque : l’avantage de cette méthode est qu’elle n’est pas destructive : on peut déplacer le pointeau et 
récupérer des frames si nécessaire ! 
 

• TROISIÈME PHASE : TRAVAIL SUR LA BANDE 2 – COUPURE À L’INTÉRIEUR D’UNE BANDE. 
Remarque : En procédant comme précédemment sur la BANDE2 on repère une oscillation de la caméra de la 
frame = 100 à la frame = 226. Une technique consiste cette à couper le film à la frame 100 en deux parties 
BANDE2-1 et BANDE2-2, puis de reculer le début de BANDE2-2 en frame 226., ce qui aura pour conséquence 
de faire disparaître la partie défaillante. Il suffira après de rapprocher BANDE2-1 et BANDE2-2 (voir schéma ci 
dessous). 
 
 
 
 
 
 
 
 
 
 
D’ABORD PanneauTimeLine > Placer le curseur > Frame = 100 (localisation de la coupure) 
PUIS  PanneauVSE-Sequencer > BarreMenus > Menu = Strip > Entrée = Cut (soft) at frame < clic 
Résultat : BANDE2 se scinde.en BANDE2-1 et BANDE 2-2 
PUIS  Procéder comme l’indique le schéma ci-dessus (déplacement de pointeau, et de BANDE 2-2) 
Remarque’ : Encore une fois l’avantage de cette technique est qu’elle n’est pas destructive de la partie non 
affichée ! 
 

• QUATRIÈME PHASE : MISE EN PLACE DES POSITIONS RELATIVES DES BANDE 1 ET 2 CORRIGÉES ET CRÉATION 
D’UNE TRANSITION 

Remarque préliminaire : L’état des bandes du PanneauVSE-Sequencer est celui de la figure ci-dessous.Or 
nous voulons que la partie BANDE 1 (dunes) débute le film, puis que la partie BANDE 2 (vagues) le termine. 
 
 
 
 
 
Il suffit de déplacer l’ensemble des deux morceaux BANDE2-1 et BANDE2-2 à la suite de BANDE1, mais le 
problème est que la zone de visulisation est plus courte que le collage des deux bandes comme le montre la 
figure ci-dessous. 
 
 
 

Curseur indiquant le début du défaut Pointeau de fin de vidéo 

BANDE 2 

BANDE 2-1 BANDE 2-2 

BANDE 2-1 BANDE 2-2 

BANDE 2-1 BANDE 2-2 

Frame = 0 
 

100 
 

226 
 

Coupure 

Déplacement pointeau 

Déplacement BANDE2-2 
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• CINQUIÈME PHASE : CORRECTION DE LA LONGUEUR DE LA ZONE DE VISUALISATION 

D’ABORD  PanneauVSE-Sequencer> Avancer le curseur «à la main » jusqu’à la fin de la BANDE 2 
PUIS  PanneauTimeLine > Copier contenu Case=Position (ici 1227) dans la Case = End : 
Résultat : PanneauVSE-Sequencer la zone de visualisation se calle sur la totalité. 
Remarque : Lors de l’animation on peut vérifier que tout est placé dans l’ordre voulu, mais il reste que les 
passages « d’ interbande » sont « violentes ». Nous allons adoucir par des transitions (fondu enchainé …) pour 
améliorer la vision. 
 

• SIXIÈME PHASE : CRÉATION D’UNE TRANSITION ENTRE BANDE 1 ET BANDE 2-1 
Remarque préliminaire : Dans Blender pour créer une transition, il faut que les deux bandes se chevauchent 
pendant un certain nombre de frames. La durée en frames de ce chevauchement sera la durée de la transition. 
D’ABORD Décaler la BANDE2-1 d’une ligne vers les haut (sélection, taper [G]+[Y] et déplacer la souris) 
PUIS  Déplacer la BANDES2-1 de 20 frames vers la droite ((sélection, taper [G]+[X] et déplacer la souris) 
voir schéma ci-dessous (utiliser les numéros de frame qui apparaissent au bout des bandes pour caler !). 
 
 
 
 
 
 
 
 
 
 
 
 
PUIS PanneauVSE-Sequencer > Sélectionner simultanément dans l’ordre BAND1 puis BANDE 2-1 
PUIS PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée = Wipe 
Résultat : dans PanneauVSE-Sequencer au dessous de l’intersection des deux bandes s’affiche une petite 
bande rouge de longueur correspondant au chevauchement : c’est la représentation de la transition (voir figure 
ci-dessous). On peut visualiser l’effet avec l’animation par le PanneauTimeLine. 
 
 
 
 
 
PUIS faire le même travail pour la jonction BANDE2-1 BANDE-2-2 : voir schéma ci-dessous 
Remarque : Attention ! Cette fois avant la transition, sélectionner dans l’ordre BANDE2-1 puis BANDE2-2. 
 
 
 
 
 
 
 
(Affinage de la transition : quelques paramètres) 
Remarque : Chaque transition possède des réglages qui changent son apparence. Ici la transition « Wipe » 
(balayage) est dans sa version brute : une ligne de séparation transversale entre l’image sortante et l’image 
arrivante (Image de gauche ci-dessous). On peut changer dans ce type de transition des éléments en 
sélectionnant la transition puis en tapant « N » pour obtenir sur la droite du PanneauVSE-Sequencer, le 
PanneauN  ainsi : 
 
PanneauVSE-Sequencer > PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = TransitionType 
 

BANDE 2-1 BANDE 2-2 BANDE 1 
 

BANDE 2-1 

BANDE 2-2 BANDE 1 
 

BANDE 1 
 

BANDE 2-1 

BANDE 2-2 

Frame = 330 
 

Frame = 350 
 

Déplacement verticale  
 

Déplacement latéral = 20 frames 
 

Frame = 575 
 

ETAT INITIAL  
 

Frame = 555 
 

BANDE 1 
 

BANDE 2-1 

 Transition 1 

BANDE 1 
 

BANDE 2-1 

BANDE 2-2 

Frame = 545 
 

Déplacement latéral = 30 frames ( 20 de chevauchement) 
 Frame = 575 

 

  
Transition 2 
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On peut choisir les options suivantes (Bande 2-1 : vagues, BANDE 1 : dunes) 
 
 
 
 
 
 
On peut aussi jouer sur l’estompage de la ligne de séparation : 
PanneauVSE-Sequencer > PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case =Blur with < à choisir 
 
Remarque importante : Les déplacements précédents on « raccourcit » la totalité de la vidéo , il est nécessaire 
de recalibrer la zone visible (ici la frame de fin qui était en 1227 doit être ramenée en 1194 pour coïncider avec la 
fin de la BANDE2-2- voir méthode paragraphe- Correction de la longueur de la zone de visualisation ci-dessus) 
 

20.9. MISE EN FORME DU DÉBUT ET DE LA FIN DE LA VIDÉO 

Remarque : Nous choisirons pour notre petit film de commencer par un titre sur un fond uni qui se décolore pour 
montrer le première scène. Pour cela on procédera d’abord à la mise en place d’un fond uni qui se décolore sur 
le première scène (en anglais Fade In) , puis nous ferons la même chose pour la fin (Fade Out). Les textes 
seront traités dans le paragraphe suivant 
 

• PREMIÈRE PHASE : CRÉATION DU « FADE IN » 
D’ABORD PanneauTimeLine > Case = PositionCurseur < 1 
PUIS  PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée = Color 
Résultat : une petite bande noire appelée BandeCOLOR dans la suite, s’affiche à partir de frame 1 au dessus de 
la BANDE1 
Remarque : cette BandeCOLOR étant sélectionnée, le PanneauN > Onglet = strip donne accès aux paramètres 
de cette bande : Paragraphe = EffectStrip > Case = color (peut être changée), Paragraphe = Edit Strip donne 
accès en particulier Case = Length  à 25 par défaut, choisir 40 pour mieux voir les éffets !! 
PUIS PanneauVSE-Sequencer >Sélectionner dans l’ordre BandeCOLOR puis BANDE1  
PUIS PanneauVSE-Sequencer >BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée = GammaCross 
Remarque : l’ordre de sélection est très important puisque l’on veut « partir » du fond COLOR pour 
progressivement voir apparaître la première scène de BANDE1. 
 

• DEUXIÈME PHASE : CRÉATION DU « FADE OUT » 
D’ABORD PanneauTimeLine > Case = PositionCurseur < fin – 40 frames (réserve de fin pour le fade ou) 
PUIS  PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée = Color 
PUIS  PanneauN > Onglet = strip > Paragraphe = Edit Strip > Case = Length < 40 (pour mieux voir !) 
PUIS PanneauVSE-Sequencer >Sélectionner CETTE FOIS dans l’ordre BANDE1 puis BandeCOLOR 
PUIS PanneauVSE-Sequencer >BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée = GammaCross 
Remarque : l’ordre de sélection est très important puisque l’on veut « partir » de la dernière scène de BA pour 
progressivement voir apparaître la couleur unie de BandeCOLOR. 
 

20.10. AJOUTER UN TEXTE TITRE EN INTRODUCTION – EDITEUR INTERNE DU PANNEAUVSE 

 
• PREMIÈRE PHASE : TEXTE FIXE ET RÉGLAGES TAILLE POSITION COULEUR 

DABORD Positionner le curseur au début Frame = 1 
PUIS  PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée = Effect Strip > SEntrée =Text 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Edit Strip > Case = Length < 60 (permet affichage pendant 
le Fase In et un peu en sortie) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = Text : < Saisir le texte ici : « Balade 
en ERDEVEN  souvenir de Bretagne 2018» 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = Size < à choisir ici 157 
Remarque : Le texte est plus long que l’écran, il suffit de l’ajuster : 

Single Clock Double Iris 
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PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = Wrap Width < 0.70 (par exemple) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = Color = RGB (1,1,0) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case =Shadow < cocher (ombrage du texte) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case = Location < à régler 
 

• DEUXIÈME PHASE : UN EXEMPLE D’ANIMATION DU TEXTE 
Objectif : faire monter le texte jusqu'à disparition 
D’ABORD PanneauTimeLine > Case = PositionCurseur = début (Frame = 1) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case Location : Y < 0 
Résultat : le texte est calé en bas de l’écran 
PUIS  Positionner le souris > Case Location : Y  
PUIS  Clicdroit > MenuContextuel > Menu = Insert SingleKeyframe 
PUIS  PanneauTimeLine > Case = PositionCurseur = fin texte (Frame = 40) 
PUIS  PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Case Location : Y < 1 
Résultat : le texte est disparaît en haut de l’écran 
PUIS  Positionner le souris > Case Location : Y  
PUIS  Clicdroit > MenuContextuel > Menu = Insert SingleKeyframe 
Résultat : Lancer l’animation depuis le début : le texte monte pour disparaître en début de film ! 
 

20.11. COMBINER UNE SCÈNE 3D AVEC LA VIDÉO 

Objectif : On cherche ici non seulement à intégrer dans la vidéo un objet 3D : Suzanne dans la vidéo, mais aussi 
à animer cet objet au cours de la vidéo 
 

• PREMIÈRE PHASE : MODIFICATION DE L’ESPACE 
DE TRAVAIL) 

 
D’ABORD Remplacer le Panneau en haut et à 
gauche (PanneauGE) par Panneau3DView (figure ci-
contre) 
PUIS  Remplacer le Panneau en haut et à droit 
(PanneauVSE - IE) par PanneauProporties 
 

• DEUXIÈME PHASE : CRÉATION DE L’OBJET 3D : SUZANNE ) 
PUIS Remplacer le cube par Suzanne 
PUIS Panneau3DView > PanneauT > Onglet = Tools > Paragraphe = Shading >Case = Smooth < clic 
PUIS Panneau3DView > Faire tourner Suzanne de -90° sur X ( elle doit regarder en l’air !) 
PUIS Sélectionner le Caméra  
PUIS Annuler tous les déplacements de la caméra : [Alt]+R (rotations annulées), [Alt]+G (translations 
annulées) 
PUIS Sélectionner la Lamp 
PUIS PanneauProporties > BarreIcones > Icône = Lamp > Paragraphe = Lamp > Case = Sun < Clic 
PUIS > Case = Strength < 2  
PUIS Panneau3DView  > Mettre en Rendered 
Remarque importante : Comme la scène 3D va être afficher « sur » la vidéo, il faut que son fond soit 
transparent, sinon on ne peut voir la vidéo. 
PUIS PanneauProporties > BarreIcones > Icône =Render > Paragraphe = Film > Case = Transparent < coche 
 

• TROISIÈME PHASE : APPARENCE DE SUZANNE : MATERIAL MÉTAL OR 
D’ABORD Panneau3DView > Sélectionner Suzanne (Mode solide est conseillé pour vérifier) 
PUIS  Vérifier le choix de « Blender Cycles » comme moteur de rendu 
PUIS  PanneauProporties > BarreIcones > Icones = Material > Bouton = New 
PUIS  PanneauMaterial > Paragraphe = Surface > Case = DiffuseBSDF < Clic 
   Menu Contextuel < Entrée = Glossy 
PUIS  PanneauMaterial > Paragraphe = Surface > Case =Color < Jaune léger ( pour métal or !) 
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• QUATRIÈME PHASE : POSITION DE LA CAMERA  

D’ABORD Déplacer la caméra en vision verticale au dessus de Suzanne (environ 5u) 
PUIS  Panneau3DView > BarreMenus > Menu = View > Entrée = Camera 
 

• CINQUIÈME PHASE : MODIFICATION DE L’ESPACE DE TRAVAIL 
D’ABORD Remettre l’espace de travail sous la forme  ci-contre : 
PUIS PanneauTimeLine > mettre le curseur au début 
PUIS PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée =Scène > SEntrée = Scène 
PUIS PanneauN > Onglet = Strip > Case = Blend < Alpha Over 
Résultat : Une Bande Verte SCENE s’affiche au dessus de l’ensemble sur toute la longueur.(Figure ci-contre) 
Remarque 1: Comme l’objet occupe la 
partie centrale de l’écran (Rendu de la 
camera), il faut réduire sa taille et le 
déplacer.  
Remarque 2 :Le choix de Cycles comme 
moteur de rendu conduit à la non 
visualisation des matérial dans le 
PanneauVSE > ImageEditor. 
Par contre si on choisit le moteur Blender 
render, ce qui change la construction des 
matrial, on peut voir les materials dans 
cette fenêtre !!!??? 
 

• SIXIÈME PHASE : TRANSFORMATION DE L’AFFICHAGE DE L’OBJET DANS LA VIDÉO 
D’ABORD PanneauTimeLine > mettre le curseur au début 
PanneauVSE-Sequencer > BarreMenus > Menu = Add > Entrée =Effect Strip > SEntrée = Transform < Clic 
Résultat : Une Bande Verte foncée TRANSFORM s’affiche au dessus de l’ensemble sur toute la longueur 
PanneauN > Onglet = Strip > Paragraphe = Edit Strip > Case = Blend : < Alpha Over 
Résultat : la video apparait en transparence derrière l’objet Suzanne. 
PanneauN > Onglet = Strip > Paragraphe = Effect Strip > Uniform Scale < cocher 
PanneauN > Onglet = Strip > Paragraphe = Effect Strip >Case = Scale < 0.2 (par exemple : type Logo !) 

 Case = Position X < 41 ; Y < -36 (coin en bas à droite par exemple) 
 Case = Rotation < -14 (par exemple) 

Résultat : Une petite tête de Suzanne est affichée tout au long de la vidéo dans le coin bas droit. Ce qui peut 
être un LOGO 3D ou autre … 
 

20.12. RÉGLAGE POUR UNE PRODUCTION DU FILM 

D’ABORD PanneauProporties > BarreIcones > Icône = Render < clcik 
PUIS  PanneauRender > Paragraphe = Dimension > Case = Résolution > X=1920px ; Y = 1080 px  
  > Case = pourcentage < 100% 
Remarque : le réglage du format ici 1920 x 1080 correspond en général à celui de l’enregistrement visualisé dans 
VLC- Vérifier aussi que les Cases Start Frame et End Frame correspondent à celles indiquées dans Panneau 
TimeLine. 
PUIS  Paragraphe = OutPut > Case = « Dossier où le fichier sera enregistré » à choisir 
PUIS  CaseFormatFichier = PNG (par défaut) à changer exemple : Colonne = Movie > Entrée = AVI JPEG 
PUIS  Case = Quality < 100% 
PUIS  Paragraphe = Sampling > Case = Render (32 par défault) à augmenter pour une meilleur qualité 
suivant la puissance du PC 
PUIS Paragraphe = Render > Bouton = Animation < Clic 
Résultat : Attendre la fin de la création, en cas d’oubli : Taper [Esc] pour sortir et recommencer 
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