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1. Machine

2. Bibliographie

¢ Ink Stitch: plateforme de design open source pour la broderie, basée sur une extension Inkscape

https://inkstitch.org/

&
ST inkstitch.org

e Blog découverte de la broderie machine et des logiciels gratuits existants http://lyogau.over-blog.co

m/

3. Installer Ink Stitch

e Page Ink Stitch https://inkstitch.org/

e Lien pour l'installation https://inkstitch.org/docs/install/

o Télécharger la version correspondante au systeme d'exploitation de l'ordinateur
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o Décompresser l'archive dans le répertoire "User Extensions" d'Inkscape (pour connaitre ce
répertoire, dans Inkscape, choisir Edit > Preferences > System)
o Redémarrer Inkscape, l'extension est accessible dans Extensions > Ink/Stitch
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e Qu suivre le tutorial : https://dutailly.net/IMG/pdf/d-inkscape-a-une-brodeuse a266.pdf

4. Préparation d'une broderie de texte
(lettrage Ink Stitch), et transfert a la
brodeuse

Ink Stitch incorpore un outil qui permet de composer un objet texte (suite de caracteres) préformaté et
adpaté a la broderie.

Outil Lettrage

Dans Extensions > Ink/Stitch > Lettrage :
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Création d'une chaine de caractéres Abcde dans un fichier .SVG :


https://dutailly.net/IMG/pdf/d-inkscape-a-une-brodeuse_a266.pdf
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1 7 Ink/Stitch Lettering

Résultat dans Inkscape :
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Création du motif de broderie

e Sélectionner l'objet lettrage

e Extensions > Ink/Stitch > Parametres

8 Embroidery Params - o X

Satin Column  Center-Walk Underlay Contour Underlay Zig-zag Underlay  Stroke
Inkscape objects
These settings will be applied to 13 objects.
- Disabling this tab will isable the following tab.

[ | B custom satin column
[ e sren
D Pull compensation

D Zig-zag spacing (peak-to-peak)

mm

i}

mm

Presets
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| o | inge ]| aepy

o Réglage Pull compensation et zig-zag spacing (respectivement Compensation de traction
et espacement du zig-zap). La compensation de traction est le réglage effectué pour compenser
l'inévitable traction ou rétrécissement de votre dessin, qui se produit lorsque le dessin est cousu.
C'est I'un des facteurs a prendre en compte si vous souhaitez que votre conception ait une finition
professionnelle.

o Possibilité d'ajouter un effet 3D en ajoutant des sous-couches (underlay) de broderie (fil
central, contour, ou sous-couche zig-zag)
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o Régler les parameétres voulus (une fenétre de preview affiche le film de la broderie), puis
cliquer sur Apply and quit

Simulation de la broderie

Sélectionner l'objet, et choisir Extensions > Ink/Stitch > Simuler pour visualiser |la progression de la
broderie dans une fenétre séparée.

Broder sur le .SVG

Sélectionner l'objet, et choisir Extensions > Ink/Stitch > Broder pour superposer la broderie sur l'objet
InkStitch.

Choisir le format de fichier .PES (compatible avec la brodeuse Brother PE770):

4 Broder X

Longueur de fusion (mm) 30
Masquer les autres calques
Format de fichier de sortie Format de broderie Brother (PES) e

Dossier

O Apercu en direct

Fermer
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Centrer l'objet sur la page

Il est important que le zéro machine se situe au centre de la page. Une astuce consiste a redimensionner la
'objet a broder. Pour cela, sélectionner I'objet ou les objets a broder, puis Fichier >

page en l'ajustant a
Propriétés du document, puis Ajuster la page au dessin ou a la sélection, et cocher Afficher Ta

bordure de 1a page pour vérifier:

oo P B B e B G

Orientation : ) Portrait ® Paysage
Dimensions personnalisées

Largeur: 9231824 Upité: mm |~

RIS

Hauteur: 119.75300

= Redimensionner la page au contenu...

Marge supérieure : |0.00000 g
Gauche:  0.00000 g Drojte: |0.00000 g
Bas: 0.00000 g
—% Ajuster la page au dessin ou a la sélection
Echelle
Echellex: ' 1.00000 S Echelley: |1.00000 2 Unités utilisateur par mm.

Bien que le SVG autorise le redimensionnement non uniforme,
il est recommandé de n'utiliser que le redimensionnement
uniforme dans Inkscape. Pour effectuer un redimensionnement
non uniforme, définissez directement la « zone de vue ».

 Zone de vue...

Arriére-plan
O Arriére-plan en damier

Couleur de fond :
Aordure

P @ afficher la bordure de page]
O Bordure au-dessus du dessin
Afficher une ombre de bordure
Couleur de la bordure : I
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Sauvegarder le fichier .SVG

Pour pouvoir le modifier a nouveau ultérieurement

Exporter le fichier au format .PES

Fichier > Enregistrer Sous , et choisir le format Ink/Stitch Format de broderie Brother (.PES).

@ Abcde.SVG.svg — Inkscape

4@ Sélectionner le fichier dans lequ

Enregi dans - doc

| enreqistrer

*

Accés rapide

Bureau Abcde.SVi

m
Bibliotheques

>

Ce PC

| @

Réseau

Nom du fichier :

Type

TitreA -

SVG Inkscape (*.svg)
SVG simple (*.svg)

SVG Inkscape compressé (*.svgz)

SVG simple compressé (*.svgz)

Portable Document Format (* pdf)

Cairo PNG (*.png)

PostScript (* ps)

PostScript encapsulé (*.eps)

Métafichier amélioré (*.emf)

Métafichier Windows (*.wmf)

PovRay (*.pov) (chemins et formes seulement)

JavaFX (*.fx)

Dessin OpenDocument (*.odg)

LaTeX avec des macros PSTricks (*.tex)

Ink/Stitch: Format de broderie de Tajima (.dst)
Ink/Stitch: Format de broderie Melco (.exp)

Ink/Stitch: Format de broderie Janome ( jef)

Ink/Stitch: Format de broderie Brother (pe

Ink/Stitch: Format de broderie Brother ( pes)

Ink/Stitch: Format G-code (.ixt)

Ink/Stitch: Format de broder Barudan (.u01)

Ink/Stitch: Format de broderie Pfaff (vp3)

Ink/Stitch - ZIP exporter plusieurs formats (.zip)

Table tragante ou coupante (AutoCAD DXF R14) (*.dxf)
Palette GIMP (*.gpl)

Fichier HP Graphics Language (*-hpgl)

Canevas HTML 5 (*.html)

Exportation Jessylnk PDF ou PNG compressée (*.zip)
Fichier HP Graphics Language pour table tracante (* plt)
SVG optimisé (*.svg)

v

SVG Inkscape (*.svg)

hd |

Enregistrer

Annuler

(facultatif) Exporter au format .TXT (Gcode)

Fichier > Enregistrer Sous , et choisir le format Ink/Stitch Format G-code (.TXT).

Pour pouvoir relire la broderie dans un simulateur de fichier GCODE. Le fichier .TXT est lisible.

par exemple : https://nraynaud.github.io/webgcode/

Copie sur une clé USB pour transfert dans la brodeuse

Il est recommandé de créer un répertoire spécifique au fichier a broder. En effet, I'écran de la brodeuse ne
dispose pas d'une prévisualisation permettant d'identifier le fichier, et n'affiche pas les noms des fichiers

(mais les noms de répertoire) :

oo 0/15.3GB

= = n
| @- | fichiers-pal | paloma6
E— o

EIEE
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5. Broderie d'un contour

Prenons par exemple la broderie du contour rectangle (encadré).
Création du fichier SVG

e Ajout d'un rectangle 6cm par 4cm:

o contour en noir, épaisseur 2mm (fixe la largeur de la broderie)
o fond vide
e (Centrage de |'objet sur la page
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Conversion Objet en chemin
Sélectionner l'objet, puis chemin > objet en chemin

Convertir Ligne en Satin

Cette conversion va permettre de créer un objet Ink/Stitch a partir d'un chemin Inkscape (Path). L'objet
Ink/Stitch sera alors brodable (embroidable).

Sélectionner l'objet puis Extensions > Ink/Stitch > outils de satin > Convertir ligne en satin.
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Et on obtient I'objet Ink/Stitch, composé de succession de segments brodables (départ, rectangle brodable,
fin) :
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Paramétrage de la broderie

Toujours via Extensions > Ink/Stitch > Paramétres
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[ Embroidery Params - O X

Satin Column  Center-Walk Underlay Contour Underlay Zig-zag Underlay Stroke
Inkscape objects

These settings will be applied to 13 objects.
» Disabling this tab will disable the following tab.
« Enabling this tab will disable Stroke and vice-versa.

D Custom satin column

D "E" stitch O
I:‘ Pull compensation mm
I:‘ Zig-zag spacing (peak-to-peak) mm

Presets

e Régler pull compensation (défaut 0.2mm), zig-zag spacing (défaut 0.4mm), la sous-couche de
broderie éventuelle (pour un effet 3D (broderie en épaisseur).
e Cliquer sur Apply and quit

1 Embroidery Params - o x u W Preview

Satin Column  Center-Walk Underlay Contour Underlay  Zig-zag Underlay  Stroke
Inkscape objects
These settings will be applied to 1 object.

& Dzig-zag underiay

P —
[ momgmcngouttorets [ ] mm

Simuler la broderie
Pour vérifier : Extensions > Ink/Stitch > Simuler

Superposer la broderie

Sur le SVG: Extensions > Ink/Stitch > Broder
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Sauvegarder le fichier .SVG
Pour pouvoir le modifier a nouveau ultérieurement

Exporter le fichier au format .PES

Fichier > Enregistrer Sous , et choisir le format Ink/Stitch Format de broderie Brother (.PES).

@

Q Sélectionner le fichier dans lequel enregistrer X
SVG Inkscape (*.svg) A~

SVG simple (*.svg)
- d
Enregi dans: TSVG Inkscape compressé (* svgz)

- SVG simple compressé (*.svgz)
i Portable Document Format (*.pdf)
Accés rapide

Cairo PNG (*.png)
PostScript (* ps)
PostScript encapsulé (*.eps)
Métafichier amélioré (*.emf)
- @ Métafichier Windows (*.wmf)
PovRay (*.pov) (chemins et formes seulement)
Abcde.Sv@avarX (i)
« Dessin OpenDocument (*.odg)
m LaTeX avec des macros PSTricks (*.tex)
Ink/Stitch: Format de broderie de Tajima (.dst)
Bibliotheques Ink/Stitch: Format de broderie Melco (.exp)
Ink/Stitch: Format de broderie Janome ( jef)

Q Ink/Stitch: Format de broderie Brother ( pe
=z Ink/Stitch: Format de broderie Brother (pes)

Bureau

Ce PC Ink/Stitch: Format G-code ( txt)
Ink/Stitch: Format de broder Barudan (.u01)
q ol Ink/Stitch: Format de broderie Pfaff (.vp3)
] & Ink/Stitch : ZIP exporter plusieurs formats ( zip)
Réseau Table tragante ou coupante (AutoCAD DXF R14) (*.dxf)

Palette GIMP (*.gpl)

Fichier HP Graphics Language (* hpgl)

Canevas HTML 5 (*.html)

Exportation Jessylnk PDF ou PNG compressée (* zip)

Nom du fichier - Fichier HP Graphics Language pour table tracante (*.plt) Enregistrer
SVG optimisé (*.svg) hd

Type SVG Inkscape (* svg) ~ | Annuler

TitreA - ‘ ‘

(facultatif) Exporter au format .TXT (Gcode)

Fichier > Enregistrer Sous , et choisir le format Ink/Stitch Format G-code (.TXT).

Pour pouvoir relire la broderie dans un simulateur de fichier GCODE. Le fichier .TXT est lisible.
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par exemple : https://nraynaud.github.io/webgcode/

Copie sur une clé USB pour transfert dans la brodeuse

Il est recommandé de créer un répertoire spécifique au fichier a broder. En effet, I'écran de la brodeuse ne
dispose pas d'une prévisualisation permettant d'identifier le fichier, et n'affiche pas les noms des fichiers

(mais les noms de répertoire) :

o 0/15,368 =

— ( = ==
| [ fihiors-pal | palomss
S !

SIElE

Voici le résultat de la broderie en fil doré :

Cas d'une ligne ou d'un contour qui se croise

e Lorsque le contour se croise (existence de points multiples), il est possible que la conversion du chemin
(objet Inkscape) en objet Satin (objet Ink/Stitch) conduise a une erreur. Par exemple :
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e Une solution consiste a découper la ligne en autant de segments sans point multiple que nécessaire : On
utuilise pour cela l'outil Editer Tes noeuds ou les poignées de contrdle d'un chemin pour Briser
Te chemin aux noeuds sélectionnés (quitte a Insérer de nouveaux noeuds de facon a ne pas briser
la courbure du chemin)

@ gamma.svg — Inkscape @ gamma_coupure.svg — Inkscape
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e La conversion en satin ne pose alors plus de probléme, ainsi que la création de la broderie :
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6. Broderie d'un objet (remplissage)

Cette partie s'intéresse a la broderie du remplissage d'un objet (intérieur d'un contour).

Dessinons un rectangle de taille 6cm X 4cm, contour vide, remplissage uni (rouge), centré sur la page
(important pour le repére machine)
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Convertir l'objet en chemin

Chemin > Objet en chemin

Parametres de la broderie

e Sélectionner l'objet Rectangle

e Extensions > Ink/Stitch > PArametres permet de régler les parameétres de remplissage par la
brodeuse:

angle of lines of stitches (angle des lignes de couture)

maximum fill stitch length (longueur maximum entre deux points)
spacing between rows (espacement de deux lignes)

etc...

O O O O


af://n267
af://n272
af://n274

B3 Embroidery Params o X 4 81 Preview

AutoFill  AutoFill Underlay ~Fill

=
I::: :m::::ill be applied to 1 object, % /
Enaling sl ol il il and st %
L [ Automatically routed fill stitching /
.

/ Angle of lines of stitches

A\

\\\\\\\\\\\\

[ Expand

Maximun fill stitch length

Spacing between rows

‘ Running stitch length (traversal between sections)

\\\\\\\\\\\\\

Skip last stitch in each row

‘ Stagger rows this many times before repeating

Underpath
Presets

Load | add | overwite Delete "
= S < =
_ Concel || Use Lot etings | ApplyandQut | |G, 247 sschesiec STITCH

e C(Cliquer sur Apply and quit

mﬂmﬂiiﬂi
3 8
\
A\

g

Simuler
Extensions > Ink/stitch > Simuler pour visualiser le déroulement de la broderie

Broder

Extensions > Ink/Stitch > Broder pour superposer un objet brodable a |'objet SVG (au rectangle)
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Enregistrer le SV
Pou pouvoir mdifier ultérieurement

Exporter au format PES

Pour le transférer via clé USB a la brodeuse.

7. Cas du remplissage de lettres

Cette partie illustre des exemples de remplissages de caractéres.
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e |es contours des lettres présentent souvent des points multiples, ce qui empéche leur conversion en
satin (a moins de retravailler manuellement pour séparer en contours sans point multiple)

e |es intérieurs sont eux bien pris en compte par la commande Broder de I'extension Ink/Stitch
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e il est possible qu'Inkscape rencontre des problémes pour certaines polices.

o Par exemple, le caractere "&" en police Stencil, aprées conversion en chemin, ne permet pas a la
commande Extensions > Ink/Stitch > Broder d'aboutir:

— Format de fichier de sortie Format di
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Dossier
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‘e L | O Apercu en direct
(] | * x

Inkscape a recu des données additionnelles du script
¥ exécuté. Le script n'a pas retourné d'erreur, mais ceci
peut indiquer que les résultats ne sont pas ceux attendus.

path4875: error: shape is not valid. This can happen if the
border crosses over itself. v

Valider

o Une solution consiste a dissocier chacun des morceaux de I'objet Inkscape, avant de les
sélectionner tous et de leur appliquer la commande Broder :

= Superposer un rectangle a l'objet Police

En faire I'intersection chemin>Intersection

Dissocier les élements de l'objet créé : chemin>Dissocier
Sélectionner tous les sous objets ainsi séparés (4 morceaux ici), et lancer la commande
Extensions>Ink/stitch>Broder, apres avoir régler les parametres si besoin
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o Autre exemple en police Laserian (de type Stencil):
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1. Objet Inkscape de type Police

2. Superposition avec un rectangle

3. Intersection (rectangle et police)

4. Séparation des objets

5. Paramétrage et commande InksStitch>Broder
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